none
DPM 2012 getting strange errors in event log "The shadow copy storage has been exhausted." followed by ntfs disk errors? RRS feed

  • Question

  • Hello,

    I have recently switched from DPM 2010 to DPM 2012, in the process I also re-created all my backup staging in DPM (deleted protection job and associated volumes). Now in DPM 2012 I get these errors in order:

    There was insufficient disk space on volume C:\...febc-4db9-9745-a30b7bcebea8 to grow the shadow copy storage for shadow copies of C:\...febc-4db9-9745-a30b7bcebea8.  As a result of this failure all shadow copies of volume C:\...febc-4db9-9745-a30b7bcebea8 are at risk of being deleted.

    Volume C:\...PM\DPM\Volumes\Replica\Non VSS Datasource Writer\vol_8642c7fe-febc-4db9-9745-a30b7bcebea8 is offline for shadow copy protection.  The shadow copy storage has been exhausted.  Please try clearing the protection fault or restart the computer followed by an increase of the shadow copy storage or a removal of unneeded shadow copies.  If all else fails, revert out of shadow copy protection mode to reclaim the use of the volume while losing the shadow copies.

    The system failed to flush data to the transaction log. Corruption may occur. When I get the "volsnap" errors, they are always followed by ntfs errors, only then do the ntfs error shown up.

    I found a MS KB that has a hotfix for the volsnap issue, but I am not sure if this 100% applies to me/DPM. Here is the link: http://support.microsoft.com/kb/983633/en-us

    Similar issue has been reported here for DPM 2007: http://social.technet.microsoft.com/Forums/en-US/dpmstorage/thread/edf930b1-cb3b-460b-8ded-f97a7feb1801

    Could this be a bug in DPM? My storage pool which is a SAN is healthy as reported by the SAN utilities.

    Any idea on what I can do?

    Thursday, November 22, 2012 3:11 PM

Answers

  • Hi,

    Apparently DPM could not grow the recovery point volume in time based on the change rate of the data being written to the replica volume.  Either that or auto-grow is not enabled for that datasource.  As a consequence, Windows volume shadow copy service placed the replica volume in shadow copy protection mode to prevent recovery point loss. Simply add more space to the recovery point volume for that data source then reboot and that should bring that replica out of shadow copy protection mode and then run a CC.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, November 23, 2012 3:47 AM
    Moderator