locked
Change published FQDN for Server 2016 RDS Deployment RRS feed

  • Question

  • Hi,


    I have read the various discussions that relate to this:  https://gallery.technet.microsoft.com/Change-published-FQDN-for-2a029b80

    However, it does not have 2016 listed.  I tried it anyway, and it did not work..

    Any updates to that script?

    Thanks

    Thursday, August 31, 2017 8:21 PM

Answers

  • Reboot did NOT work, but I was poking around IIS and saw that the default website was a redirect to RD.INSIDE.DOMAIN.COM.  Change that to RD.DOMAIN.COM, and that got it working..

    Can't launch any applications, but that is a new problem.. :)

    • Marked as answer by ML28 Thursday, August 31, 2017 10:23 PM
    Thursday, August 31, 2017 10:23 PM

All replies

  • It does work in 2016 though. Are you testing internally or from the outside?  Internally will require some further consideration (DNS).

    • Edited by rseiler Thursday, August 31, 2017 9:13 PM
    Thursday, August 31, 2017 9:00 PM
  • I have internal DNS for the same URL.. 

    tested outside, and inside.  No love.

    Script runs, says it worked, but even the "Deployment Properties" still list the old URL in the RD Web Access tab.


    Also:  from the inside, when I test with the new URL, it redirects me to the old one..  Indicating the old URL is still being used.
    • Edited by ML28 Thursday, August 31, 2017 9:18 PM
    Thursday, August 31, 2017 9:16 PM
  • Yes, it doesn't change in the RDS Overview. Everything in Deployment Servers there, for example, is the original name, which is very misleading. This feature should have never been removed from the UI in the first place.

    I'll try to recall where it is in the Registry this turns up so that you can check.

    Did you reboot afterwards?  I don't recall if that's needed though. If you're using RemoteApps, be sure to refresh the feed.

    I don't quite understand how a redirect would be happening. I've never seen that.

    Thursday, August 31, 2017 9:31 PM
  • OK, going to try to reboot the web and broker servers and see if that helps..

    BTW, I have the same behavior inside and out-  If I go to "RD.DOMAIN.COM", it redirects to "RD.INSIDE.DOMAIN.COM"..  Of course, that does not resolve when I am outside!

    Thursday, August 31, 2017 10:14 PM
  • Reboot did NOT work, but I was poking around IIS and saw that the default website was a redirect to RD.INSIDE.DOMAIN.COM.  Change that to RD.DOMAIN.COM, and that got it working..

    Can't launch any applications, but that is a new problem.. :)

    • Marked as answer by ML28 Thursday, August 31, 2017 10:23 PM
    Thursday, August 31, 2017 10:23 PM
  • Were you able to get this working? I have the same issue. I wanted to change the published web URL to something to more customize URL that users will understand and know the difference for each environment that is created. 

    Sakai T

    Thursday, September 6, 2018 3:00 PM
  • That tool worked for us with 2016 (despite not mentioning 2016 in the description), so short of that redirect thing ML28 ultimately found, which is a separate problem, it should work for you too.
    Thursday, September 6, 2018 3:34 PM