none
Published sharepoint app incorrect redirection RRS feed

  • Question

  • Hi!

    I'm trying to publish sharepoint 2010 application with UAG and get some trouble. I configured app in UAG according to documentation, configured AAM in sharepoint and when I access published app with it public hostname (https://sps.mydomain.com) after authentication I'm redirected to error page "You are not authorized to access this application".

    Web monitor registers the error: "A request on trunk uag; Secure=1 failed because of an unknown application. The URL is /main/Pages/HomePage.aspx. The source IP address is X.X.X.X. The user is XXXXX"

    My configs are:

    Internal sharepoint application: http://sps, fqdn: sps.domain.local

    Public host name: sps.mydomain.com

    Sharepoint AAM:

    1. http://sps - Default - http://sps

    2. https://sps.mydomain.com - Internet - https://sps.mydomain.com

    3. http://sps.domain.local - Internet - https://sps.mydomain.com

     

    Network monitor on UAG shows '302 Moved temporarily' sharepoint server answer to URL Location: http://sps.mydomain.com/main/Pages/HomePage.aspx - I think this is the cause of error - there should be either https://sps.mydomain.com... or http://sps.domain.local...  

    But why sharepoint redirects to public address with incorrect protocol? Is this incorrect AAM settings? Or something wrong in sharepoint? (I'm not good with sharepoint).

    Wednesday, February 1, 2012 11:05 AM

Answers

  • Well, I was wrong with AAM settings - rule 3 from previous post should be:

    3. http://sps.mydomain.com - Internet - https://sps.mydomain.com

     

    • Marked as answer by Roman Annenko Wednesday, February 1, 2012 6:30 PM
    Wednesday, February 1, 2012 6:30 PM