locked
KB2807986 RRS feed

  • Question

  • KB2807986 will not install under Windows Vista Home Premium SP2.  I've tried every solution I could find on various Microsoft tech forums, but I have been unable to find someone with the identical problem:

    The Windows update "Security Update for Windows (KB2807986)" could not be installed because of an error: 2147942432 "The process cannot access the file because it is being used by another process." (Command line: ""C:\Windows\system32\wusa.exe"  C:\[omitted]\Windows6.0-KB2807986-x86.msu")

    And the full XML file from the log:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-WUSA" Guid="[omitted]" />
        <EventID>3</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2013-08-01T17:49:07.863Z" />
        <EventRecordID>15</EventRecordID>
        <Correlation />
        <Execution ProcessID="1440" ThreadID="1280" />
        <Channel>Setup</Channel>
        <Computer>RAC-PC</Computer>
        <Security UserID="[omitted]" />
      </System>
      <EventData>
        <Data Name="UpdateTitle">"Security Update for Windows (KB2807986)"</Data>
        <Data Name="ErrorCode">2147942432</Data>
        <Data Name="ErrorString">The process cannot access the file because it is being used by another process.</Data>
        <Data Name="CommandLine">"C:\Windows\system32\wusa.exe" C:\[omitted]\Desktop\Windows6.0-KB2807986-x86.msu</Data>
      </EventData>
    </Event>

    I'm at my wit's end trying to get this resolved.  I'm not sure how to determine which file in particular it is complaining about to troubleshoot further on my own.  I've tried disabling everything on startup except for processes from Microsoft, but no luck.  I've attempted to disable services and kill processes one at a time until it works, also to no avail. 

    Help is appreciated.  This was on a client's machine after removing a few malware and virus infections, and the machine appears to be clean now.  All updates install except this one. 

    Thursday, August 1, 2013 6:14 PM