none
HTM file forces download RRS feed

  • Question

  • I am having issues with my users accessing a htm file in IE versions 9 and up. Currently users are accessing emails through OWA 2010 and receive a link to a htm file. The issues is they are being forced to download the link rather than simply opening it. The files are being saved to random locations and contain sensitive information. I have set the Exchange server to allow the .htm extension to open rather than force saving. The function works in Firefox, IE 6, IE 7 and IE8. In Chrome, IE 9 and IE 10, the browser forces a download, which seems to be a security issues within the browser. I have set the site to the lowest security but still no progress. Any suggestions?

    Thanks,

    AJ

    Friday, November 8, 2013 4:08 PM

All replies

  • Hi,

    review the mime-types supported on your servers....

    emails use the message/rfc822

    files with extensions html, htm, aspx, jsp etc are text/html

    use GPO to prevent users installing other browsers that can hijack the file associations.


    Rob^_^

    Friday, November 8, 2013 11:55 PM
  • Hi,

    Except for Rob's suggestions, you can attempt to reset Internet Explorer settings first.

    Or please try run IE in No Add-on mode to check if this issue occurs.

    Thanks!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Monday, November 11, 2013 4:10 PM
    Moderator
  • Hi,

    review the mime-types supported on your servers....

    emails use the message/rfc822

    files with extensions html, htm, aspx, jsp etc are text/html

    use GPO to prevent users installing other browsers that can hijack the file associations.


    Rob^_^

    The MIME type is supported for text/html. Direct file access on the exchange server are set to allow the opening of the mime text/html without saving. Is there a security setting with IE9 and 10 that would prevent users from being able to Open rather than having to Save? I would have to roll all users back to IE8 in order for this to work..

    -AJ

    Tuesday, November 12, 2013 4:23 PM
  • I have reset the IE setting and ran with no add-ons. I am still unable to open the file without saving first.

    Thanks,

    AJ

    Tuesday, November 12, 2013 4:26 PM
  • Hi,

    First, please make sure you have associated the htm file with Internet Explorer. So locate to Control Panel>Default Programs>Associate a file type or protocol with a program.

    Additionally, please check the two parameters, AllowedFileTypes and ForceSaveFileTypes in exchange server.

    Set-OwaMailboxPolicy

    http://technet.microsoft.com/en-us/library/dd297989(v=exchg.141).aspx

    Thanks!


    Andy Altmann
    TechNet Community Support

    Wednesday, November 20, 2013 5:25 PM
    Moderator
  • .htm is set to default program of Internet Explorer. Exchange has .htm set to allowfiletypes. See below

    [PS] C:\Windows\system32>get-owamailboxpolicy | select -expandproperty allowedfi
    letypes
    .rpmsg
    .xlsx
    .xlsm
    .xlsb
    .tiff
    .pptx
    .pptm
    .ppsx
    .ppsm
    .docx
    .docm
    .zip
    .xls
    .wmv
    .wma
    .wav
    .vsd
    .txt
    .tif
    .rtf
    .pub
    .ppt
    .png
    .pdf
    .one
    .mp3
    .jpg
    .htm
    .gif
    .doc
    .bmp
    .avi
    [PS] C:\Windows\system32>

    Only IE9 and up will not allow the .htm file to open. IE8 and firefox will.

    Thanks,

    AJ

    Wednesday, November 20, 2013 8:37 PM