locked
Testing for broken tables RRS feed

  • General discussion

  • One of the Moderators in the Office IT Pro forums is breaking the tables with HTML code... I am just trying to find out how. Please ignore these posts.

     

    Hi,

    This sounds like a problem with the file associations in Windows. The first thing to try is to force Excel to reconstruct all the proper association information. You do that by following these steps:

    1. Make sure that Excel is not running (exit the program).
    2. Click the Start button to displays the Start menu.
    3. From the Start menu, choose Run. Windows displays the Run dialog box.
    4. In the Open box, enter the full path name to your Excel program, followed by the /regserver switch. If the full path name includes spaces, surround the full path name by quote marks. The following is an example of what you can enter in the Open box (your path may be different):
    "c:\Program Files\Microsoft Office\Office\Excel.exe" /regserver 

    Click OK.

    If you still cannot double-click on a workbook to open it, try these steps:

    1. Get out of Excel completely.
    2. Open a My Computer window.
    3. Choose Tool | Folder Options. You should see the Folder Options dialog box.
    4. Make sure the File Types tab is displayed.
    5. In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).
    6. Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.
    7. In the list of actions, choose Open.
    8. Click the Edit button. Windows displays the Editing Action dialog box.
    9. The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.
    10. Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following:
     [open("%1")]
    

    Click on OK and Close all the other open dialog boxes.

    Tuesday, November 16, 2010 2:17 PM

All replies

  • Original code:

    <p>Hi,</p>
    <p>This sounds like a problem with the file associations in Windows. The first thing to try is to force Excel to reconstruct all the proper association information. You do that by following these steps:</p>
    <ol>
    <li>Make sure that Excel is not running (exit the program). </li><li>Click the Start button to displays the Start menu. </li><li>From the Start menu, choose Run. Windows displays the Run dialog box. </li><li>In the Open box, enter the full path name to your Excel program, followed by the /regserver switch. If the full path name includes spaces, surround the full path name by quote marks. The following is an example of what you can enter in the Open box (your
     path may be different): </li></ol>
    <pre>&quot;c:\Program Files\Microsoft Office\Office\Excel.exe&quot; /regserver </pre>
    <li>Click OK.    ----->Used a list tag without an ol or ul tag
    <p>If you still cannot double-click on a workbook to open it, try these steps:</p>
    <ol>
    <li>Get out of Excel completely. </li><li>Open a My Computer window. </li><li>Choose Tool | Folder Options. You should see the Folder Options dialog box. </li><li>Make sure the File Types tab is displayed. </li><li>In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).
    </li><li>Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.
    </li><li>In the list of actions, choose Open. </li><li>Click the Edit button. Windows displays the Editing Action dialog box. </li><li>The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.
    </li><li>Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following:
    </li></ol>
    <pre>  [open(&quot;%1&quot;)]
    </pre>
    <p>Click on OK and Close all the other open dialog boxes.</p>
    </li>  ------> Ending list tag with no open list tag

     

    Improper use of list tags is apparently the issue... Thanks for the sandbox to be able to test this out. And just to show you what I meant, I'll use the next post for the original code in HTML.

    Tuesday, November 16, 2010 2:25 PM
  • Hi,

    This sounds like a problem with the file associations in Windows. The first thing to try is to force Excel to reconstruct all the proper association information. You do that by following these steps:

    1. Make sure that Excel is not running (exit the program).
    2. Click the Start button to displays the Start menu.
    3. From the Start menu, choose Run. Windows displays the Run dialog box.
    4. In the Open box, enter the full path name to your Excel program, followed by the /regserver switch. If the full path name includes spaces, surround the full path name by quote marks. The following is an example of what you can enter in the Open box (your path may be different):
    "c:\Program Files\Microsoft Office\Office\Excel.exe" /regserver 
  • Click OK.

    If you still cannot double-click on a workbook to open it, try these steps:

    1. Get out of Excel completely.
    2. Open a My Computer window.
    3. Choose Tool | Folder Options. You should see the Folder Options dialog box.
    4. Make sure the File Types tab is displayed.
    5. In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).
    6. Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.
    7. In the list of actions, choose Open.
    8. Click the Edit button. Windows displays the Editing Action dialog box.
    9. The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.
    10. Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following:
     [open("%1")]
    

    Click on OK and Close all the other open dialog boxes.

Tuesday, November 16, 2010 2:27 PM