none
WDS Access denied RRS feed

  • Question

  • To start with I'd like to say that I am not a member of Domain Admins nor have ever been.

    About a year and a half ago I built a Windows 2008 server R2 machine.   It has been used for a variety of things.   Last spring I installed the WDS component so that I could use PXE boot on our network.  A couple months ago I started playing around with deploying images and generally just trying to learn the WDS functions.  Then last week we started to implement SCCM 2012 on our network.  Last friday I went into the WDS to turn off the PXE boot and when I try to make changes to the service I get a dialog box saying Access Denied.

    Any thoughts as to why I can no longer control the WDS?  Any thoughts or comments are greatly appreciated.

    WD

    Thursday, November 22, 2012 5:09 PM

All replies

  • Hi,

    Towards the OS deployment in organization, Microsoft provides three resolutions:

    1. Windows Deployment Services;

    2. Microsoft Deployment Toolkit;

    3. System Center Configuration Manager;

    SCCM provide the most powerful functions to deal with the OS and software deployment in your organzation.

    From your description, you mentioned that WDS is no longer controlled. You mean the WDS console can't be opened? Please share a snapshot here. Since you are using SCCM 2012 in your network, does any client reporting OS installation via network issue?

    The issue began when you tried to make changes to the service, which service is being modified? Have you tried to revert back the setting fo this specific service?

    Please run the following command in Windows PowerShell with evaluated rights:

    Get-Service | Where-Object {$_.name -like "*WDS*"}

    Of couse, take a look in Event Viewer, please feel free to post back your findings.

    Regards,

    James


    James Xiong

    TechNet Community Support

    Monday, November 26, 2012 2:50 AM
    Moderator
  • Hi there;

    I need to be able to disable the PXE boot on the WDS server so that we can enable the PXE boot on the SCCM distribution point.   This is what I get when I try to do that.

    Keep in mind that I built this WDS server and was using it to learn the deployment features.   I even managed to deploy a couple of operating systems with it .  Suddenly I have lost control of the WDS.   I would simply unplug the machine from the network except that the machine is performing a couple of extra functions.  I can find nothing relevent in the Event Viewer.

    When I ran the command suggested by James I get the following:

    Status   Name               DisplayName
    ------   ----               -----------
    Running  WDSServer          Windows Deployment Services Server

    Wednesday, December 5, 2012 7:01 PM
  • This doesn't exactly answer your question, but if you no longer need WDS on this server, why not instead of trying to disable PXE, you simply remove the WDS role from the server?
    Wednesday, December 5, 2012 11:59 PM
  • That is a solution, however I was hoping to keep the WDS functional till we have figured out the SCCM stuff.  Fortunately I figured out that I could simply stop the WDS server and that disables the PXE.  Now if I need it I can simply go in and restart the WDS without having to reinstall it.

    Thanks all for your help.

    WD

    • Proposed as answer by Mb1245 Monday, December 10, 2012 7:46 PM
    Thursday, December 6, 2012 7:07 PM