locked
Vista not seeing 2nd CPU on Dual Core Pentium D 945 RRS feed

  • Question

  • I'm using Vista Business.  I used the Business Upgrade disk to to a fresh install.  I noticed that the Device mgr saw both processors, but Task mgr did not.  This was confirmed using a Sidebar gadget.  I tried upgrading the built in HAL from ACPI x86 to the Advanced one to no avail.  I have NOT activated the install yet as I'm still playing around with it.

    I have tried searching the net for an answer and all I see is others with similar problem.  It appears a format and reinstall did not fix their problem.  I'm trying to avoid this and see if there is an easier way.  Can someone point me in the right direction?

    Friday, February 9, 2007 7:18 PM

All replies

  • I was able to resolve the problem on my own.  It turns out that XP also had the same symptoms after a fresh reload.  This narrowed the problem down to the mobo.  I have the Asus P5RD2-VM.  ATI Xpress 200 chipset.  I have the latest bios 0903.  After checking out the BIOS, I soon discovered that my Hyperthreading was disabled.  I could not remember if I had changed this feature.  I had nothing to lose, so I enabled the feature.  As you may already know the PD 945 does not have the HT feature.  Therefore, whether or not this BIOS feature was enabled or not shouldn't have mattered.  To my surprise it did.  XP was now able to see the 2nd CPU in Task Mgr.  After the Vista Business upgrade, the same was true.

    This leads me to believe the problem is with the BIOS and how it communicates to the OS, specifically Task Mgr.  I've also learned that TM is not a reliable information source on how many CPUs are in the computer.

    Hope this info will be useful to someone else.

    Wednesday, February 14, 2007 8:05 PM