Windows 8 does not go to sleep - how to identify the device/app preventing sleep


  • Hello,

    I have a quite new Windows 8 Pro installation upgraded from Windows 7, but as a clean install. It is running on a Asus K53E laptop bought almost a year ago but I ran into a problem with going to standby mode. The laptop successfully dims the display and then turns it off at the set time but it never reaches the sleep mode.

    I followed the steps from but to no avail. The command Powercfg - devicequery wake_armed shows only keyboard and mouse but I don't suspect the mouse as it is Microsoft Wireless Mouse and I turn it off before trying to induce sleep. I have made sure to turn off iTunes media sharing and Windows Media Player Network Sharing service. The drivers are from Microsoft or the newest I could get from Asus.

    The command Powercfg -energy showed some errors - mostly with USB devices/hubs and with one of the system drivers:

    System Availability Requests:System Required Request
    The device or driver has made a request to prevent the system from automatically entering sleep.
    Driver Name \FileSystem\srvnet

    I rather suspect some incompatible driver but to press Asus support for some update I would need to know what to blame. I reviewed system logs in Event Viewer but can't find any useful entries around the time when the computer should go to sleep, but there are so many logs that I might have missed the right one. So my question is if somebody could introduce me to a tool that would help to pinpoint the problem.

    I see the subject is quite ubiquitous for Windows 7 so I would be grateful to anyone who could suggest any options other than mentioned above.

    Thanks in advance,


    Monday, November 05, 2012 9:46 PM


  • Thanks, I disabled defrag and it was the problem, sleep now works fine, I now just manually defrag monthly. My system is windows 8 on an HP Compaq CQ58. Cheers Don.
    Tuesday, May 13, 2014 6:38 AM

All replies

  • Hi,

    Please run the following command and see if it works:

    powercfg -requestsoverride driver \FileSystem\srvnet system

    For more details about the usage of Powercfg command”

    Powercfg Command-Line Options


    Nicholas Li

    TechNet Community Support

    Wednesday, November 07, 2012 7:05 AM
  • Please forgive me late answer.

    Unfortunately your suggestion made no effect to my problem. Could you possible offer any other path I could take to troubleshoot my issue?



    Thursday, November 15, 2012 12:01 PM
  • Hello Nicholas,

    Could you please notify person responsible for powercfg that the default behavior to save report HTML file to %systemroot%\system32 folder prevents from opening this report in browser?

    I ran the powercfg tool and it has given me with:

    Microsoft Windows [Version 6.2.9200]
    (c) 2012 Microsoft Corporation. All rights reserved.
    C:\Windows\system32> Powercfg -energy
    Enabling tracing for 60 seconds...
    Observing system behavior...
    Analyzing trace data...
    Analysis complete.
    Energy efficiency problems were found.
    8 Errors
    4 Warnings
    16 Informational
    See C:\Windows\system32\energy-report.html for more details.

    However, copying the path to HTML report and pasting into browser window results in:

    I suppose, this is because report is stored in the protected %systemroot% folder that prevents unelevated processes from accessing it.

    The workaround would be to copy the report file to an unprotected location such as My Documents and open it from there.

    Well this is the world we live in And these are the hands we're given...

    Thursday, November 15, 2012 2:33 PM
  • Hi,

    I have the same problem and I've tried a few of the easier solutions with no success.  There are a number of process-of-elimination chases that could be done, but it seems to me it should be fairly easy to directly address this problem. \FileSystem\srvnet seems like a pretty clear indicator of the problem, and there's got to be some way of querying this device/module/service/process directly to understand exactly why it's holding a suspend lock.



    Sunday, November 18, 2012 4:24 PM
  • hi i am newbie here and i have kind of same problem

    does your problem fix?if doesn't

    try to disable windows defrag schedule in right click My Computer-Manage-Computer management-system tools-task scheduler-task scheduler library-microsoft-windows-defrag

    may be it can help you :)

    Tuesday, November 20, 2012 1:05 AM
  • or you have been disable windos service "windows error reporting" ?
    Tuesday, November 20, 2012 1:12 AM
  • Hello,

    I am experiencing the same problem on Windows 8 RTM. Due to the \FileSystem\srvnet device driver, the system will not go to sleep. Unfortunately, the command

    powercfg.exe /requestsoverride driver \FileSystem\srvnet system

    does not work for me. Is there any other way to resolve this problem?

    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Sunday, December 02, 2012 8:43 AM
  • On Windows 8 did not worked for me:

     I've even left the homegroup, removed all media sharing (blocked), changed the property in power configuration to allow sleep while sharing media.


    No effect, PC does not sleep automatically. I have to press the sleep button (or choose it from the menu) every time. Super annoying


    Additional info: with Win 7 ultimate everything was fine. I did a fresh W8 installation and now I have the issue


    • Edited by m.savazzi Tuesday, December 04, 2012 10:07 AM
    Tuesday, December 04, 2012 10:06 AM
  • Just as a sanity check, can we confirm that disabling the network adapters allows the system to idle to sleep?



    Thursday, December 13, 2012 6:33 AM
  • Thanks for this idea - I'm definitely going to check when I find time to disable network adapters.
    • Proposed as answer by aircraft Sunday, December 15, 2013 8:52 AM
    • Unproposed as answer by aircraft Sunday, December 15, 2013 8:52 AM
    Friday, December 14, 2012 5:34 AM
  • I am suffering from the same "PC Insomnia" as the others here, since installing Windows 8 (it was a clean install, freshly formatted system). Tried the

    powercfg -requestsoverride DRIVER \FileSystem\srvnet SYSTEM

    that others have mentioned but it seems to not have any effect. I do not want to disable WOL because that defeats the whole purpose of sleeping in the first place, I need to be able to wake up the PC via WOL, and this should not prevent it from sleeping. Is this a Win8 bug or ... ? I see tons of threads referencing the same \FileSystem\srvnet problems so I tend to think "no". Still seeking a solution that works.

    Wednesday, December 26, 2012 3:09 PM
  • Luke-

    If you have a chance, could you try to disable your network adapters from Device Manager?  Obviously, this would not be a viable workaround! :) However, it would help us figure out if this is an issue with A) the requestoverride not working or B) something else that is not on the energy report is keeping the compuer awake.

    Happy Holidays,


    Wednesday, December 26, 2012 7:36 PM
  • Hi John & Happy Holidays to you too!

    I spent the better part of the last 2 days working on figuring this out. Scoured the web & forums and tried literally everything, including disabling the Ethernet adapter as you suggested). It didn't seem to matter if I disabled the network adapter AFTER the bootup was complete and I was already seeing the sleep block request in powercfg -requests. At that point, disabling the adapter (or even unplugging the Ethernet cable) did not "fix" the problem, the machine still would not sleep after the scheduled timeout. I *do* think that it is somehow that the requestoverride was being ignored (not something else that wasn't showing up on the report) because after the fix below I don't see that "[DRIVER] \FileSystem\srvnet" in the powercfg -requests anymore and the PC is sleeping normally.

    Here's a list of the things I've tried that did NOT work -- this list is the most comprehensive I could put together:

    • Updated video card drivers (AMD in my case) to the latest version, as well as tried "rolling back" to the latest driver available via Windows Update
    • Tried a "clean boot" - disabling everything non-Microsoft using msconfig and rebooting
    • Ran a detailed energy report via powercfg -energy
    • Fiddled with my computer's BIOS settings related to S3 sleep
    • Tried adding the request override via powercfg -requestsoverride DRIVER \FileSystem\srvnet SYSTEM
    • Checked for active NETBIOS connections using nbtstat -s
    • Checked for general active TCP network connections & their associated PIDs using netstat -n -p TCP -o
    • in the Power Options control panel, made sure under Advanced > Multimedia settings that Allow the computer to sleep was enabled when sharing media
    • Made sure that the Wake-On-Lan settings for my Ethernet adapter were set for "Magic Packet" only and NOT "Pattern Match"
    • Checked Idle Timers (using freeware IdleClock) to make sure a faulty USB device (keyboard/mouse) wasn't keeping the computer awake
    • Made sure there were no ACPI Wake Timers set via powercfg -waketimers
    • checked Event Logs for anything relevant (Event IDs 42, 131 from Kernel-Power or Event ID 1 from Power-Troubleshooter)
    • fiddled with HomeGroup settings (joining & then leaving, or disabling the HomeGroupListener and HomeGroupProvider services entirely)
    • Tried disabling Hybrid Sleep
    • Completely disabled Media Streaming via Windows Media Player, and/or setting the WMPNetworkSvc service to disabled
    • Enabled the hidden "Allow Sleep with Remote Opens" power option via the following Registry edit:
    • Tried disabling the "Line In" audio device (see this thread)

    So after many hours of testing NONE of those things worked. I had seen some threads around suggesting the maybe it was related to IPv6, or some specific programs or services misbehaving with regards to IPv6 connections. I don't have a native IPv6 address but my home router (running an OpenWRT derivative called CeroWrt) does support 6in4 tunnels such as those provided by the Tunnelbroker service. And I was running one of those so my PC did get assigned a "real" IPv6 address via that tunnel. I decided to try shutting all of that down, and lo and behold that seems to have fixed things for now.

    I've been running for a few hours like this and have put the PC to sleep, woken it up, shut it down and restarted it several times to be sure. I think it's too soon to declare victory as there's a chance the problem will resurface, but for now it does seem likely that it's related to IPv6 somehow. How or why exactly remains a mystery to me, but if there's any further testing you'd like me to do I'm happy to oblige.

    • Edited by Luke Hamburg Wednesday, December 26, 2012 10:44 PM
    • Proposed as answer by Exotic Hadron Tuesday, January 22, 2013 3:04 PM
    Wednesday, December 26, 2012 10:44 PM
  • Awesome sleuthing, Luke!

    Just to confirm, which of these two was the case:

    1) "powercfg -requests" reported that DRIVER\FileSystem\srvnet was blocking sleep. However, "requetsoverride" didn't work when using IPv6.

    2) "powercfg -requests" didn't report anything, yet IPv6 was blocking sleep.

    Also, did you have both IPv6 and v4 addresses or just IPv6? Which NIC are you using and what driver version? I'm going to try to set up a repro on this and dig into the kernel debugger.

    Alternatively, if you could create a kernel dump (make sure you don't have any personal data open!) and share it on SkyDrive, I might be able to divine enough from that.  Make sure to set your dump type to "full" or "complete" as per



    Thursday, December 27, 2012 12:07 AM
  • John thanks again -- see below:

    • powercfg -requests was nearly always reporting that DRIVER\FileSystem\srvnet was blocking sleep, despite the fact that I had manually added the exclusion via powercfg -requestsoverride DRIVER \FileSystem\srvnet SYSTEM -- I don't know if it's normal for overridden drivers to still appear in the -requests output, so I can't say for sure if the override was simply being ignored, or if like you said it wasn't being applied to IPv6 connections. Either way, the override did not have the desired effect!
    • In my testing, whenever powercfg -requests reported no blockers, the system was able to sleep normally. The difficulty I had was exclusively related to srvnet and in all cases where the PC had "insomnia" I would find \FileSystem\srvnet in the -requests output.
    • A temporary workaround that I toyed around with prior to finding the IPv6 solution was to stop & then restart the srvnet service, which got rid of the blocking request. This forced the Computer Browser, Server, Server SMB Driver and Server SMB Driver services to stop (dependencies) and so these need to be restarted as well afterwards. So I made a simple batch file to handle all of this, attached this to Task Scheduler and had it running at Startup. This was working for a while but I found that at some point after using the machine for awhile, the srvnet driver would start blocking again. But it was worth noting that stopping & restarting it did "fix" the sleep problem at least temporarily.
    • The PC did have both IPv4 and IPv6 addresses during the testing, but I have since turned off radvd and shut down the 6in4 tunnel interface on the router here, so I am back to IPv4-only (I do still have the fe80:: link-local address though, as I have not disabled the IPv6 protocol on the Ethernet card itself)
    • Ethernet NIC is a motherboard-integrated Realtek 8168-based PCIe device - and I'm using Realtek NIC drivers as of this writing. The driver filename is "rt630x64.sys" and version is 8.7.1025.2012

    If you'd still like the memory dump I could generate one. This PC has 16GB of RAM, not sure if the dump file would be 16GB in size, but I suppose if most of the RAM was free that the file could be compressed quite a bit.

    Thursday, December 27, 2012 5:49 AM
  • Sure don't see how this qualifies an "Answer" though it is a great set of data.

    I've been troubleshooting a Win 8 insomniac and, while I certainly haven't tried everything Luke has, have been down a number of the same dead ends.

    I turned off IPV6 on mine. (Can't say what my router runs but it is one of the OpenWRT derivatives. To my knowledge, I'm not doing anything with IPV6 beyond the LAN. But my ignorance in that area is huge.) With IPV6 off the stack, there was no change. But booting with the net disabled makes for a very sleepy machine. Was just about to test the same thing just with the net disconnected and no other settings on the PC changed.

    Key thing of note: my insomniac is also a Realtek 8168 series NIC. I'm using the Microsoft Rt630x86.sys driver.

    It's most amazing to me that there have been power saving features in Windows for what, over 15 years now, and they are still the single LEAST RELIABLE feature in Windows. Just think how much extra CO2 has been released because Windows Power Save still doesn't...

    Friday, December 28, 2012 3:57 AM
  • I am sorry to say that after another 24 hours, I have to retract some of my above assertions. Apparently having an assigned IPv6 was *not* the root cause of the srvnet activity. I noticed today that the "[DRIVER] \FileSystem\srvnet" was appearing again in the powercfg -requests output. However, in spite of that the PC was still going to sleep after my specified 30 minute timer. So maybe the override *WAS* working after all. It most definitely wasn't working a couple of days ago. So I don't know if today I was just "lucky" or if some of the fiddling that I had listed above made some actual difference.

    At this point what I really want to be able to figure out is WHAT is behind those "An active remote client has recently sent requests to this machine" statements!

    • WHAT remote client? What was it's IP address? What resource did it try to access? How can more detail be gleaned.
    • What does "recently" mean - 5 seconds ago? 5 minutes? 30 minutes? It would be helpful to know precisely when this activity occurred.

    Does anyone know how to debug further -- getting under the hood so to speak to the raw data that pwercfg.exe is reading? It is promising that the Realtek seems to possibly be a common factor. So perhaps we're looking at an actual driver bug. But the more details we have the better.

    Friday, December 28, 2012 5:22 AM
  • Let me also add some test results that point away from IPv6 but toward some interaction with Layer 3+ devices:

    Two more data points:
    - subject PC connected to router with rest of Win LAN disconnected: has srvnet request, doesn't sleep, requestsoverride doesn't
    - router disconnected*, subject PC on Win LAN: has srvnet request, doesn't sleep, requestsoverride doesn't

    And an even more intersting one:
    - subject PC connected to a different, much older, router with no other WAN/LAN or WiFi connections: has srvnet request, doesn't sleep, requestsoverride doesn't; then, with requestoverride still set, unplugged from the router and connected to an isolated Layer 2 (MAC level device only) GigE switch. While removing the temporary test router and coiling its cord, subject PC fell asleep. When awakened, no srvnet request asserted.

    What I infer from all of this: some interaction with Layer 3+ devices is causing Rt630x86.sys driver to assert something that looks like a srvnet request but can't be overriden. This is causing insomnia.

    * clarification, now that I think about it: this case was actually original router disconnected, using the different much older router for its switch. But it'd still be a router and still be sending and receiving Layer 3+ traffic.

    • Edited by Dick Watson Friday, December 28, 2012 5:40 AM clarify the conditions of the second testcase
    Friday, December 28, 2012 5:29 AM
  • Dick, Luke-

    It looks like you two are on to something.  Can either or both of you try out a driver from Realtek's site?

    The one I downloaded has the following version info - how does this compare to what you two have on your systems?


    Friday, December 28, 2012 6:13 PM
  • John-
    That's the exact driver I've got on my system (except mine is the x64 version).

    MD5 checksum is: 17dfd02577a5a635fa9642e1f7ae866b

    Any idea how we can debug or get more detail on "who" or "what" is making these requests to srvnet when they show up? If we have WinDbg installed (I do) is there a way to peek in?

    Friday, December 28, 2012 9:26 PM
  • I think the only way forward will be to get a dump from one of you so I can check out the internal states during insomnia.  Before that it would be good to first try disabling "File and Printing Sharing for Microsoft Networks" for all your network connections to ensure that this actually does cure the insomnia.



    • Proposed as answer by Marthaz Sunday, November 20, 2016 4:21 PM
    Friday, December 28, 2012 9:53 PM
  • Sure thing. What is the proper method to generate the dump?
    I assume it might be along the lines of:

    1. reproduce the problem on the live system
    2. force a BSOD using something like NotMyFault (notmyfault.exe /crash) or via the RightCTRL+SCROLL_LOCK trick
    3. zip up MEMORY.DMP and send you a link to download it (privately I assume - how would I reach you?)

    Or is there some other procedure I should use?
    (thanks again for the continued help with this!)

    Friday, December 28, 2012 10:48 PM
  •  Yup - details are here:

    "Full" is needed. "Complete" would be overkill.

    You should be receiving an email with instructions for upload. Maximum size is 2GB.  If it's too big, try using BURNMEMORY or the like to make your system temporarily have less RAM available.


    Friday, December 28, 2012 11:06 PM
  • I don't want to rain on anybody's parade here, but I just installed my LAST (one way or the other) Win8 upgrade and now my primary-use laptop, hereafter subject PC #2, with Intel LAN hardware and drivers, is suddenly an insomniac and exhibiting the same symptoms right down to have it get sleepy after turning off file and printer sharing. And, at the moment, because of some as yet unresolved problem with multiple wireless connections to the same LAN breaking the LAN connection entirely, (though I still get to the Internet over the same WiFi that's reporting all local subnet addresses as unreachable) it's seeing these SrvNet and "active remote client has recently sent requests to this machine" requests though I can't connect to/ping ANY LAN addresses besides the gateway.

    This machine always slept like a baby under Win7. The upgrade was "delete partitions" bare metal. (At least the second and third attempts. The first was a "retain nothing" upgrade that kept a 40GB partition of old nothing on a 120GB SSD. What a joke.) I only have a small portion of the required apps and capabilities setup. After putting on all the pending WinUpdates and only about ten minutes worth of post install setup completed, I went to sleep last night and it didn't. So whatever the problem is, it's something pretty fundamental to Win8.

    On subject PC #1 I did try the more recent Realtek direct download driver Rt630x86.sys 8.7.1025.2012. It had even worse insomnia problems like only going to sleep in half of the trials WITH file and printer sharing off the whole time! Reverting to the driver shipped with Win 8, Rt630x86.sys 8.1.1019.2011, and remaining in file and printer sharing off, returned subject PC #1 to blissful somnolence. Luckily, sharing printers and files from that machine is not a big deal. From my laptop, on the other hand, ...

    Sunday, December 30, 2012 7:29 PM
  • Just wanted to chime in again.

    John: I got the instructions for uploading the dump file to MSFT. Trouble is- the machine has actually been sleeping properly for the past few days! Ironic that after finally getting down to the nuts 'n' bolts of what needs to be done to debug this, the problem mysteriously vanishes. While I fully expect the problem to resurface at some point (at which time I will create the dump file) -- at this time my machine is no longer exhibiting the problem.  I haven't changed anything that I can think of beyond all the steps I gave above; File & Printer Sharing is still enabled, and still using the same Realtek NIC driver 8.7.1025.2012. I've put the PC through several sleep/wake and shutdown/restart cycles. So at this point I'm shrugging my shoulders and hoping that one of the other posters here who are still having the problem can create the debug crash dump, as I'm sure there's a bug lurking somewhere!

    Happy new year!!

    Sunday, December 30, 2012 8:29 PM
  • I have the exact same problem as described in this thread on 2 Windows 8 PCs. Both have a Realtek NIC and have the 8.7.1025.2012 driver installed. With the older driver (from Windows update) one of the PCs had the problem of waking up within 1-5 minutes after going to sleep each time.

    Just before writing this post I blocked all media streaming under network center->advanced sharing settings, and finally the PC went to sleep. But I think it is too early to tell if this is a good workaround.

    If you let me know how to upload a memory dump I will attempt to create one somewhere in the coming days.


    Monday, December 31, 2012 12:17 PM
  • Blocking all media streaming was part of the workaround in my case. The other thing keeping the PC awake was still the \FileSystem\srvnet driver. I found that overriding it with "powercfg /requestsoverride driver \FileSystem\srvnet system" didn't do anything, but the following does:

    powercfg /requestsoverride driver srvnet system

    So it seems that "\FileSystem\srvnet" is not recognized, but if you just type "srvnet" it is recognized! A bit tricky because you can't see anywhere if the override is active.

    Using the same logic I could override the power request generated by Windows Media Player ("media sharing is enabled in Windows Media Player"):

    powercfg /requestsoverride process wmpnetwk.exe system

    With this override active I could enable media streaming again without this leading to the insomnia. I will test some more to determine when media streaming causes this problem because only 1 PC suffered from it.

    With that being said, we really need to know why the "srvnet" driver tries to keep the PC awake so the problem can be fixed. The request override is just a workaround.

    Happy new year!

    Tuesday, January 01, 2013 7:47 PM
  • FYI #1 If you are seeing srvnet activity, you can run 'Get-SmbSession' from an elevated powershell to see what active sessions there are.

    FYI #2 For powerrequests, please provide the output of:

    'powercfg /requestsoverride'

    'reg query HKLM\System\CurrentControlSet\Control\Power\PowerRequestOverride /s'

    Wednesday, January 02, 2013 7:41 PM
  • Still at two of three Win8 machines having insomnia if file and printer sharing is on. These were captured in order just now on one of them:

    C:\Windows\system32>powercfg requests

    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.





    C:\Windows\system32>powercfg /requestsoverride



    C:\Windows\system32>reg query HKLM\System\CurrentControlSet\Control\Power\PowerR
    equestOverride /s


    from an Adminstrator PowerShell:

    Windows PowerShell
    Copyright (C) 2012 Microsoft Corporation. All rights reserved.

    PS C:\Windows\system32> Get-SmbSession
    PS C:\Windows\system32>






    Wednesday, January 02, 2013 9:20 PM
  • Dick-

    Does "powercfg /requestsoverride driver srvnet system" allow the systems to idle to sleep? Hans seemed to have success with this.



    Wednesday, January 02, 2013 9:25 PM
  • "powercfg /requestsoverride driver srvnet system" appears to at least let one of the insomniacs get some sleep. I didn't test it on the other--it's busy backing up--but will test and report any different result.

    This isn't an answer or a solution but is a workaround for machines that must file and printer share. For my two insomniacs, I'm thinking just turning off file and printer sharing is a less invasive solution while, hopefully, MS runs this problem to ground and issues a fix.

    Wednesday, January 02, 2013 10:22 PM
  • This is the Get-SmbSession output: (note that only one PC is active on the network for hours)

    PS C:\Windows\system32> Get-SmbSession

    SessionId                     ClientComputerName            ClientUserName                NumOpens
    ---------                     ------------------            --------------                --------
    566935683073                  [fe80::7097:9c8:7cf2:4ec5]    MicrosoftAccount\hansxxxxx... 1

    The "ClientComputerName" address is the local address. See this output:

    PS C:\Windows\system32> ipconfig

    Windows IP Configuration

    Ethernet adapter Ethernet:

       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fe80::7097:9c8:7cf2:4ec5%12
       IPv4 Address. . . . . . . . . . . :
       Subnet Mask . . . . . . . . . . . :
       Default Gateway . . . . . . . . . :

    Tunnel adapter

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:ccc:135c:3f57:f4c8
       Link-local IPv6 Address . . . . . : fe80::ccc:135c:3f57:f4c8%14
       Default Gateway . . . . . . . . . : ::

    And still there is a power request active:

    PS C:\Windows\system32> powercfg /requests

    [DRIVER] \FileSystem\srvnet
    Een actieve externe client heeft onlangs aanvragen naar dit systeem verzonden.





    This is in Dutch and can be translated to "an active remote client has recently sent requests to this machine".

    My overrides are working but the problem is that they now allow the machine to go to sleep even though a file is being shared on another PC. So this problem really needs to be fixed: srvnet and wmpnetwk.exe (media sharing) should not keep the PC awake unnecessary, but only if actually "recently" used.


    Thursday, January 03, 2013 3:41 PM
  • I'm having the same problem and will monitor this thread for a possible answer. My computer would sleep fine 100% of the time under Windows 7 but only about 50% of the time under Windows 8.

    Mine is a 64 bit system and I upgraded from W7 to W8 so it is not a clean install.



    Friday, January 04, 2013 7:17 PM
  • Just to add some more tips:

    powercfg -requests list the blocking programs - use to inspect.

     \FileSystem\srvnet is about Windows filesystem networking and shares. Normally files will be closed when not in use. So how come this can be a problem a Windows client - normally a file server will be serving files?

    Well, some people are using their Windows client as a file server - i.e. multimedia or video files. So you have a player on another machine may keeping that file open. Close the player or multimedia system. May be a loopback problem as well, i.e. the player on the same Windows client coming through the shares as loopback. Meanwhile the default setting in Power config > Advanced > Multimedia Settings is default: Prevent idling to sleep.

    Set Prevent ideling to sleep to Allow the computer to sleep. In that case ... if you guys are using a Windows client as a file server for videos, just take note that the 2nd hand file server may now go to sleep while serving the file.

    Anybody using Perfect Disk 12.x? Has a problem even with stealth patrol and scheduling disabled - that will post a power request if just the user interface is opened. Preventing the machine from going to sleep. But there will be a post in powercfg -requests,

    USB. Some USB 3rd party equipment - I have especially seen that with some consumer devices for gaming - are not implemented corectly - or does not set the flags right for usb features. I.e. will prevent sleep (no post in power request ... but will block sleep i.e. at hardware level ... Windows goto to sleep ... but the PC sort of resumes back into Windows immediately)

    Sunday, January 06, 2013 1:47 PM
  • I tried everything and more to resolve my sleep issues but after disconnecting absolutely everything and uninstalling every driver imaginable i found and cured the issue by uninstalling apps one by one and eventually discovered it was the 'TvCatchup' app that was preventing my pc from sleeping. Hope this may help.
    Monday, January 07, 2013 11:20 AM
  • I would like to say again that a lot of people are clearly reporting that their PC won't go to sleep even if there is NO OTHER PC active on the network. They see this output of powercfg /requests:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.
    This request stays active no matter what. I personally see a local SMB session but have no idea where it is coming from.

    You get a different output when another PC is accessing files: "An active remote client has opened files on this machine."
    That is NOT the problem for those people, because the request goes away when the other PC stops accessing files.

    Tuesday, January 08, 2013 9:04 PM
  • Another thing is the request from media sharing:
    [PROCESS] wmpnetwk.exe
    Media sharing is enabled in Windows Media Player
    Once this request is present it never goes away. I've done quite some testing to be pretty sure of this. Even if only one PC is active, and after rebooting that PC.

    I really hope Microsoft can get to the root of these problems.

    @John E: if you're interrested I can make that memory dump and upload it.

    Tuesday, January 08, 2013 9:15 PM
  • birdbrain - I'd be interested in taking a look at a dump where a persistent "An active remote client has recently sent requests to this machine" is occurring.  Post your e-mail (you can ROT-13 it if you want to avoid spambots) and I'll send you an upload link.



    Tuesday, January 08, 2013 10:15 PM
  • I was not able to generate a full memory.dmp, only a mini dump. I followed the instuctions, set the pagefile min max to memory size + 100MB, set the dump type to full, and used NotMyFault.exe /crash. I tried several times. In the system log it says "writing dump to memory.dmp", but it's just not there. What am I doing wrong?


    Wednesday, January 09, 2013 9:48 PM
  • Hmm, it sounds like you are covering all the bases.  That KB has more knowledge than I do in this area.  If you have a large amount of RAM on the system, you may want to temporarily reduce it by using the "removememory" option: and try again in case the storage adapter isn't handling larger dump files.



    Wednesday, January 09, 2013 10:24 PM
  • Alrighty, I'll try that as soon as I get the chance.

    Thanks so far.


    Thursday, January 10, 2013 7:39 AM
  • The "removememory" option worked! I limited the amount of RAM to just under 2GB and created a dump. During this dump no unnecessary software is running, no other PCs were active, and both the "srvnet" and "wmpnetwk.exe" power requests were active without a clear cause.

    Please send the upload link to the highly encrypted email address jvaqbjf8grfg@yraanregf.rh and I will be happy to upload the dump.


    Thursday, January 10, 2013 8:52 PM
  • Well the good news is that the srvnet's idle detection logic state machine looks good.  T

    The dump was captured at "Thu Jan 10 12:29:13.270 2013 (UTC - 8:00)", all queues are idle, and srvnet has been idle since "Thu Jan 10 12:26:56.067 2013 (UTC - 8:00)", so it's about 2.5 minutes.

    Can you open "Computer Management", "System Tools", "Shared Folders" and see if there's anything in "Shares", "Sessions" or "Open Files"?

    I'll dig into the dump some more to see if I can get the sessions from this side.


    Saturday, January 12, 2013 12:54 AM
  • I just solved my hibernate problem!!

    I did have the same issue, and tried everything. Only srvnet was showing in powercfg /requests. It would never go automatically to sleep.

    It turned out that the VIA audio driver was causing my system to not sleep anymore. I uninstalled the Via software, and am now using the standard supplied microsoft driver. I guess it's due to the auto-sensing new inputs stuff.  Earlier I also got to fix it by disabling all not-used audio devices in the Sound Control Panel of Windows, but this time I had to uninstall the driver and it's software from the add/remove control panel.


    Well, still have these problems, sometimes it does sleep, sometimes not. It's an improvement, but not the solution.

    • Edited by Umito1 Thursday, January 24, 2013 11:15 PM
    • Proposed as answer by Stu2001 Friday, August 16, 2013 7:43 PM
    Wednesday, January 16, 2013 11:28 PM
  • What are the odds this will ever be fixed? Does Microsoft have an open problem on this? Or is this too much of an Old Windows problem to ever be fixed?

    Had to share a file off one of my insomniacs. Turned on File Sharing. Insomnia instantly returns.

    Sunday, February 10, 2013 4:11 PM
  • I totally agree. Filesharing and media sharing cause many (if not all) Windows PCs to stay awake. How can it be this does not get the attention it deserves, in a world that is ever more focussed on energy saving?
    Monday, February 11, 2013 7:17 AM
  • I found that my laptop won't go to sleep if it's doing its file search indexing.  Good grief, it can do that anytime *smile*.  But once I disabled that (thought that I had, but forgot about the service part), and did the srvnet requestoverride, that was it, the laptop will go to sleep again.  Not very happy with the fact that nearly anything seems to keep the laptop from going to should be the other way around, only high-priority activity should keep the computer awake.  And I should be able to specify what keeps the computer awake, not the other way around.

    And have to be vigilant, to make sure the computer goes to sleep, and go into research mode when it doesn't.  Just a bad implementation, as far as I'm concerned.

    Friday, February 15, 2013 3:54 AM
  • I too have this problem ever since upgrading my PC to Windows 8 with a clean install. I hope there will be a solution for this.
    Friday, February 15, 2013 11:05 AM
  • Hi,

    I have had this problem a couple of times, and every time it has turned out that the powercfg report mentioned USB problems, but on TECHNET somewhere I had read a post that identified that the problem was a USB problem but could be resolved by upgrading Video drivers.  I assume this is because on an AMD system, the chipset drivers are incorporated into the video drivers, or actually vice versa.  But whenever there has been an upgrade available this has worked.

    My problem right now has started when I accidentally stepped on the OFF switch for my power strip while installing a video device.  Unfortunately, there is no upgrade to my video drivers available right now, so I am forced to try to do it the hard way, with no luck thus far. I am considering a reinstall, because sleep (and everything else) worked perfectly until that incident.

    Saturday, February 23, 2013 8:21 PM
  • I've noticed that the recent update for ADBE Flash player seems to contain a defect that prevents monitor from turning off. Found with powercfg.

    Well this is the world we live in And these are the hands we're given...

    Saturday, February 23, 2013 10:17 PM
  • Hi

    Computer with Windows 8, clean install, does not sleep unless you set sleep time 1 minute, that is not very useful, right?

    Learning in some Forum's Discussions, I tried the command "Powercfg -devicequery wake_armed" and I got NONE. Then I run the command "Powercfg -energy" and found 8 errors, all related to the USB drivers. That seems incongruent since says there is nothing to wake the computer but also that the USB can not go to the sleep mode all right.

    I have checked Intel website for driver update and there is nothing there and during a search on the internet, seems I have the must updated driver for the USB ports. I have also checked on Device Manager the USB Controllers the items that had "Power Management" and in all of the option "Allow this device to wake this computer" were fainted and with the box unchecked.

    The most peculiar thing is the fact that, as I said in the beginning is the fact that if I set the sleep time to 1 minute, it sleeps, any value bigger than that, does not sleep at all but the monitor shuts down.

    Can somebody help me here to understand what is going on and how to solve this?



    Tuesday, March 12, 2013 2:37 AM
  • powercfg -requestsoverride driver \FileSystem\srvnet system This deleted all of my power plans. Is there a way I can reverse this
    Sunday, March 17, 2013 11:39 PM
  • What worked for me was
    Network Connections | Wi-Fi Properties | Configure... | Power Management |
    "Allow the computer to turn off this device to save power" - Check the box.

    I tried a LOT of other things, but this was my magic 'bit'.

    I have seen other solutions referring to Video and SSD drivers, but I believe I have the latest of both.

    Win8 64-bit Lenovo T430 Samsung SSD

    Cheers, Daragh

    • Edited by Daragh F Tuesday, March 26, 2013 2:14 PM
    Tuesday, March 26, 2013 2:13 PM
  • Ok, I wanted to post this in case it benefits anyone. After tearing lots of hair out over this for months on end, I never did find any "magical setting" that eliminated the problem for good. For a while the problem disappeared on its own, but then a few weeks ago it mysteriously came back. I was fed up and so I came up with a solution that fixes the problem for me. It's not the most elegant thing in the world but it has worked for me and if you follow the steps below, you should be able to set it up without too much trouble.  Hopefully MS will officially address this (if it's even their bug which remains to be seen) but for now, try this out and let me know if it works for you:

    1. create a batch file, name it "C:\Scripts\restart_srv.cmd" containing the following content:

    @echo off
    set logfile="%TMP%\srvlog.txt"
    if exist %logfile% goto begin
    echo [%date:~4,10% %time%] logfile created>%logfile%

    echo -->>%logfile%
    echo [%date:~4,10% %time%] srvnet check triggered>>%logfile%
    openfiles /Query 2>NUL | FIND /C "INFO: No shared open files found" >NUL
    if errorlevel 1 goto yes_opens
    echo [%date:~4,10% %time%] no open files, proceeding to check for srvnet driver block>>%logfile%
    powercfg -requests | find /C "[DRIVER] \FileSystem\srvnet" >NUL
    if errorlevel 1 goto no_srvnet_block
    echo [%date:~4,10% %time%] **block detected, restarting srv**>>%logfile%
    net stop /y srv >NUL 2>NUL
    goto :eof

    echo [%date:~4,10% %time%] open files detected, not restarting srv>>%logfile%
    goto :eof

    echo [%date:~4,10% %time%] no srvnet block detected, not restarting srv>>%logfile%
    goto :eof

    2. launch Task Scheduler (taskschd.msc)

    3. create a new task called "Restart srv" and set it up like the screenshots below (start at midnight, repeat every hour for 24 hours)

    4. (this step is ** optional ** -- You only need to do this if you want to be able to manually kick off this task easily via a desktop icon)

    create a new shortcut, with the following attributes:
    - target=C:\Windows\System32\schtasks.exe /run /tn "Restart srv"
    - run: minimized
    - icon: %SystemRoot%\system32\SHELL32.dll (red NO)

    5. Fire off the task manually (either by double clicking the shortcut from step 4 or by manually running the Task via right-click: Run from within Task Scheduler) and check the logfile created by the task (open %TMP%\srvlog.txt with notepad) to make sure it's doing its job:

    Good luck and hope this helps some people who are paying needless $$ for their insomniac PCs! :)

    • Edited by Luke Hamburg Tuesday, March 26, 2013 7:03 PM
    • Proposed as answer by old_luckman Thursday, April 04, 2013 6:21 PM
    Tuesday, March 26, 2013 6:23 PM
  • It's worth to have a look at

    Tuesday, March 26, 2013 7:07 PM
  • Arpoador: thanks for the advice but if you read through the entire thread, you'll see that the problem is in most cases, the powercfg /requests command does not give any real info as to why the PC isn't sleeping, other than saying "srvnet" which does not really help. The fix I posted above does work however, at least for me.
    Tuesday, March 26, 2013 7:18 PM
  • Nice thread. Wish I'd seen it earlier.

    For me, the thing that worked is exposing and enabling "Allow sleep with remote opens," as described in this helpful article (Win7, Win8, same difference when it comes to this stuff):

    It's also mentioned up the thread in that very comprehensive post by Luke (I assume you then did go in and enable it for your chosen power scheme), so it's hardly a cure-all, but I felt it needed more exposure in this thread.

    Update: I'd also like to mention this, since no doubt a very large percentage of this thread overlaps with the same issue on Win7. This is a hotfix bundle for Win7 that's ostensibly for enterprise users but which can be installed by anyone. It fixed a very stubborn insomnia problem on one of my Win7 machines, even though I don't see any obviously sleep-related issues mentioned in the detailed listing of hotfixes in the article. It's not too surprising to me though, since a large number of system files are updated.

    • Edited by rseiler Sunday, March 31, 2013 7:17 AM
    Saturday, March 30, 2013 6:27 AM
  • Hi all,

    I'm happy to report that after the latest round of windows updates my computer is now going into sleep mode automatically. Don't know what exactly fixed it but its working for me.

    Note: It could also be the NVidia driver as that and the windows updates seem to have worked.
    • Edited by PM76 Saturday, March 30, 2013 8:49 AM
    • Proposed as answer by Dick Watson Thursday, April 04, 2013 2:10 AM
    Saturday, March 30, 2013 8:47 AM
  • Hi all,

    I'm happy to report that after the latest round of windows updates my computer is now going into sleep mode automatically. Don't know what exactly fixed it but its working for me.

    Note: It could also be the NVidia driver as that and the windows updates seem to have worked.

    Hi, thank you for this information. Could you please post the hotfixes that were installed recently for others could know in the future which updates fix the issue?

    You can get a list by running the following command at the elevated command prompt:

    C:\Windows\system32>wmic qfe where "installedon = 'm/dd/yyyy'" get hotfixid,caption
    Substitute m with the month, dd with the day, and yyyy with the year of the date the hotfix update was installed on, for example: 3/28/2013 for March 28th, 2013.
    Thank you.

    Well this is the world we live in And these are the hands we're given...

    Sunday, March 31, 2013 3:33 PM
  • You can get a list by running the following command at the elevated command prompt:

    Or use my new toy: 

    PS C:\> get-hotfix | sort InstalledOn

    See also Example 4 here:

    Who needs systeminfo for Hotfix(es) any more?   ; )

    Tuesday, April 02, 2013 12:57 AM
  • Indeed! Whatever got dropped recently appears to have "improved" the insomnia "feature". I now have Printer and File Sharing enabled on all my Win8 machines for the first time since installing them and discovering that several of them turned into insomniacs if it was enabled.

    Don't know what caused the "improvement" but glad to have it.

    Thursday, April 04, 2013 2:12 AM
  • I have all the latest Windows Updates applied as well, and I am still seeing srvnet blocks in the logs generated by my script (above) as recent as yesterday, so I think there is still more work to be done.  For now I still feel that my script is the best solution. It's the only thing that has worked 100% for me so far.

    Thursday, April 04, 2013 1:00 PM
  • sorry for the late reply, here is the hotfix list on my PC.

    Description      HotFixID      InstalledBy          InstalledOn
    -----------      --------      -----------          -----------
    Update           KB2790920     NT AUTHORITY\SYSTEM
    Security Update  KB2789650     NT AUTHORITY\SYSTEM
    Update           KB2770917     NT AUTHORITY\SYSTEM
    Update           KB2769165     NT AUTHORITY\SYSTEM
    Update           KB2764870     NT AUTHORITY\SYSTEM
    Update           KB2768703     NT AUTHORITY\SYSTEM
    Update           KB2769034     NT AUTHORITY\SYSTEM
    Update           KB2785094     NT AUTHORITY\SYSTEM
    Update           KB2780342     NT AUTHORITY\SYSTEM
    Update           KB2781197     NT AUTHORITY\SYSTEM
    Update           KB2788350     NT AUTHORITY\SYSTEM
    Security Update  KB2789649     NT AUTHORITY\SYSTEM
    Update           KB2771821     NT AUTHORITY\SYSTEM
    Update           KB2777166     NT AUTHORITY\SYSTEM
    Security Update  KB2737084     NT AUTHORITY\SYSTEM
    Security Update  KB2799494     NT AUTHORITY\SYSTEM
    Security Update  KB2797052     NT AUTHORITY\SYSTEM
    Update           KB976002      NT AUTHORITY\SYSTEM
    Security Update  KB2727528     NT AUTHORITY\SYSTEM
    Security Update  KB2807986     NT AUTHORITY\SYSTEM
    Update           KB2795944     NT AUTHORITY\SYSTEM
    Update           KB2792009     NT AUTHORITY\SYSTEM
    Update           KB2758246     NT AUTHORITY\SYSTEM
    Update           KB2761094     NT AUTHORITY\SYSTEM
    Update           KB2756872     NT AUTHORITY\SYSTEM
    Update           KB2794599     NT AUTHORITY\SYSTEM
    Security Update  KB2753842     NT AUTHORITY\SYSTEM
    Update           KB2777294     NT AUTHORITY\SYSTEM  12/11/2012 00:00:00
    Update           KB2784160     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2712101_... NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Security Update  KB2770660     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2771431     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Security Update  KB2729462     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2769166     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2779768     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2782419     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2779562     NT AUTHORITY\SYSTEM  12/12/2012 00:00:00
    Update           KB2750149     NT AUTHORITY\SYSTEM  02/02/2013 00:00:00
    Security Update  KB2742616     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Security Update  KB2736693     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Security Update  KB2742614     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Security Update  KB2785220     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Security Update  KB2757638     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Security Update  KB2756923     NT AUTHORITY\SYSTEM  01/10/2013 00:00:00
    Update           KB2823233     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2815769     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2800088     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2824670     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2812829     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Security Update  KB2809289     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2790907     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2812822     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00
    Update           KB2811660     NT AUTHORITY\SYSTEM  03/12/2013 00:00:00

    Thursday, April 04, 2013 6:58 PM
  • Hi, I've also been suffering from sleep issues with a fresh install of Windows 8. I've had these problems since the install, which was about 3 weeks ago,

    I'm using my PC as a HTPC. The PC wakes to record a show and is set to go to sleep 20 mins after the show finishes.

    Or at least that is what is supposed to happen. Generally (probably 70 - 80% of the time) the PC stays awake.

    I haven't run any windows updates yet as my net connection is currently down and don't have the opportunity to download large files.

    I have been running Luke's suggestion above for 2 days and so far (touch wood) the PC has been going back to sleep every time. It hasn't stayed awake once :)

    In the 2 days the PC would have woken up to record shows at lease 7 times and gone back to sleep each time.

    Thanks for your fix Luke :)

    I'll post back here if anything changes. 

    Tuesday, April 09, 2013 10:37 AM
  • Hello

    I was having the same problem. The computer had been sleeping without any problem, and then for no apparent reason started to wake up in the middle of the night.

    I found that that there was an update waiting to install that was being shown that it would install on the next scheduled maintenance - I manually made the update install , checked for more updates, and since then the computer has behaved again.

    Monday, April 15, 2013 5:59 AM
  • FYI

    For anybody interested, it seems there is a power request bug (audio) in Intels latest WiDi/Miracast package ( for Windows 8.

    After an active connection - the power request for audio is not relinguished. You have to actually close the WiDi program and thus the Windows client WiDi/Miracast "service" to retire the power request ... that is preventing the Windows client from going to sleep - allthough ... as stated ... the active connection has been closed.

    Let's see if Intel will fix this in its next release ... however bad timing, since the new basic feature of Smart Tv's in this spring 2013 is ... Miracast. May be Microsoft should put some pressure on Intel to get it fixed now ...

    Monday, May 13, 2013 10:29 PM
  • Computermensch,
    I can't say for sure if you're right about the WiDi bug preventing sleep but I can tell you that on my system I don't even have any wireless interfaces (no Intel WiDi) and so I can at least rule out that being the only source of the problem. There's more to the story here. For now, my workaround solution above remains the only thing that reliably solves the problem for me.

    • Proposed as answer by zivalee Wednesday, May 15, 2013 10:58 PM
    • Unproposed as answer by zivalee Wednesday, May 15, 2013 10:58 PM
    Tuesday, May 14, 2013 1:04 PM
  • Hello. I've been following this thread for days because I have the same problem. I bought the new pc last month, april 2013, and the sleep feature was working fine until about a week or so ago.  I had a chat on the phone with one of the dell reps I spoke with him about my computer not going to sleep automatically and he told me that he would like to send someone to replace the motherboard but that was after doing a restore point which didn't solve the problem and then restoring my PC to factory settings which didn't solve the problem either. I told him that I couldn't do that for now but the thing is I finally found out today what was keeping my computer from going to sleep and I wanted to know if there was anything we could do about it.  I have a wireless DSL router and so I wanted to test if that was the "culprit" and sure enough it was. I turned it off and put the power options on 1 min to turn off display and 1 min to go to sleep and it worked. Then I turned the router back on and did the test again and it wouldn't go to sleep. I did this test 5 times resulting in that when the wireless router was off it would go to sleep automatically and when it was on it wouldn't go to sleep automatically. So is there an option or setting to fix this? Thank you.  :-) PS...First time posting here so I'm sorry if I did it wrong :-/
    • Edited by zivalee Wednesday, May 15, 2013 11:12 PM
    Wednesday, May 15, 2013 11:09 PM
  • Hello John,

    I built two computers running windows 8 pro and they did go into sleep mode without a problem until after windows did an automatic update twice.

    Very frustrating. I think this is a very important feature for a lot of people and should be given some priority resolving. I have tried many things as well to get my computers to sleep.  Could the settings below cause my computer to not automatically go to sleep? In Task Scheduler for Adobe updater Under security settings it is checked "run whether user is logged on or not" Thank you for any input on this matter.

    Thursday, May 23, 2013 3:05 PM
  • I have an external Western Digital Drive.

    I updated my drives hardware.

    I updated the WD Smartware Software.

    I restarted.

    I watched my computer sleep.

    I think there was a conflict possibly between the drives sleep settings and the machines.

    Wednesday, July 24, 2013 9:54 PM
  • Hi,

    I was having this insomniac PC problem lately. In my case, I've found out that the device that prevents PC from going to sleep was wireless mouse (HP x4000 wireless desktop mouse). I've unplugged it and now PC is having a sleep when necessary..

    Hope this helps someone.

    Mehmet Melik

    Friday, July 26, 2013 8:10 PM
  • I have the exact same symptom. After trying out all kinds of trick to no avail, I decided to roll back the 13 windows 8 updates I recently installed around July 22th, 2013, since I had no this problem not long time ago, and recently I only installed the windows updates and some App updates. It turned out windows updates are the culprit in my case. After uninstalled those windows updates which are dated around July 9th, 2013, sleep and hibernate works very well. Hope this will help people out. Microsoft needs to get this fixed asap.

    P.S. I reinstalled the afore-mentioned windows system updates for Trial and error, and found it was KB2855336 that caused the problem. So you can just uninstalled it to fix the problem. My computer is Thinkpad T400, running on Windows 8 64bit. 

    • Edited by YongSpirit Saturday, July 27, 2013 7:38 AM more information
    Saturday, July 27, 2013 7:04 AM
  • I also found when the sleep and hibernate problem is gone, when I run "powercfg /energy", I could still get the error message

    "System Availability Requests:System Required Request 

    The device or driver has made a request to prevent the system from automatically entering sleep.
    Driver Name \FileSystem\srvnet"

    So I think this message is quite misleading when people try to find the root cause of the sleep and hibernate problem.

    Saturday, July 27, 2013 7:45 AM
    Monday, July 29, 2013 1:09 AM
  • SOLUTION !!!

    Disable (don't remove) Microsoft Kernel Debug Network Adapter from Device manager in Network adapters.

    you will also find resolution when you check Command prompt (Admin) type in  powercfg/requests.

    AND you can leave screensaver on.

    Thursday, August 01, 2013 10:53 AM
  • SOLUTION !!!

    Disable (don't remove) Microsoft Kernel Debug Network Adapter from Device manager in Network adapters.

    you will also find resolution when you check Command prompt (Admin) type in  powercfg/requests.

    AND you can leave screensaver on.

    • Proposed as answer by TamsZ Thursday, July 23, 2015 2:41 AM
    Friday, August 02, 2013 1:33 AM
  • powercfg /requestsoverride driver srvnet system worked for me.  Thanks, Hans.
    Wednesday, August 07, 2013 3:10 PM
  • Just wanted to chime in here again, since there have been so many comments since my last post. I've tried all of the alternate solutions posted here, and my fix using the scheduled task (method described in detail, earlier in this thread) remains the only 100% working solution for me to date. I am fully up to date with all hardware drivers and Windows Updates, so whatever is causing this has not been fixed yet. People reporting otherwise are probably just getting lucky and will see the bug reappear on their systems at some point in the future.

    See screenshot below, showing that even as of today with this fully patched system, my script is still detecting "insomniac" conditions and resetting the srvnet driver:

    Monday, August 12, 2013 11:55 PM
  • Samsung Magician can also prevent sleep/hibernation. If you have a Samsung SSD, stop the tool.

    "A programmer is just a tool which converts caffeine into code"

    Tuesday, August 13, 2013 5:20 AM
  • Just curious is anyone has tried disabling the 'wake on LAN' under Device manager - network drivers - properties - advanced? 

    David Dracoules

    Tuesday, August 13, 2013 6:36 PM
  • Since KB2855336 these settings dissapeared in network adapter configuration (Power management tab is gone due to this update!)

    Sunday, August 18, 2013 5:44 AM
  • Power management tab is gone due to this update!

    I still have the tab (and I have the update installed)

    "A programmer is just a tool which converts caffeine into code"

    Sunday, August 18, 2013 6:35 AM
  • I too have had that same problem, especially with Intel Extreme motherboards DZ77GA-70K and model DZ77RE-75k, which use duel LAN drivers. I cured the problem by going to computer, right click, slide down to properties, left click on device manager.  Go to Network adapters, the first one being the wireless adapter. Mine is the 802.11bgn 1TR1R. Right click on it, and left click properties. Go to the power management tab, and left click. Mine has 2 boxes. One says allow the computer to turn off this device. That one should be checked. The next one down says - Allow this device to wake the computer. That needs to be un-checked. Then close those boxes and proceed to your LAN Network Connection. My Intel Board has 2. Right click on the LAN adapter and click properties. Then click on the Power Management Tab. Then if it is anything like mine, you need to un-check all of the boxes under the Wake on LAN. My two adapters have 4 boxes which were all checked by default when Windows loaded. 

    Wake on magic packet

    Wake on patter match

    Wake on magic packet from power off state, and

    Wake on link settings. 

    I had to un-check all of these on both of my network adapters. Then go to power management in the control panel, change plan settings, change advanced power settings, go to PCI EXPRESS, and turn off the Link State Power Management.  I have not had a sleep problem since. Then you might want to check every device in your device manager, because any device with a power management tab under properties will give you the option to allow that device to wake the computer, including the USB hubs. My problem was the network adapters, so I'd make sure you go there first.  Additionally, if you are running Windows 8 on a desktop especially with a solid state drive, I recommend you also turn off the Windows 8 fast start, and if you run an SSD for your operating system, set your hard drive in power options to never turn off. The reason for that setting is, if you set an SSD to turn off in a certian amount of time, it reeks havoc on the drive trim system, which tries to keep running and the drive is off. This too can keep your computer from sleeping properly, and cause errors on your SSD. I hope this post helps, because I tried everything you guys have stated on this forum, and no luck. What I did above fixed the problem for good. I have not had a sleep issue since, and I build and load at least one extreme computer per week. HOPE THIS HELPS.  By the way if you get it to sleep even for 30 seconds, you can also use this command in the command prompt after you run it as administrator.  powercfg -lastwake. This will tell you the exact device that is waking the computer.

    Dale Morse

    Microsoft Partner, and Intel Channel Member

    • Edited by Dale Morse Wednesday, September 11, 2013 7:16 AM Hope This will help
    Wednesday, September 11, 2013 7:07 AM
  • This is a great thread! I finally got my Win 8 machine to sleep and wake on local command thanks to Luke's script and the other advice shared.  Now, it is sleeping a little bit too hard...  I have an Xbox 360 functioning as a Windows Media Center Extender and I would like for it to be able to wake up the computer hosting windows media center.  It is hardwired to the same router as the WMC machine.  Any guess as to what settings need to be adjusted to allow this to occur?  I've left "Wake on magic packet" checked, but it appears the Xbox isn't using the magic packet.  Other sources suggest that the Slim model and newer do in fact use the magic packet, but I've got an older fat boy.

    Edit:  I found a similar technet discussion which led me to the WakeOnLan command line by Depicus.  I was able to use it to verify that my WakeOnLan function is working properly.  To get the Xbox 360 to wake up the computer, I must need to enable "Wake on Pattern Match" (it doesn't seem to use the magic packet), but unfortunately, that causes the computer to become insomniac.  Clearly my problem is related to network traffic, I guess the next research project is to figure out where the traffic is coming from...  it is only a home network with a few devices.

    An alternative solution would be to somehow embed Depicus's tool into the startup script of the Xbox 360 so that I can leave "Pattern Match" unchecked, but I have no idea if that is possible.

    (sorry, no links until my account is verified)

    • Edited by sensij Thursday, September 12, 2013 4:08 PM updated info
    Thursday, September 12, 2013 4:44 AM
  • * THIS MAY WORK !! *    It fixed mine!

    In the process of setting up a "task" in the "Task Scheduler," as described in this discussion, I noted that there were five or six scheduled "tasks" for backing up and or synchronizing documents, photos, etc. to various drives that were not on my PC. After looking at the script and description for these tasks I noted that they included the word SanDisk, Kingston, Seagate, etc.  I Disabled them (right side of the Task Scheduler window) and it slept a few times. [Do the next step with great caution BACKUP FIRST. At least turn on Restore and create a restore point.] I then did a word search on the manufactures name of the offending scripts and DELETED them. This also removed the offending Tasks from the Scheduled Tasks Library.

    It Worked for me.  

    Some of these thumb drives, and MANY of the USB External HDD's have built-in S/W and I may have tried them. Seagate started just like a CD disk for a program when I plugged it in and that was the worse offender! Somehow it ended up where I do not want it. I KNOW I "un-installed" any thing I did not want BUT some programs do not uninstall nicely from WIN-8.

    I take no responsibility if deleting portions of the registry breaks your PC - Especially if you do not back it up.

    WHY, PLEASE, WHY doesn't MS SHOW the offending task in the Powercfg error report? What they have is no better than the old (1970's) "Check Engine" light and no OBDII reader (and no provision as there are no codes even sent).

    How does, Do they even try, to keep track of the fact that if you have several external USB drives and/or have restored your PC that the external drive may have a different drive letter? Why doesn't this S/W track the drive serial number?

    Worse yet, take a look at all of the JUNK in the USB "installed" database [USBDBView]. If you are in the habit of popping in any old thumb drive, USB drive, Once on a hub, the next time not - IT IS A MESS.  

    Saturday, September 28, 2013 12:56 PM
  • Found a reason in my system. Windows 8.1

    Cisco VPN Client was causing the insomnia.

    When I disable the network adapters, the system sleeps like a baby...

    I will try other approach because I need the VPN working... Any suggestions will be appreciated :-)


    Sunday, September 29, 2013 3:53 PM
  • FIGURED IT OUT !!! what i did... created new power scheme set it for like 5 min to sleep ( so I could check) "Change Advanced Settings".... On the to "paragraph" of the window is "Change Settings that are currently unavailable" Then scroll down to "Sleep"-Expand "+" "Allow Wake Timers" - "Disable"

    Wait for it... Works !!! Now set the sleep time for what you want Mine is 2 hrs.

    Thursday, October 03, 2013 5:40 PM
  • Are You Kidding ??

    FIGURED IT OUT !!! what i did... created new power scheme set it for like 5 min to sleep ( so I could check) "Change Advanced Settings".... On the to "paragraph" of the window is "Change Settings that are currently unavailable" Then scroll down to "Sleep"-Expand "+" "Allow Wake Timers" - "Disable"

    Wait for it... Works !!! Now set the sleep time for what you want Mine is 2 hrs.

    Thursday, October 03, 2013 5:41 PM
  • FIGURED IT OUT !!! what i did... created new power scheme set it for like 5 min to sleep ( so I could check) "Change Advanced Settings".... On the to "paragraph" of the window is "Change Settings that are currently unavailable" Then scroll down to "Sleep"-Expand "+" "Allow Wake Timers" - "Disable"

    Wait for it... Works !!! Now set the sleep time for what you want Mine is 2 hrs.

    Tried it, but my computer still won't sleep even with disable 'allow wake timers'.
    • Edited by rockitdoc Friday, October 04, 2013 12:46 PM
    • Proposed as answer by Teeraphab Friday, October 04, 2013 7:53 PM
    • Unproposed as answer by Teeraphab Friday, October 04, 2013 7:53 PM
    Friday, October 04, 2013 12:41 PM
  • I found the cause of my notebook insomnia, just uninstall the Intel PROSet/Wireless Software. This software worked find in Windows 7 but not in Windows 8.

    Friday, October 04, 2013 7:55 PM
  • Hi luke, I tried your script. However, it seems that once in a while srvnet crashes during the restart. Can you help me on this? Chris
    Friday, October 11, 2013 5:23 PM
  • All computers that are using HOMEGROUP have to all be on the same HOMEGROUP and have to be properly configured to share something before any of the computers will auto sleep properly. Procedure: Have all computer leave the HOMEGROUP. Unshare ALL files/folders on all computers.  Create a new HOMEGROUP password when ALL other computers are on and running and share what folders you want. Go around and immediately change the password of the other computers and share what folders you want.

    To see if this is your issue, just leave the HOMEGROUP and set sleep for 1 minute then see if the computer auto-sleeps.

    Example, I had two computers on Win 8.1 Pro that I just installed who would NOT connect using my old HOMEGROUP password. I created a new HOMEGROUP password and managed to get these two computers to share files. However, there was a THIRD computer on the network (with Win 8) who had the old HOMEGROUP password. I successfully changed it to the new HOMEGROUP by leaving and rejoining using the new password. Yet I could not see any files on this last computer. I had to unshare with the HOMEGROUP all of the files and folders under users. Then I shared the one folder that I wanted to share. That worked and that also FINALLY let my computer sleep!

    I think this is the reason why some of the workarounds fixed the issue. The netsrv issue is probably trying to connect to the HOMEGROUP computers that are not connected properly. Leaving HOMEGROUP would fix the problem, as well as turning off IPv6 (which is needed by HOMEGROUP to connect), and finally killing the LAN just turns off all sharing.

    EDIT: Four other users confirmed cases of auto-sleep failing when updating to Win8.1. Doing the HOMEGROUP procedures fixed them all. THIS IS A BUG.

    • Edited by John Pombrio Sunday, October 20, 2013 11:08 AM
    • Proposed as answer by sdmf74 Thursday, October 24, 2013 3:39 PM
    Sunday, October 13, 2013 8:08 PM
  • Hi luke, I tried your script. However, it seems that once in a while srvnet crashes during the restart. Can you help me on this? Chris

    Hi Chris
    Not sure why that would be but - you could add some error-checking logic to the script to test whether srvnet has successfully started, and then if it hasn't - attempt to restart it again. I haven't tested this code because I haven't had that issue, but something along the lines of:

    @echo off

    set logfile="%TMP%\srvlog.txt"

    if exist %logfile% goto begin

    echo [%date:~4,10% %time%] logfile created>%logfile%


    echo -->>%logfile%

    echo [%date:~4,10% %time%] srvnet check triggered>>%logfile%

    openfiles /Query 2>NUL | FIND /C "INFO: No shared open files found" >NUL

    if errorlevel 1 goto yes_opens

    echo [%date:~4,10% %time%] no open files, proceeding to check for srvnet driver block>>%logfile%

    powercfg -requests | find /C "[DRIVER] \FileSystem\srvnet" >NUL

    if errorlevel 1 goto no_srvnet_block

    echo [%date:~4,10% %time%] **block detected, restarting srv**>>%logfile%

    net stop /y srv >NUL 2>NUL

    ping -n 5 -w 1000>NUL

    sc query srv | find "RUNNING" >NUL 2>&1

    if errorlevel 1 goto SrvNotRunning

    goto :eof


    echo [%date:~4,10% %time%] **srv did not autostart, attempting manual start**>>%logfile%

    set cnt=0


    if %cnt% GEQ 5 goto SrvCantStart

    set /A cnt+=1

    echo [%date:~4,10% %time%] **waiting for SRV service to start [%cnt%]**>>%logfile%

    sc start srv >NUL 2>&1

    ping -n 2 -w 1000>NUL

    sc query srv | find "RUNNING" >NUL 2>&1

    if errorlevel 1 goto wait1

    echo [%date:~4,10% %time%] **SRV service is now running**>>%logfile%

    goto :eof


    echo [%date:~4,10% %time%] **Tried 5 times to start SRV but failed**>>%logfile%

    goto :eof


    echo [%date:~4,10% %time%] open files detected, not restarting srv>>%logfile%

    goto :eof


    echo [%date:~4,10% %time%] no srvnet block detected, not restarting srv>>%logfile%

    goto :eof

    Let me know if that works better for you!
    Saturday, October 19, 2013 6:44 PM
  • In Windows 8 Pro 32-bit, sleep mode worked normally.

    I was having this sleep mode problem since the upgrade from Windows 8 Pro to Windows 8.1 Pro.

    What worked for me was the following =

    Control Panel --> All Control Panel Items --> Network and Sharing Center --> Advanced Sharing Settings :

    Private = Turn Off Network Discovery.

    • Edited by DD7VV Sunday, October 20, 2013 5:38 AM
    Sunday, October 20, 2013 5:32 AM
  • Woah, this thread went of my hands :)

    I wanted to thank everyone for their suggestions. I've tried quite a few of them, but none has succeeded.

    Just 2 days ago I upgraded from Win 8 Pro to 8.1 and after I left my PC unattended for like half an hour it went to sleep for the first time since a year (when I changed Windows 7 for Windows 8). I was so happy - I thought the issue was fixed for me in 8.1 but only today insomnia returned. And it seems it is unrelated to HomeGroup. I'm guessing it might be some rogue driver. ASUS made drivers for Windows 8, but soon after they abandoned my model altogether so I don't expect anything else to be fixed.

    For me this issue is hopeless. I'm happy that some of you found other users' suggestions useful - none worked for me :(

    I am grateful for all them and would like to ask you to keep them coming. Maybe one day I'll find out what's the issue, but I'm also afraid that I'll sooner buy a new non-insomniac laptop.

    Thanks again!

    Sunday, October 20, 2013 12:40 PM
  • Hi John,

    It seems that disabling my WiFi network adapter does the trick. I tried updating drivers to the newest available in Windows Update and Realtek website and ASUS website but to no avail. Clearly the network connectivity is the culprit.

    I tried fighting with Windows Media Network service, homegroup and file sharing but none helped. I will probably give up since I don't suppose to get newer drivers for my card (the last ones are from Microsoft, released in May 2013).

    I'm on Realtek 8188CE if somebody was interested. I see other guys also have Realtek cards.

    Sunday, October 20, 2013 1:23 PM
  • I disabled it a long time ago before posting this thread. Unfortunately, it doesn't work for me :(
    Sunday, October 20, 2013 1:44 PM
  • Unfortunately this procedure doesn't work for me. And for some period of time this year I had Homegroup removed and it didn't help :( Thanks for the tip, though. Maybe it'll help someone.
    Sunday, October 20, 2013 2:10 PM
  • John thank you so much, I tried nearly everything in this thread. Just like many others my sleep issues seem to come and go but after troubleshooting again all night I simply left my HOMEGROUP and bam sleepytime. Now its my turn goodnight and good luck all, what a pain.
    • Proposed as answer by BogBeast Tuesday, October 29, 2013 12:04 AM
    • Unproposed as answer by BogBeast Tuesday, October 29, 2013 12:05 AM
    Thursday, October 24, 2013 3:36 PM
  • I recently found the same. The problem is with my WIFI. If I turn off WIFI, then everything fine. My WIFI is Intel WIFI LINK 5300AGN. Also, as I reported before, the problem will go if I uninstall KB2855336. They are related. For those old wifi card, it seems we won't receive any new fix any more. What a pain.

    • Proposed as answer by JoeGreyHair Wednesday, October 30, 2013 7:37 PM
    • Unproposed as answer by JoeGreyHair Wednesday, October 30, 2013 7:37 PM
    Saturday, October 26, 2013 9:59 PM
  • I have updated my Windows 8 Pro to windows 8.1 pro a couple of days ago and had this problem of the computer not going to sleep.  I was also unable to create a custom power profile and kept getting the message "Access Denied" when trying to do so.

    Having spent many hours today trying to resolve this problem and tried most of the above solutions to no avail, I finally decided to uninstall AVAST Antivirus 2014 (I had updated this to the latest version when carrying out the Windows 8 to 8.1 update).  Rebooted the machine after uninstall and amazingly I am now able to create custom power profiles and my computer sleeps properly.  Goodbye Avast! and Goodnight!

    Hope this helps someone.

    • Edited by JoeGreyHair Wednesday, October 30, 2013 9:10 PM
    Wednesday, October 30, 2013 7:44 PM
  • powercfg /requestsoverride driver srvnet system worked for me.  Thanks, Hans.

    I have a similar problem to this, and have used the above command which works for me. However, there are consequences if you share files from your PC to others on your network.  Look at the following powercfg /requests trace:

    [DRIVER] \FileSystem\srvnet
    An active remote client has files opened on this machine.

    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.
    [SERVICE] \Device\HarddiskVolume2\Windows\System32\svchost.exe (TermService)

    The srvnet block for the files open entry was initiated when I opened a file from my PC to my Home Server (the above trace is from my Home Server). 

    As a consequence, a srvnet block will be set up if a file is opened across the network.  If this is overridden using the powercfg command, the host PC could go to Standby while you have the file open, which is not desirable. 

    The TermService entry results from a remote session, and would not be blocked.

    My advice is as follows.



    I am uncertain if this is a bug in Windows 8.1, as it seems to have been around since Vista which largely rewrote the driver model in Windows.  However, Microsoft may have tightened up the power management policies in 8.1 to gain better power management on tablets, and this issue may now be more evident because of that, or something they missed during development (a bug).

    Please also see my more extensive post on; search for "Windows 8.1 RTM Update Will Not Go to Standby".

    • Edited by JonM-2 Monday, November 04, 2013 12:26 AM Update
    Monday, November 04, 2013 12:11 AM
  • Windows 8.1 changed my Ethernet Network Driver.  I changed it back without IPV6 enabled and the November 14th, 2013 Windows Updates I received disabled my original Network Driver again even though it is installed in Control Panel, and again, all IPV6 network options were enabled and the computer again would never, ever sleep.

    I fixed this by having to disable IPV6 in TWO places.

    1.  I had to click on Network Icon, then I had to click on Network and Sharing.

    From there, at the top where it says "Connections", I clicked on "Ethernet".

    I clicked on "Properties" and "Unchecked" the Internet Protocol Version 6 (IPV6).

    It was by unchecking the IPV6 step above that finally let my computer sleep.

    2.  Previously, in the same Dialog Box, I also chose the "Configure" button located underneath my Ethernet controller, and on the "Advanced Tab" I had disabled (unchecked) (three) options that referenced "IPV6" connectivity.  From there, I made sure that on the "Power Tab" I checked the option to "Allow the computer to put this device to Sleep". 

    Now, after completing both of the steps, listed above, she sleeps and wakes up from sleep normally.

    The only other problem I have ever had with my computer "not sleeping" is listed below.

    I hope that you and your computer are happy friends again.

    If you run the command "powercfg /requests" in an elevated DOS prompt, you should see "None", "None", None, and None.  My problem here previously was a message that said an "Audio stream was in use" and this prevented my computer from sleeping about a year ago.  I had "Input Monitoring" enabled on my sound card to monitor my microphone through the speakers,  and when I disabled "Input Monitoring", my computer again then slept fine after that.

    I really hope that programmer's in the future will save us all a lot of grief and heartache by "testing" sleep functionality before shipping their software. FYI, "IPV6" is a new internet protocol that at the current time,, is not necessarily a must for most users.  I hope that you can get some zzzz's soon.

    • Proposed as answer by pat100 Tuesday, December 17, 2013 9:52 PM
    Friday, November 15, 2013 11:17 PM
  • You said you "unchecked the Internet ProtocolVersion 6 (IPVS6)".  Is it still unchecked or did you re-check again to have a connection.  Can you still browse the internet by un-checking this feature?
    Sunday, November 17, 2013 6:39 AM
  • I have a related problem:

    windows 8.1 not going into sleep mode in 50% of tries

    My machine is regularly refusing to go into sleep mode even when klicking the specific command. What happens instead is, that the monitor(s) is/are shuting down but hard drive, vent,... is still running, can't be waken up, so i have to shut it down completely to trestart the machine.

    to find out the reson-why, i have those powercfg commands one finds in the net -> no results yet. so i decided tried to make a "testrow".

    I started the machine and regularly send it to sleep especially after every program i started or after every hardware (mouse, second monitor,..)  I attched. 

    I did this for about three hours -> during that test time no problem at all - machine went into sleep mode like a baby.

    Than i worked I while with (an already opened) browser - no new program opened or new hardware attached - and voila after about additional 30 minutes the machine is not going into sleep anymore.

    wtf - anybody an idea or any hints on how to debug this behaviour to find out the evil piece?   

    grateful for any help


    Wednesday, November 20, 2013 12:23 PM
  • I've been having issues with Windows automatic sleep for years. In fact, I think it never worked for me no matter what system I was using (XP, Vista, 7, 8...). I've completely given up on it and I think MS just won't bother to fix it anytime soon.

    I've got a new problem now that makes my computer automatically resume from sleep AND hibernation rigth after it has been put into that state. And WOL is disabled btw.

    Standby features are botched in Windows OS.

    Sunday, December 01, 2013 11:02 AM
  • Most probably there is no just one reason for this problem. In my experience it is caused by a mouse. I have two desktop computers running Windows 8.1 Pro and use two Logitech mice, G700 and Perfomance MX. The computer with G700 has no problem going to sleep, the one with Perfomance MX wakes up immediately after going to sleep IF THE MOUSE IS ON. 

    The problem is definitely not only with the Logitech mouse or the radio receiver it uses. Before I had a wired Razer mouse and had the same problem. Then nothing would help, you cannot unplug the mouse every time you leave! 

    So try putting your computer to sleep and at the same time disconnect/turn off your mouse. If it helps, you know the culprit, even if you cannot do much about fixing it :) Hope this helps at least some.

    • Edited by Proxfesor Wednesday, December 04, 2013 9:02 AM
    Wednesday, December 04, 2013 8:45 AM
  • Friends,

    I managed to fix this issue after reading a fair number of posts in this thread, but this seemed to work for me right out.

    1. Hibernate your PC
    2. When it wakes up (mine did rather immediately), open up CMD
    3. Issue the command "powercfg /lastwake" to see what device / operation woke your computer up. For me, it was "Realtek PCIe GBE Family Controller:
    4. Issue the command: 
    Powercfg -devicedisablewake "Realtek PCIe GBE Family Controller" but replace the words "Realtek....Controller" with whatever your results were. Include the "quotes" around the term.
    5. Try hibernating again.

    Worked for me!

    Friday, December 13, 2013 1:30 PM
  • Hi SmokeyTheBear,

    I have the same problem with Realtek PCIe GBE Family Controller, after using your powercfg /lastwake suggestion, but when I type:

    Powercfg -devicedisablewake "Realtek PCIe GBE Family Controller"

    it says "You do not have permission to enable or disable device wake". Anyone know how I get around this?

    Monday, December 16, 2013 1:23 PM
  • Excellent -

    Billy Colt post:  "disable IPV6 in 4 places"  fixed it for me in Win8.1. Thanks a lot!

    ( The only annoying bit is that I had this problem on another computer about 5 months ago - fixed it after days of struggling - but today I could not remember how I did it - luckily I had a link to this thread - but unluckily I forgot I had it and also where I had stored it!)

    • Edited by pat100 Thursday, December 19, 2013 1:07 PM
    • Proposed as answer by SB Lonestar Saturday, December 28, 2013 2:06 PM
    • Unproposed as answer by SB Lonestar Saturday, December 28, 2013 2:06 PM
    Tuesday, December 17, 2013 9:50 PM
  • If the PC won't sleep due to network problems try this

    Open Control Panel

    Click System

    Click Device Manager

    Find your network adapter

    Click Power Management Tab

    Check allow this computer to turn off the device

    Check allow this device to turn on Computer

    Below this option check allow only magic packet to wake computer

    Worked like a charm. The extender can wake up the PC as well if this is checked.


    Saturday, December 28, 2013 2:14 PM
  • had this problem too. What i had to do was to uninstall some Virtual Machine Player (like Oracle Virtual Box for me) and it just worked. It had something to do with my network adapters. Hope this helps anyone.
    Tuesday, December 31, 2013 12:07 AM
  • Hi. What DID worked for me was to go to the Power Options, set the "Turn Off Display" option to "Never" and set the sleep to desired value. That did the trick.
    • Proposed as answer by SPMenic Monday, March 03, 2014 11:38 PM
    Saturday, February 08, 2014 9:22 PM
  • The following worked for me BUT I use for email and if I have email open in a browser then it won't sleep.  If I close that browser window then it sleeps.  I use a USB wireless network adapter and it was preventing the PC from sleeping but this command fixed that.  Run it from an elevated cmd window.  I'm running Windows 8.1 Pro.  I also usually have VPN sessions running too and it still will go to sleep if I'm away from the PC long enough.

    powercfg -requestsoverride service rasman system

    Monday, February 17, 2014 9:49 PM
  • Tried most of this and it works sometimes and others not. This is a huge Windows problem that has occurred also in earlier versions. Seems there are only 2 answers. 1. Push the sleep button when you leave. 2. Live with it. This thread is obviously not for 99.9% of users to even consider. Miicrosoft seems to have no interest in fixing it. I give up and just push the button or may just let it run for the advantage of faster start and always available For remote via Teamviewer. And no, Wake on LAN almost never works.
    Friday, February 28, 2014 2:38 AM
  • Hi. What DID worked for me was to go to the Power Options, set the "Turn Off Display" option to "Never" and set the sleep to desired value. That did the trick.

    This worked for me...thanks!
    Monday, March 03, 2014 11:39 PM
  • I have actually read through this whole thread, and tried most of the thoughtful suggestions – there is also lots of **** written here.

    The ONLY decent solution that will certainly remove the srvnet from powercfg requests (and cure insomnia) is to disable “File and Printer Sharing from Microsoft Networks” in the NIC configuration. Nothing else really works.

    Also, once srvnet is logged in powercfg request, the only way to remove it seems to be to restart srvnet. Disabling “File and Printer Sharing from Microsoft Networks" will NOT remove the srvnet lock.

    Shame MS still didn't address this issue!

    • Edited by DavorJ Wednesday, March 05, 2014 5:24 PM
    Wednesday, March 05, 2014 5:16 PM
  • Hy,

    I also had BSOD in Windows 8.1 Pro. Installed Eclipse+Android+Emulator+Oracle Virtual Box. Installed MS Visual Studio 2012+Windows Phone 8 SDK + Emulator + Hyper-V .

    I tried many things found on Internet. The one that worked (not found on net, that's why i write it here) was to uninstall Hyper-V that was automatically installed with Windows Phone SDK+Emulators. I uninstalled it from Network -> Change adapter settings-> right click on adapter-> Properties->Hyper-V... I couldn't uncheck it, I had to uninstall it.



    Wednesday, March 12, 2014 3:06 PM
  • I found this thread the same way as many others and tried various things mentioned here. 

    My case is a bit different since the powercfg /requests actually shows nothing so theretically everything should work but does not. And, yes, I do see sleep blockers when they do exist like the infamous steam "open audio stream" issue. Steam does not always kill audio stream for those autoplay-videos they have for games.

    I got the MCE standby tool which is used to diagnose suspend issues in a bit more user-friendly manner. It shows "driver J" as sleep blocker but as it's supposed to be just output from powercfg I'm not sure if that means anything. The tool shows countdown to sleep / idle time proceeding normally but nothing happens when time is up. If I set a really short time limit like 1minute it does in fact work but that's not too convenient.

    One thing worth trying is "standby helper", a tool purpose built to force windows to go to sleep, same as when you hit "sleep" manually. You can find it here 

    User interface is a bit klunky and it's short on instructions but "monitoring" options at least have popups. Basically you can set idle timeout, what is considered "idle" with regards to CPU load and network/disk activity. Indexing service could easily sabotage this app if the limits are too low, on the other hand you don't want backup session interrupted. There's an option to force sleep ie override sleep blocker apps. You can also set a kill-list of apps to close automatically, I'm not 100% sure how useful that would be but author says he puts flash player there. I'm not sure what the "idle count" actually does. At the face of it it seems it would mean a multiplier for the timeout but that makes no sense. 

    Saturday, March 15, 2014 9:37 PM
  • I'm not sure what the "idle count" actually does. At the face of it it seems it would mean a multiplier for the timeout but that makes no sense. 

    I contacted the author on twitter - Idle state is checked every 10 seconds, so idle count means the machine must meet all the configured idle parameters for at least 10 seconds * n. Useful if you play with the disk IO / cpu / network idle settings I presume.
    Tuesday, March 18, 2014 8:59 AM
  • Here is what solved the problem to me on Windows 8.1:

    1- I turned Homegroup off.  That solved the problem just while I had Energy Settings set to Turn off Display in 1 minute and to sleep in 2 min.  However, when I changed the Energy settings to turn off Display in 10 minutes and to sleep in 20 min,  it stopped sleeping automatically again!!

    2- Then I've set the Energy Setting to NEVER turn off the video.  And then it worked back again.  My pc now goes to sleep automatically after 20 min.  This issue is solved now.

    I noticed however that, once in a while during the day, the PC wakes-up "by itself". That doesn't happen during the night when the whole family is sleeping.  What I found is that this happens exactly in the moment when one of the other computers connected to my home network is turned on. The first issue is really  solved now because the computer goes to sleep again after the programmed time.  But then I have a new problem now; It wakes up by itself when another computer is turned on.... 

    My conclusion is: There is no unique solution for everyone using Windows 8.1. It depends on what you have installed and running.

    It is really a shame that Microsoft takes so long to fix such a problem after so many postings.  This thread began with Windows 8 on November 2012 and continues until today March 22nd, 2014  with Windows 8.1 !!   1 year and 4 months !

    • Edited by JosiasMJr Sunday, March 23, 2014 12:51 PM Information added
    Friday, March 21, 2014 5:37 PM
  • It is really a shame that Microsoft takes so long to fix such a problem after so many postings.  This thread began with Windows 8 on November 2012 and continues until today March 22nd, 2014  with Windows 8.1 !!   1 year and 4 months !

    You're aware this is pretty much just a follow-up thread for identical Windows 7 issue? Windows insomnia is common and aggravating problem that dates all the way to Windows 2000 when suspend first became feasible. In my case there is zero indication with powercfg that anything is keeping the machine up and the idle countdown works normally. It just does not sleep. 

    Standby helper works for me.

    Wednesday, March 26, 2014 5:58 PM
  • Hi all,
    Synergy Mouse and Keyboard sharing was my culprit.

    Uncheck Synchronize screen savers, all good.
    Monday, May 05, 2014 8:32 AM
  • Thanks, I disabled defrag and it was the problem, sleep now works fine, I now just manually defrag monthly. My system is windows 8 on an HP Compaq CQ58. Cheers Don.
    Tuesday, May 13, 2014 6:38 AM
  • I had a same issue with my new Win 8.1 x64 on Dell SPS 8700.

    It doesn't go to sleep mode on scheduled time. I checked all possible options mentioned in this forum as well as in others. Unfortunately didn't find the route cause.

    My solution is to download the Sysinternals from here (only psshutdown.exe file is required):

    and create a scheduled task, which will run the following command:

    <PATH_TO_FILE>psshutdown.exe -d

    when the computer is idle for desired period (I set it for one hour), but you can schedule it in any way you need it. Note that "Highest privileges" should be checked in General tab.

    Hope it helps...

    • Proposed as answer by ZTavor Monday, June 23, 2014 1:28 AM
    Monday, June 23, 2014 1:26 AM
  • Your script has solved my problem.
    Sunday, July 13, 2014 2:30 PM
  • I was seeing this:

    C:\Windows\system32>powercfg requests

    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.




    I tried changing "Turn Off Display" to "Never" and it worked at least once.  Prior to that I had change online account to local account and my computer went to sleep on its own for the first time in a long time. 

    Time will tell if the "Never" fix continues to work.

    Monday, July 14, 2014 7:56 PM
  • I modified your script as there are a few issues. Another computer may open a directory, or connect to a printer, which would not  show up in openfiles. Also, after a session goes away, the block may be there for a little time.

    So here is a suggested variation (and since I have short timeouts, it could be run every 5 or 10 minutes):

    @echo off
    set logfile="%TMP%\srvlog.txt"
    set flagfile="%TMP%\openconn.flg"

    if exist %logfile% goto begin
    echo [%date:~4,10% %time%] logfile created>%logfile%

    echo -->>%logfile%
    echo [%date:~4,10% %time%] srvnet check triggered>>%logfile%

    if exist %flagfile% goto recent

    openfiles /Query 2>NUL | FIND /C "INFO: No shared open files found" >NUL
    if errorlevel 1 goto yes_opens
    echo [%date:~4,10% %time%] no open files>>%logfile%

    net session | find /C "There are no entries in the list" >NUL
    if errorlevel 1 goto yes_opens
    echo [%date:~4,10% %time%] no open sessions>>%logfile%

    powercfg -requests | find /C "[DRIVER] \FileSystem\srvnet" >NUL
    if errorlevel 1 goto no_srvnet_block

    echo [%date:~4,10% %time%] **block detected, restarting srv**>>%logfile%
    net stop  /y srv >NUL 2>NUL
    net start /y srv >NUL 2>NUL
    goto :eof

    echo [%date:~4,10% %time%] open files or sessions were detected on the last run, not restarting srv>>%logfile%
    del %flagfile%
    goto :eof

    echo [%date:~4,10% %time%] open files or sessions detected, not restarting srv>>%logfile%
    echo [%date:~4,10% %time%] >%flagfile%
    goto :eof

    echo [%date:~4,10% %time%] no srvnet block detected, not restarting srv>>%logfile%
    goto :eof

    Tuesday, October 14, 2014 3:59 PM
  • powercfg /requestsoverride driver srvnet system worked for me.  Thanks, Hans.



    Not to bump an old thread, but I've had a resurrection of this problem since the latest Windows 10 update (Threshold 2). Going back through my fixes, I read this and wanted to clarify that you *CAN* remove the power requests.

    You do so by not typing the ending qualifier (ie: system). So if you input a powerrequest with:

    powercfg -requestsoverride driver srvnet system

    Then to remove that, you'd type:

    powercfg -requestsoverride driver srvnet

    Sunday, November 15, 2015 9:25 PM
  • I changed it from using openfiles /query to net files so replace that line with
    net files | find /C "There are no entries in the list" >NUL

    also, in win 10 you have to set "Run with highest privilegues" and add password.

    • Proposed as answer by marvf44 Sunday, March 05, 2017 4:56 AM
    • Unproposed as answer by marvf44 Sunday, March 05, 2017 4:56 AM
    Tuesday, March 15, 2016 10:06 AM
  • I'm running 8.1, and lately, for the past few weeks, I have noticed that it won't sleep. The symptoms are the same, running powercfg -requests shows srvnet keeping the system from sleep. I found that dropbox is the culprit here. If I remove dropbox from the starup list so that it doesn't run at boot up, then the srvnet entry in powercfg -requests goes away and the system sleeps again. So I believe that this is a problem introduced by dropbox in its last update as I was previously able to run dropbox and also enter sleep.

    Obviously, if you don't run dropbox, this solution does not apply to you, but if you run netstat, you can see all the connections that your system is using, and any that are open may be the culprit.

    Sunday, March 05, 2017 4:59 AM