locked
Client Security Script Failed to Access Non-MOM API RRS feed

  • Question


  • Hi ,,

    i want to ask about the error below actually my reporting server was working fine but after i changed the communication port number i started getting the below error , and there is no reporting issues in my server , hope you can help me to solve that .

    Error shown as below :

    Description:
    When the MOM server processed a Client Security script, the script failed to access a non-MOM API.
    - API name: GetRegistryValue(REG_SQL_SERVER_FOR_ONEPOINT_DB)
    - Error code: 429
    - Error description: ActiveX component can't create object
    - Rule name: Malware Outbreak Parameters - Time Slot 2
    - Script name: Microsoft Forefront Client Security - Malicious Software Outbreak

    To investigate and resolve this incident:
    1. Check to see if this problem is persistent. You can do so by reviewing the MOM Operator Console and looking for similar alerts.
    2. If the problem is not persistent, this alert was likely caused by a transient issue and no action is needed.
    3. If the problem persists, look for other related events or indications for the problem in the MOM event view and in the Windows event viewer, and resolve any issues discovered.

    For more information, refer to the Product Knowledge tab.
    Name: Client Security Script Failed to Access Non-MOM API
    Severity: Error
    Resolution State: New
    Domain: CPC
    Computer: VS-CPC-INF-FF
    Time of First Event: 2/7/2010 10:46:00 AM
    Time of Last Event: 2/7/2010 10:46:00 AM
    Alert latency: -5 min, -51 sec
    Problem State: Investigate
    Repeat Count: 0
    Age:
    Source: Microsoft Forefront Client Security Microsoft Forefront Client Security Script Name = Microsoft Forefront Client Security - Malicious Software Outbreak API Name = GetRegistryValue(REG_SQL_SERVER_FOR_ONEPOINT_DB) Error Number = 429
    Alert Id: c1ff7855-1082-480b-9d45-cdca27bae374
    Rule (enabled): Microsoft Forefront Client Security\Common Rules\Client Security Script Failed to Access Non-MOM API
    Sunday, February 7, 2010 7:34 AM

Answers

  • Hi,

    Just for your information :

    By default, agents communicate with the MOM Management Server through port 1270. Consider changing the communication port (1270) to a port that is known only to the administrators of your organization. Changing the communication port impacts agents differently, depending on how they are installed:

    • If you change the port number after you install agents manually, then you must rerun the manual agent setup program on the agent computers to point to the new port.

    • Agents that are installed remotely will begin communicating through the new port after they receive updated configuration settings (every one minute, by default). No additional configuration is necessary on agents that are installed remotely.

    Finally, be sure to verify that the port you specify is enabled through the routers on the wide area network (WAN) link.

    To change the communications port on the MOM Management Server

    1. In the left pane, expand Administration, and click Global Settings.

    2. In the right pane, right-click Communications, and then select Properties.

    3. On the Communications tab, change the port number to the desired port.

    4. Restart the MOM service on the MOM Management Server.


    Bechir Gharbi. MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS ConfigMgr
    • Proposed as answer by Nick Gu - MSFT Thursday, February 11, 2010 7:26 AM
    • Marked as answer by Nick Gu - MSFT Sunday, February 21, 2010 4:44 AM
    Monday, February 8, 2010 1:50 PM