locked
Win 7 Explorer auto-resize all columns ? Was this ever solved ? RRS feed

  • Question

  • I'm finding (and have been since Windows 7 was launched) that the columns in detail view are VERY often not set wide enough for the contents of the folder. It's not just the name, it's even the date or size too.

    So I might have a file that's 145GB and instead of seeing 145,321,678 KB I see 145,321,6...

    and I get the same for file type and for file name and for date modified.

    It's completely understandable if there's not enough room. After all, what else should it do?

    But if I've got my folder contents area set at for example 1200 pixels wide, and I need 500 to accommodate the longest filename, 150 for date modified, 150 for file size, and 200 for type that's a total of 500+150+150+200 = 1000. Easily enough, and with 200 pixels to spare.

    What I would expect in that situation is that Explorer would be clever enough to figure out "hey, I can maximize each of the columns to accommodate the widest values in the folder". But instead it decides to not do that. It'll size the columns slightly too small if we're lucky and far too small if we're unlucky, and it'll leave (in that example above) 300 or 400 pixels unused at the right side.

    Sunday, December 10, 2017 6:18 PM

Answers

  • Hi,

    I totally understand what you mean. From the official blog, we can see that "size all columns to fit" can't be the default. https://blogs.msdn.microsoft.com/oldnewthing/20120925-00/?p=6503/

    You can set it manually:

    However, "apply to folders" yet will not help with "Size all columns to fit" since how it sizes them is specific to the currently opened folder in Windows Explorer. You can also use the hotkey Ctrl++ to achieve the goal.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by dd_991 Monday, December 11, 2017 10:07 AM
    Monday, December 11, 2017 5:01 AM

All replies

  • Hi,

    I totally understand what you mean. From the official blog, we can see that "size all columns to fit" can't be the default. https://blogs.msdn.microsoft.com/oldnewthing/20120925-00/?p=6503/

    You can set it manually:

    However, "apply to folders" yet will not help with "Size all columns to fit" since how it sizes them is specific to the currently opened folder in Windows Explorer. You can also use the hotkey Ctrl++ to achieve the goal.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by dd_991 Monday, December 11, 2017 10:07 AM
    Monday, December 11, 2017 5:01 AM
  • Thanks Vivian. Naturally I'm disappointed but at least I know there isn't a solution out there that I never tried hard enough to find. I wasn't even taking advantage of the "Size All Columns to Fit" option, I was manually resizing the columns all this time, so that's going to be an improvement :)
    Monday, December 11, 2017 10:09 AM
  • Works OK. 
    Thanks
    ETienneVermeiren

    Friday, October 4, 2019 7:21 AM