none
SQL Server replication requires the actual server name to make a connection to the server. Specify the actual server name (Replication.Utilities) RRS feed

  • Question

  • Canot create subscription

    Please help me

    I get the error code is:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to 89.19.13.138.

    ------------------------------
    ADDITIONAL INFORMATION:

    SQL Server replication requires the actual server name to make a connection to the server. Specify the actual server name, '94DE80ACD308'. (Replication.Utilities)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    PLEASE CHECK THIS LINKS

    my server info : http://www.tolgasimsek.com/11.jpg

    and

    error screen : http://www.tolgasimsek.com/22.jpg


    • Edited by TolgaSimsek Wednesday, September 10, 2014 5:05 PM
    Wednesday, September 10, 2014 1:58 PM

Answers

  • This can happen when the Publisher or Subscriber hostname has been renamed at some point.

    On the publisher and subscriber execute this:

    SELECT @@SERVERNAME

    On both the publisher and subscriber execute this:

    SELECT * FROM sys.servers

    Also, on both publisher and subscriber execute this from the command prompt:

    hostname

    You should see a mismatch in names.  If so, drop your publication and disable distribution.  Then execute sp_dropserver and sp_addserver and restart sql services.

    sp_dropserver <old_name>;
    GO
    sp_addserver <new_name>, local;
    GO

    Then reconfigure replication.

    Replication requires the actual server name - Incorrect server name


    Brandon Williams (blog | linkedin)

    Wednesday, September 10, 2014 4:33 PM
    Moderator

All replies

  • Hello,

    This may happen if you try it from a remote computer. Could you try to the same by login on the server and by using the management tools of the SQL Server instance?

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    • Marked as answer by TolgaSimsek Wednesday, September 10, 2014 2:30 PM
    • Unmarked as answer by TolgaSimsek Wednesday, September 10, 2014 2:30 PM
    Wednesday, September 10, 2014 2:23 PM
    Moderator
  • I am trying to subscribe to a remote server already. 

    but the remote server and settings belong to me, although I could not complete.
    Wednesday, September 10, 2014 2:29 PM
  • Tolga,

    it won't work if you do not connect to the instance using the actual server name. This can be obtained through the following code.

    select @@servername

    Use this name to connect to the instance in management studio. If your client cannot resolve to this name, you can either add an alias on cliconfg for the native client OR add the name to your hosts file, located under C:\Windows\System32\drivers\etc. e.g.:   89.19.13.138      myservername

    Wednesday, September 10, 2014 2:32 PM
  • Hello,

    Please try not to do it from a remote computer, log on to the server locally and then do it.

    The following thread provides some workarounds too:

    http://www.sqlservercentral.com/Forums/Topic343045-291-1.aspx

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, September 10, 2014 2:33 PM
    Moderator
  • Please note that you CAN access replication functionality remotely, all you have to do is to connect using the actual server name in management studio. If you cannot resolve the DNS name to the IP address, use the methods I listed before.

    It won't work if you try to connect using the IP address, even locally.
    Wednesday, September 10, 2014 2:36 PM
  • Did the server renamed after the SQL installation?

    Refer the below link

    Try to understand the issue before jumping into remedies section

    http://www.cryer.co.uk/brian/sqlserver/replication_requires_actual_server_name.htm

    --Prashanth

    Wednesday, September 10, 2014 2:36 PM
  • Did the server renamed after the SQL installation?

    Refer the below link

    Try to understand the issue before jumping into remedies section

    http://www.cryer.co.uk/brian/sqlserver/replication_requires_actual_server_name.htm

    --Prashanth


    The IP address is in the error message. He tried to connect using the IP "89.19.13.138". I've been through this error before.

    Wednesday, September 10, 2014 2:50 PM
  • This can happen when the Publisher or Subscriber hostname has been renamed at some point.

    On the publisher and subscriber execute this:

    SELECT @@SERVERNAME

    On both the publisher and subscriber execute this:

    SELECT * FROM sys.servers

    Also, on both publisher and subscriber execute this from the command prompt:

    hostname

    You should see a mismatch in names.  If so, drop your publication and disable distribution.  Then execute sp_dropserver and sp_addserver and restart sql services.

    sp_dropserver <old_name>;
    GO
    sp_addserver <new_name>, local;
    GO

    Then reconfigure replication.

    Replication requires the actual server name - Incorrect server name


    Brandon Williams (blog | linkedin)

    Wednesday, September 10, 2014 4:33 PM
    Moderator
  • Just been caught by this problem. I don't know the history of the box I am working on but the dropdown list gives:

    myservername

    myservername\

    myservername\INST2

    Transpires SSMS didn't like the registration myservername\ for replication although everything else works

    Registering the connection myservername sorted the problem out.

    Monday, November 4, 2019 3:17 PM