none
Windows Server 2008 SP2 guest VM on Windows 10 Hyper-V host - Updating Integration Services

    Question

  • Hi!

    I am implementing a lab in my Windows 10 Hyper-V host running a Windows Server 2008 SP2 guest VM. The first time I run the VM, it detected several new hardware, that I think they can be resolved by installing the Integration Services.

    I know that Windows 10 and Windows Server 2016 do not have vmguest.iso anymore and now it can be installed using Windows Update service, but my problem is that I can not connect the VM to Internet.

    So the question is, How can Integration Services be installed on the VM if it has not connection to Internet?

    thanks in advance


    Cristian L Ruiz

    Thursday, February 09, 2017 2:56 AM

Answers

  • Hi Cristian,

    >>How can Integration Services be installed on the VM if it has not connection to Internet?

    I'm afraid not possible as far as I know.

    I have seen posts that someone copied the vmguest.iso from Server 2012 R2 and installed on the VM. It seems to work, but it is not an officially supported operation. You could test the workaround in lab.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Cristian Ruiz Friday, February 10, 2017 3:25 PM
    Thursday, February 09, 2017 6:31 AM
    Moderator

All replies

  • Hi Cristian,

    >>How can Integration Services be installed on the VM if it has not connection to Internet?

    I'm afraid not possible as far as I know.

    I have seen posts that someone copied the vmguest.iso from Server 2012 R2 and installed on the VM. It seems to work, but it is not an officially supported operation. You could test the workaround in lab.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Cristian Ruiz Friday, February 10, 2017 3:25 PM
    Thursday, February 09, 2017 6:31 AM
    Moderator
  • Thanks Leo,

    Finally I installed it using the vmguest.iso image from a Server 2012 R2, and it worked.


    Cristian L Ruiz

    Friday, February 10, 2017 3:27 PM