none
Change Journal not active error on SQL DB RRS feed

  • Question

  • I have a SQL server that will not back up any of the DBs on it at all. We are running DPM 2012 RTM and SQL 2008 R2 with the latest SP and CU. I can back up files on C:, but when I try to back up a SQL DB, all I get is:

    Change journal not initialized or is the wrong size (ID 30118 Details: The volume change journal is not active (0x8007049B))

    I have other SQL servers backing up with no issues on the same DPM server, so I don't think the issue is in there. I have created a change journal manually and that didn't help. At that point, I got different errors, but it still wouldn't back up. I have removed the client a few times, rebooted, reinstalled, and I still cannot get a good consistency check. Any ideas?

    Thursday, May 10, 2012 4:13 PM

Answers

  • Hi,

    As a "workaround" you can try this, however, recovery points will take as long as a consistency check takes.

    A) On the protected server, browse to the registry path HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0.
    B) Create a DWORD registry value called "ForceFixup" and set it to 0x1.
    C) Restart the DPMRA service on the protected server.
    D) On the DPM server, re-run a consistency check and future recovery points should work.

    Once you get it consistent and a few recovery points made, try deleting the key and see if ti works after that.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 5:53 PM
    Moderator
  • Yes! Score! So that key didn't actually work, but it got me to an error that led me to the problem.

    The DPM job failed for SQL Server 2008 database because the SQL Server instance refused a connection to the protection agent.

    So apparently, SYSTEM was not a sysadmin on these SQL instances. I wonder if that perm changed on 2012? I was also under the impression that these are 2008 R2 DBs. I found out that they are actually 2012. Are there any known issues with DPM 2012 and SQL 2012? Thanks for your help!!

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 6:23 PM
  • Hi,

    Well, it mask the problem with the dpm filter bitmap, and got you further.  DPM 2012 does support protecting SQL 2012 but we do not yet support the "always on" feature.   We plan on supporting that in SP1.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 6:31 PM
    Moderator

All replies

  • Hi,

    <snip>
    At that point, I got different errors, but it still wouldn't back up.
    >snip<

    What are those different errors ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, May 12, 2012 11:14 PM
    Moderator
  • Different things, like the journal is corrupt or that it's busy, etc. Nothing consistent or anything that makes sense.
    Tuesday, May 15, 2012 4:34 PM
  • Try running this batch file and see if it ever stops running.  Change the drive letter to the volume reporing the USN error(s).

    <checkusn.cmd>

    cls
    echo on
    :again
    fsutil usn queryjournal c:
    IF %errorlevel% NEQ 0 goto Error
    fsutil usn enumdata 1 0 1 c:
    IF %errorlevel% NEQ 0 goto Error
    goto again
    :Error
    Time /T 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 15, 2012 4:48 PM
    Moderator
  • So I'm assuming I'll have to manually setup the change journal again? The DPM client is installed and after running the batch file, it's saying the journal is still not active.
    Tuesday, May 15, 2012 4:58 PM
  • It ran for quite a while and didn't finish. How long should it run?
    Tuesday, May 15, 2012 6:11 PM
  • it should run forever as long as there are no problems with the usn journal - so now protect the SQL db and see if we get good backups, and if not, does the batch file error out.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 15, 2012 7:35 PM
    Moderator
  • Change Tracking has been marked inconsistent due to one of the following reasons
    1. Unexpected shutdown of the protected server
    2. Unforeseen issue in DPM Bitmap failover during cluster failover. (ID 30500)

    That is the error I am getting on the consistency check now, with manual journals created. It is a SQL cluster and all nodes are online. And the DB did not fail over.

    Tuesday, May 15, 2012 7:41 PM
  • And the script is still running.
    Tuesday, May 15, 2012 8:10 PM
  • It sounds like the DPM Filter Driver bitmap is corrupt.

    Recreate the DPM bitmap on the protected server. From an elevated command prompt, run the following commands on the protected server to try to recreate the DPM bitmap for the volume.

    Fltmc detach dpmfilter <drive letter of the volume>:

    Then run:
    Fltmc attach dpmfilter <drive letter of the volume>:

    Run a new Consistency check for the datasources and it should now complete successfully.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 15, 2012 8:14 PM
    Moderator
  • DPM is unable to continue protection for <SQL server name and instance> on SQL Server <cluster server> because the change tracking information is corrupt (ID 30156 Details: Do not attach the filter to the volume at this time (0x801F000F))

    Now this....

    Tuesday, May 15, 2012 8:58 PM
  • I could not duplicate this using the same steps I provided.  Do you have any filter drivers listed when you run FLTMC from command prompt ?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Tuesday, May 15, 2012 9:28 PM
    Moderator
  • Filter Name                     Num Instances    Altitude    Frame
    ------------------------------  -------------  ------------  -----
    DpmFilter                               4       385300         0
    MpFilter                               17       328000         0
    luafv                                   1       135000         0
    Tuesday, May 15, 2012 9:28 PM
  • Yeah, I would bet you can't duplicate it. I have several other SQL clusters backing up with no issues. It's just this one cluster, for some odd reason. Any ideas?
    Wednesday, May 16, 2012 5:47 PM
  • Hi,

    As a "workaround" you can try this, however, recovery points will take as long as a consistency check takes.

    A) On the protected server, browse to the registry path HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0.
    B) Create a DWORD registry value called "ForceFixup" and set it to 0x1.
    C) Restart the DPMRA service on the protected server.
    D) On the DPM server, re-run a consistency check and future recovery points should work.

    Once you get it consistent and a few recovery points made, try deleting the key and see if ti works after that.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 5:53 PM
    Moderator
  • Yes! Score! So that key didn't actually work, but it got me to an error that led me to the problem.

    The DPM job failed for SQL Server 2008 database because the SQL Server instance refused a connection to the protection agent.

    So apparently, SYSTEM was not a sysadmin on these SQL instances. I wonder if that perm changed on 2012? I was also under the impression that these are 2008 R2 DBs. I found out that they are actually 2012. Are there any known issues with DPM 2012 and SQL 2012? Thanks for your help!!

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 6:23 PM
  • Hi,

    Well, it mask the problem with the dpm filter bitmap, and got you further.  DPM 2012 does support protecting SQL 2012 but we do not yet support the "always on" feature.   We plan on supporting that in SP1.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by iclay Wednesday, May 16, 2012 6:32 PM
    Wednesday, May 16, 2012 6:31 PM
    Moderator