none
Outlook 2016 Advanced Search not working properly

    Question

  • We have a terminal server Windows 2012 R2 with Office 2016 connecting to O365 for email.

    The Outlook simple search works and highlights the relevant email however when i use the Advanced Find i receive no return.

    I start Outlook in safe mode and both the simple search and Advanced Find work?

    I went the Comms add-in area and found the Windows Search email indexer unchecked and not loaded - I check the box but it never loads?

    Does anyone have any suggestions?

    Tuesday, March 28, 2017 4:36 AM

All replies

  • Hi,

    Did you get any error message when it failed to search via Advanced Find?

    There used to have a known issue with Advanced Find in Outlook and the issue has been fixed in build 16.0.7167.2040 and higher. I'd recommend you update your Outlook to the latest version and then see whether this issue continues.

    Please let me know the result.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 28, 2017 7:37 AM
    Moderator
  • That comm add-in was disabled in Outlook 2010 and later. 2010 and 2013 have their own search. 2016 has the option to use Windows for search again, but it's not associated with that comm add-in.
    Tuesday, March 28, 2017 4:28 PM
  • Still the same after downloading and installing all current updates
    Friday, March 31, 2017 6:21 AM
  • The Windows search is including Outlook for all the users
    Friday, March 31, 2017 6:22 AM
  • You are referring to PST files - there are only ost files on the terminal server
    Friday, March 31, 2017 6:23 AM
  • Still the same after downloading and installing all current updates

    What build are you using now after installing all updates?

    Are you using cached Exchange mode or online Exchange mode? We may also try to switching between the two modes and see the result.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 3, 2017 2:08 AM
    Moderator