locked
Unable to restore default sort order of Libraries RRS feed

  • Question

  • I think I may have found a bug in windows 7, minor, but it's there.  I'm using RTM Enterprise.

    When you create a new library and include several folders, the dialog to manage the library allows you to sort the folders.  This sort order is reflected in the tree navigation in the left, as well as the display of folders in the main explorer window.  The default setting uses "Arrange: Folder", which creates logical groupings of the included folders.  If you create a library with two included folders, the explorer's main window would show a column for each included folder.

    First thing to note, and this is where I think the bug is, if you were to open "View -> Group by", you'll notice no group-by setting is used but Ascending is selected.  If you change the group-by setting to something else, ie "Name" and then reset it back, there's no way to get the original grouped-sorted value back.

    Although you can add "Folder Path" to the details and the group-by this value, it has the same appearance but it does not reflect the user's defined library sort order.

    Sunday, October 4, 2009 7:00 PM

Answers

  • I know that after change the Group By value, we cannot change it back to original style in Group By setting.

     

    There is an "Arrange By" option on right above of the window. Click on it and choose "Clear Changes" can help us back to original style.

    Friday, October 9, 2009 2:27 AM

All replies

  • I know that after change the Group By value, we cannot change it back to original style in Group By setting.

     

    There is an "Arrange By" option on right above of the window. Click on it and choose "Clear Changes" can help us back to original style.

    Friday, October 9, 2009 2:27 AM
  • Yes, I'm quite aware of the Clear Changes feature.  That only works with the current changes you've made for this session.  Once it's changed -- the original style in Group By is GONE.

    This is a bug in Windows 7 -- the only way to get the default sort order of the Library back is to delete it and recreate it.
    Thursday, October 15, 2009 2:45 PM
  • I will report this issue to see if there is any update will be released to fix it. Thank you for your time.
    Friday, October 16, 2009 7:54 AM
  • I too have this problem with Win7 Home Premium 64bit.
    Tuesday, March 9, 2010 5:46 PM
  • Here's what I found that works even better than deleting and rebuilding:

     

    Go into the libraries directory.

    Right-click the affected library.

    Drag to any empty space in the directory window and release.

    When the context-specific menu pops up, choose "Copy here."

    Voila!  Library copied with default grouping restored!

    Delete the de-grouped library and rename the new library with the old library name.

    • Proposed as answer by Absurdist Saturday, April 23, 2011 8:44 AM
    Saturday, April 23, 2011 8:43 AM
  • Its sad tht we have to first play around then search the net to find something which is right there! :| The ui has reamined much the same with the number of features increasing and ... no out of the box thinking.
    Tuesday, April 26, 2011 3:02 AM
  • I have this problem too, but your answer doesn't help as the 'Clear Changes" option does not appear for my Music library.

    I can't believe that it's 2012 and this bug has still not been resolved.

    Saturday, September 8, 2012 1:24 AM
  • 1. Show the column whose property name is System.ItemSearchLocation.

    I don't know the column name of English version. Maybe Search Location.

    2. Group by the column.

    Monday, December 10, 2012 4:17 PM