locked
Exchange Cached Mode Settings not Applying to Outlook 2016 (365 ProPlus) RRS feed

  • Question

  • Hi Guys,

    No matter what i do; using the Outlook 2016 GPO settings or creating registry keys, the Cached Exchange Mode settings aren't applying to Outlook. ALL other GPO's take affect. Including policies in the same GPO as the Cached Exchange Mode settings.

    "Use Cached Exchange Mode" remains un-ticked, and the slider is always set to "All". When i tick the box it doesn't enable the slider.

    I've been working on this for two days straight. I've been deleting the local and roaming profile every time i make a change.

    I've enabled regedit for the test account and i can see the keys are created under HKCU\SOFTWARE\Policies\Microsoft\office\16.0\outlook\cached mode

    cachedexchangemode = 2
    syncwindowsettings = 1
    syncwindowsettings = 0

    I've seen conflicting information about where the keys should be so added registry keys to the same policy. Creating the keys under: HKCU\SOFTWARE\Microsoft\office\16.0\outlook\cached mode

    Outlook is the latest version of 365 ProPlus, deployed with ODT. I've also tried uninstalling that, and installing Office 2016 Pro and have the same problem.

    I've tried disabling all other GPO's and created a new policy only containing those three settings and enforcing the policy.

    I've been using rsop/gpresult/policy wizard/registry to verify of the GPO's and policies are applying the the test user.

    I've double checked loopback processing and GPO assignment/permissions

    I've even built a new server.

    I've deleted the office2016 adml/admx files of the domain controllers, downloaded new versions and copied them in. 

    I've run out of things to test.

    Thanks,

    BR

    Friday, May 24, 2019 5:32 AM

Answers

  • Hi,

    Thanks for your reply.

    In this situation, please try the steps below and see if there is any difference.

    1. User Configuration\Policies\Administrative Templates\Microsoft Outlook 2016\Account Settings\Exchange\Cached Exchange Mode\Cached Exchange Mode\Cached Exchange Mode (File | Cached Exchange Mode)
    2. User Configuration\Policies\Administrative Templates\Microsoft Outlook 2016\Account Settings\Exchange\Cached Exchange Mode\Cached Exchange Mode\Use Cached Exchange Mode for new and existing Outlook profiles
    3. Or check the following reg key.
      Open regedit.exe and navigate to following key
      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\cached mod
      Create a new DWORD key and name it "Enable"
      DWORD: Enable
      Now set the value of the key as "1"

      This may require a reboot to take effect.


    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    Friday, May 31, 2019 8:46 AM

All replies

  • Hi,

    Is this a problem that has only recently occurred?

    How do you judge that your Outlook is not in cached mode? 

    >> "Use Cached Exchange Mode" remains un-ticked, and the slider is always set to "All". When i tick the box it doesn't enable the slider.
    Do you mean the "Use Cached Exchange Mode” Option is Grayed Out or you can't start your Outlook in cached mode even if you have checked the option?

    Besides, it is suggested to create a new Outlook profile via Control Panel > Mail and see if there is any difference.

    If possible, you can also configure your account on another computer and test again.

    Any update, please feel free to post back.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    Monday, May 27, 2019 6:48 AM
  • Hi Aiden,

    It's been an issue since we built the Server 2016/Office 2016 UAT environment. Our production environment is Server 2012R2 and Office 2013 and we don't have any GPO problems like this.

    >> How do you judge that your Outlook is not in cached mode? 
    Outlook is displaying more than the 1 month of mail set by registry and GPO. Also there's no OST. It also says "online mode" or something similar in the status bar.

    >> Do you mean the "Use Cached Exchange Mode” Option is Grayed Out or you can't start your Outlook in cached mode even if you have checked the option?
    No it's not grayed out. If i go in to the Account settings i can manually tick "use cache exchange mode". When i open Outlook next it's in cached mode.

    >> Besides, it is suggested to create a new Outlook profile via Control Panel > Mail and see if there is any difference.
    I'm deleting the local and roaming profile each time, to completely clear any settings before login.

    >> If possible, you can also configure your account on another computer and test again.
    I've built three Server 2016 boxes now (from scratch, not using an image)

    It's something funky going on with Group Policy and/or Outlook 2016
    I've even created a new GPO which ONLY contains "
    Cached Exchange Mode (File | Cached Exchange Mode)" = Download full items and "Use Cached Exchange Mode" = 1 month AND linked it to an new OU only containing that object with blocked inheritance and "Use Cached Exchange Mode" is STILL unticked in Outlook 2016 > Account Settings



    • Edited by BBRoberts Wednesday, May 29, 2019 3:42 AM words
    Wednesday, May 29, 2019 3:26 AM
  • Hi,

    Thanks for your reply.

    In this situation, please try the steps below and see if there is any difference.

    1. User Configuration\Policies\Administrative Templates\Microsoft Outlook 2016\Account Settings\Exchange\Cached Exchange Mode\Cached Exchange Mode\Cached Exchange Mode (File | Cached Exchange Mode)
    2. User Configuration\Policies\Administrative Templates\Microsoft Outlook 2016\Account Settings\Exchange\Cached Exchange Mode\Cached Exchange Mode\Use Cached Exchange Mode for new and existing Outlook profiles
    3. Or check the following reg key.
      Open regedit.exe and navigate to following key
      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\outlook\cached mod
      Create a new DWORD key and name it "Enable"
      DWORD: Enable
      Now set the value of the key as "1"

      This may require a reboot to take effect.


    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    Friday, May 31, 2019 8:46 AM
  • Hi Aiden,

    Step 3 did the trick. I had to create the DWORD "Enable" (via GPO) for it to work.

    Option/Step 1 and 2 didn't make any difference.

    Thanks,

    BR

    Wednesday, June 5, 2019 4:03 AM