none
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID RRS feed

  • Question


  • I am receiving the following error in the Event Viewer from the source DistributedCOM (Windows 8.1 64 bit) :

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID class identitification
    {C2F03A33-21F5-47FA-B4BB-156362A2F239}
     and APPID identification
    {316CDED5-E4AE-4B15-9113-7055D84DCC97} 
     to the user Lenovo\Ewa with security identification SID
    (S-1-5-21-1287633286-651115146-4152900111-1001) from the address LocalHost (using
    LRPC) acting in the application container with identity SID
    ZinioLLC.Zinio_2.1.0.317_x64__0q6dqzpp40p2e
    (S-1-15-2-720185855-2675332291-2976434075-758544043-626028312-300598871-2309835828.

    This security permission can be modified using the Component Services administrative tool.

    It regards Zinio Reader application.

    Please advice how can I fix the problem.

    Thanks and best regards, Ewa

    Sunday, March 22, 2015 6:50 PM

Answers

  • Hi Ewa,

    It's just a example instead of your real ID.

    The ID of yours {316CDED5-E4AE-4B15-9113-7055D84DCC97} must be in that list. Have you attempt to find it?

    I have search it on my lab computer(Windows 8.1)as below:


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Friday, March 27, 2015 9:43 AM
    Friday, March 27, 2015 8:27 AM
    Moderator
  • Hi Ewa,

    You could change owner firstly as below steps:

    1. Open the registry editor to the following key - HKEY_CLASSES_ROOT\AppID\{316CDED5-E4AE-4B15-9113-7055D84DCC97}.

    2. Change the permissions on the key itself by right-clicking on the {316CDED5-E4AE-4B15-9113-7055D84DCC97} key, and selecting "permissions".

    3. This will open up a permissions dialog box. Click the "Advanced" button.

    4. The key is owned by trustedinstaller. This needs to change before we continue, so click the "Change" link.

    5. Assuming the account you're using is part of the Administrators group, just type in "Administrators" in the box and click the "OK" button.

    6. Click the "Apply" button, then click the "OK" buttons until the permissions dialog window closes.

    7. You will need to right-click the registry key again (from step 2) and select "Permissions" again from the list.

    8. With "Administrators" highlighted, click to place a check into the "Full Control"/"Allow" box.

    9. Click the "Apply" button, then click "OK" again until the permissions dialog window closes.

    After done, run dcomcnfg as Administrator, you would see as below, continue the steps in the previous reply we discussed.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Wednesday, April 1, 2015 5:05 PM
    Monday, March 30, 2015 9:34 AM
    Moderator
  • Hi,

    Yes, this is aiming at change the owner of this file.

    You also could refer to this official document to confirm your steps:

    Take Ownership of a File or Folder

    https://technet.microsoft.com/en-in/library/cc753659.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Thursday, April 2, 2015 2:43 PM
    Thursday, April 2, 2015 9:15 AM
    Moderator

All replies

  • Hi,

    Try this:

    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID -> Right Click -> Properties and select the Security tab.
    4. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account user Lenovo\Ewa  and set local launch and local activation.
    5. Restart the application Service linked to this Application ID or restart the server and monitor.

    For more information, please refer to this article:

    https://support.microsoft.com/en-us/kb/899965

    Note: this is applied to Windows 8.1.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, March 24, 2015 2:36 AM
    Moderator
  • Hi,

    Thanks for you reply. Would like to mention that the ID of my app. is different than given by you ID {961AD749-64E9-4BD5-BCC8-ECE8BA0E241F} and it is  :

    {316CDED5-E4AE-4B15-9113-7055D84DCC97}

    Have tried to find my application in  DCOM configuration  but it is not listed (those given by you as well).

    Would appreciate if you can still give some advices.

    Thanks and best regards,

    Ewa

    Tuesday, March 24, 2015 4:56 PM
  • Hi Ewa,

    It's just a example instead of your real ID.

    The ID of yours {316CDED5-E4AE-4B15-9113-7055D84DCC97} must be in that list. Have you attempt to find it?

    I have search it on my lab computer(Windows 8.1)as below:


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Friday, March 27, 2015 9:43 AM
    Friday, March 27, 2015 8:27 AM
    Moderator
  • Hi Karen,

    Thank you very much for your help and reply.

    Have found this Application but there is a problem with Security tab, it is not possible to edit and make any changes.

    Would appreciate your further assistance and advice.

    Thanks and best regards,

    Ewa

    Friday, March 27, 2015 9:47 AM
  • Hi Ewa,

    You could change owner firstly as below steps:

    1. Open the registry editor to the following key - HKEY_CLASSES_ROOT\AppID\{316CDED5-E4AE-4B15-9113-7055D84DCC97}.

    2. Change the permissions on the key itself by right-clicking on the {316CDED5-E4AE-4B15-9113-7055D84DCC97} key, and selecting "permissions".

    3. This will open up a permissions dialog box. Click the "Advanced" button.

    4. The key is owned by trustedinstaller. This needs to change before we continue, so click the "Change" link.

    5. Assuming the account you're using is part of the Administrators group, just type in "Administrators" in the box and click the "OK" button.

    6. Click the "Apply" button, then click the "OK" buttons until the permissions dialog window closes.

    7. You will need to right-click the registry key again (from step 2) and select "Permissions" again from the list.

    8. With "Administrators" highlighted, click to place a check into the "Full Control"/"Allow" box.

    9. Click the "Apply" button, then click "OK" again until the permissions dialog window closes.

    After done, run dcomcnfg as Administrator, you would see as below, continue the steps in the previous reply we discussed.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Wednesday, April 1, 2015 5:05 PM
    Monday, March 30, 2015 9:34 AM
    Moderator
  • Hi Karen

    Thank you very much for your detailed reply.

    Have started to the steps with the registry and now I am at the point 5 :

    "5. Assuming the account you're using is part of the Administrators group, just type in "Administrators" in the box and click the "OK" button."

    As all have in Polish have done screen shot please only inform - this "administrators" I have to type into the white fileld /from the right side - get when cliked "change trustedinstaller" in point 4/?

    As regards registry I am always very careful to avoid problems.

    Thanks and best regards,

    Ewa

    Wednesday, April 1, 2015 5:20 PM
  • Hi,

    Yes, this is aiming at change the owner of this file.

    You also could refer to this official document to confirm your steps:

    Take Ownership of a File or Folder

    https://technet.microsoft.com/en-in/library/cc753659.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EWAGOSIA Thursday, April 2, 2015 2:43 PM
    Thursday, April 2, 2015 9:15 AM
    Moderator
  • For me, this is the Windows Insider Service. Everything in the Security tab is grayed out. I cannot install any Office updates and get this message in the Event Viewer:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
    {3185A766-B338-11E4-A71E-12E3F512A338}
     and APPID 
    {7006698D-2974-4091-A424-85DD0B909E23}
     to the user JARWINDOWS10-RE\jar_2 SID (S-1-5-21-848177387-43054893-382191460-1004) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.Cortana_1.8.3.14986_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-1861897761-1695161497-2927542615-642690995-327840285-2659745135-2630312742). This security permission can be modified using the Component Services administrative tool.

    Saturday, December 10, 2016 5:06 PM
  • Hi Karen, 

    Thanks for the detailed write-up!

    I am experiencing the same issue except mine is a Runtime Broker that keeps crashing. When I get to step 9 the launch and activate permissions is greyed out. I followed this thread: https://social.technet.microsoft.com/Forums/windows/en-US/81afec37-1906-4048-a209-2db1b160f7e3/dcom-config-security-tab-greyed-out-typical-measures-not-working

    However, I am stuck on not being able to edit the fields. Thoughts?

    Tuesday, April 17, 2018 1:00 AM
  • Thank you
    Tuesday, September 25, 2018 12:36 PM