none
Group Policy not being applied on computers

    Question

  • Hi,

    I recently configured Hyper-V in my org. Now i am trying to apply the policies but it does not seems to be working.

    If i apply the wallpaper or screensaver policy to the user's configuration it's working, however computer policies not working at all. I tried to get the RSoP  and gpresult but its's showing users policy only and computer configuration empty


    Please help me on this


    Regards, Kalyan




    • Edited by kalyan12131 Tuesday, March 21, 2017 11:07 AM
    Monday, March 20, 2017 5:19 PM

All replies

  • Hi Kalyan,

    >> I tried to get the RSoP  and gpresult but its's showing users policy only and computer configuration empty

    Try using admin account to login then checking the RSOP to see if computer settings is there.

    Besides, please check your GPO related settings, e.g. applied ous, enforced? block inherited? appropriate user privileges? and so on.

    Best regards,

    Andy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 21, 2017 7:18 AM
    Moderator
  • Hi Andy,

    Thanks for the reply, we have 2 different vlans. This is the newly built environment with 2 DCs.

    DC and servers are on one vlan and users are on other vlan. User policy is getting applied without any issue, but computer policy not being applied. I tried to generate the report using gpresult which shows user configuration only whereas computer configuration is empty. 

    For your info this is hyper-v environment with DCs are on Hyper-V and users m/c are physical


    Regards, Kalyan



    • Edited by kalyan12131 Tuesday, March 21, 2017 11:14 AM
    Tuesday, March 21, 2017 11:07 AM
  • Hi Andy,

    Thanks for the reply, we have 2 different vlans. This is the newly built environment with 2 DCs.

    DC and servers are on one vlan and users are on other vlan. User policy is getting applied without any issue, but computer policy not being applied. I tried to generate the report using gpresult which shows user configuration only whereas computer configuration is empty. 

    For your info this is hyper-v environment with DCs are on Hyper-V and users m/c are physical


    Regards, Kalyan



    Hi,

    just to be sure: you know that computer policies needs to be applied on computer objects? Also check if you have implemented GPO central store.

    Radek

    Tuesday, March 21, 2017 12:17 PM
  • Radek,

    Yes I know this, I applied the policy to computer objects only and restarted the m/c several times but no luck.

    Let me confirm do I need to enable central store GPO, because I never did this on other datacenters and gpo is working fine there


    Regards, Kalyan

    Tuesday, March 21, 2017 1:36 PM
  • Radek,

    Yes I know this, I applied the policy to computer objects only and restarted the m/c several times but no luck.

    Let me confirm do I need to enable central store GPO, because I never did this on other datacenters and gpo is working fine there


    Regards, Kalyan

    Depends on the infrastructure. If you have multiple domain controllers and you are using ADMX templates, than you should have GPO central store implemented. It is anyway best practise to have GPO central store implemented.

    Have you tested Gpresult -r on target computer if policy has been applied?

    Radek

    Tuesday, March 21, 2017 2:40 PM
  • Yes i have tested it but shows computer configuration settings as empty.


    Regards, Kalyan

    Tuesday, March 21, 2017 4:25 PM
  • Still user policy only being applied, computer policy not applying,. Is there any port for Group Policy to opened as my servers (DCs) are in 110.x series and clients on 111.x series

    Regards, Kalyan

    Sunday, March 26, 2017 7:48 AM
  • Have you also checked event logs on your domain controllers? 

    Can you access SYSVOL content from all domain controllers? Is the content same?

    110.x series? You mean subnet?

    Radek

    Monday, March 27, 2017 6:23 AM