none
Skype for Business Voicemail RRS feed

  • Question

  • I've got a issue to where if I set my Skype for Business client to forward messages to voicemail after so many seconds, the person calling gets the OVA menu instead of being able to leave a voicemail.

    They hear "To access your mailbox, please enter your extension" instead of hearing, "Please leave a message for xxxx"

    Where do I need to look?

    Thursday, September 3, 2015 1:55 PM

Answers

  • Figured out what my problem was. I didn't have the correct EUM address in my accounts.


    I added the +xxxx Lync extensions and another EUM for the email address and everything started working.


    I also made the default EUM to be the email address of the Skype for Business user / Dialplan.
    • Marked as answer by Jason Bandy Sunday, September 6, 2015 12:01 AM
    • Edited by Jason Bandy Monday, September 7, 2015 6:14 AM
    Saturday, September 5, 2015 8:51 PM

All replies

  • Are you using Exchange 2013 On-Premises?  Can you send a screenshot of your Skype client settings?  If that's correct, you'll want to load up your logger and watch SIPStack to see what's being sent to Exchange.


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, September 3, 2015 3:10 PM
  • Yes, Skype for Business and Exchange 2013 are all on-premises.

    You talking about clslogger in the Skype for Business debugging tools?

    Thursday, September 3, 2015 3:13 PM
  • Yes to the logger.  You'll want to watch SIPStack and find the Invite sent.  Just to see what's buried in the To header.

    INVITE sip:SkypeDialPlan@ExchangeServer.swc.com:5061;transport=tls;maddr=ExchangeServer.swc.com SIP/2.0
    From: "Outside Caller"<sip:+16305551212@swc.com;user=phone>;epid=EBA65B743F;tag=df27b9ba8c
    To: <sip:+16309991234@swc.com;user=phone>

    In your unanswered call settings, are they set to voicemail after 30 seconds, or are they set to voicemail sip address or phone number? 


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, September 3, 2015 3:40 PM
  • Odd, I see where it goes to the Voicemail Extension - +5275 but instead I get a OVA prompt wanting me to put in my pin (if it's from a known phone number), if it's coming from a different phone number that doesn't have a entry in AD, it asks to type in your mailbox number and then pin.

    Here's the full trace

    https://drive.google.com/folderview?id=0B-1g9BbHua7ZflJkRVhKSzJCQ3JvbWQwYVJEV05LNU9ua3g1VXBoMkNrc1ViWlVPU09UeDg&usp=sharing

    Numbers of Importance:

    270-555-1212 (Outside Caller)
    +5252 (Internal Lync Extension)
    +5275 (Lync Voicemail Extension to Exchange 2013 Server)

    192.168.250.251 = PSTN Gateway

    cisex2013.domain.local (192.168.250.9) = Exchange 2013 SP1 UM Server
    sfbedge.domain.local (192.168.197.21) = Edge Skype for Business Server
    Skype.domain.local (192.168.250.11) = Front End Skype for Business Server


    • Edited by Jason Bandy Thursday, September 3, 2015 8:50 PM
    Thursday, September 3, 2015 8:49 PM
  • That's odd, but I haven't studied it too deeply.  I usually see the voicemail sent to the sip address assigned to the UM contact object, yours goes to a phone number. Where are you forwarding the number to in the client?  What do the call forwarding settings look like?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, September 3, 2015 9:15 PM
  • Tried sip address too (voicemail@domain.local) and it does same thing.
    Thursday, September 3, 2015 9:26 PM
  • Is call forwarding set to voicemail as seen in the picture attached, or is it a number or sip address?


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, September 3, 2015 9:29 PM
  • Somehow I think the name of "Voicemail" was changed to "Lync". Haven't tracked that issue down yet.

    If I put in +5275 or type voicemail@domain.local it changes the name to Lync

    But, yes, I've tried that in the dropdown as well.



    • Edited by Jason Bandy Thursday, September 3, 2015 9:55 PM
    Thursday, September 3, 2015 9:49 PM
  • Any ideas?
    Saturday, September 5, 2015 5:50 PM
  • Is voicemail not an option in the drop down? Are you showing as voicemail enabled fm the Skype server side?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Saturday, September 5, 2015 8:00 PM
  • Figured out what my problem was. I didn't have the correct EUM address in my accounts.


    I added the +xxxx Lync extensions and another EUM for the email address and everything started working.


    I also made the default EUM to be the email address of the Skype for Business user / Dialplan.
    • Marked as answer by Jason Bandy Sunday, September 6, 2015 12:01 AM
    • Edited by Jason Bandy Monday, September 7, 2015 6:14 AM
    Saturday, September 5, 2015 8:51 PM