locked
NIC TEAMING RRS feed

  • Question

  • trying to make a NIC team on a phsyical windows server 2012

    Ive tried the below...

    PS C:\> New-NetLbfoTeam -Name Trunk -TeamNicName Trunk -TeamMembers Trunk-1,Trunk-2 -TeamingMode LACP

    Confirm
    Are you sure you want to perform this action?
    Creates Team:'Trunk' with TeamMembers:{'Trunk-1', 'Trunk-2'}, TeamNicName:'Trunk', TeamingMode:'Lacp' and
    LoadBalancingAlgorithm:'TransportPorts'.
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"):
    New-NetLbfoTeam : Operation timed out: TeamNic installation did not complete in a timely manner. Check if all
    TeamMembers are disabled
    At line:1 char:1
    + New-NetLbfoTeam -Name Trunk -TeamNicName Trunk -TeamMembers Trunk-1,Trunk-2 -Tea ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (MSFT_NetLbfoTeam:root/StandardCimv2/MSFT_NetLbfoTeam) [New-NetLbfoTeam],
       CimException
        + FullyQualifiedErrorId : MiClientApiError_Failed,New-NetLbfoTeam

    PS C:\>

    IDEAS?

      
    Monday, February 25, 2013 5:25 PM

All replies

  • I have tried with the native broadcom drivers and the vendor drivers...

    Twitter: @dguilloryjr LinkedIn: http://www.linkedin.com/in/dannyjr Facebook: http://www.facebook.com/#!/dguilloryjr

    Monday, February 25, 2013 5:29 PM
  • Hi there,

    I was just about to create a new thread for exactly the same problem.

    Server 2012 Standard (fully patched/updated), running on a HP Proliant DL380 G6 (with latest firmware/drivers for everything).

    I've also tried both the Broadcom and (default) Microsoft drivers, and get the same result with both of them.

    Tuesday, February 26, 2013 4:43 AM
  • Any messages in the event log?

    .:|:.:|:. tim

    Tuesday, February 26, 2013 1:28 PM
  • No ... nothing in the event log.
    Tuesday, February 26, 2013 7:37 PM
  • Hi,

    Thank you for the post.

    You may use the UI instead of powershell command to achieve the same result as per this blog: http://blogs.technet.com/b/privatecloud/archive/2012/06/19/nic-teaming-in-windows-server-2012-brings-simple-affordable-traffic-reliability-and-load-balancing-to-your-cloud-workloads.aspx

    Regards,


    Nick Gu - MSFT

    Thursday, February 28, 2013 7:44 AM
  • Tried that already.  The UI method results in exactly the same error being given ...

    • Proposed as answer by jason.mott Monday, March 18, 2013 4:07 PM
    • Unproposed as answer by jason.mott Monday, March 18, 2013 4:07 PM
    Monday, March 4, 2013 2:16 AM
  • I'm on a HP Proliant 360p Gen8 and I am having the same issues. The NIC is a HP Ethernet 1Gb 4-port 331FLR Adapter. Any luck or pointers?


    Fred Larracuente Stronghold System Solutions Corp. Guaynabo, PR USA www.strongholdcorp.net

    Friday, June 28, 2013 3:19 PM
  • Nope ... I've still never been able to resolve this.

    So far I've had exactly the same problem on *3* seperate servers now.

    It's causing me some real headaches!

    Wednesday, July 10, 2013 12:35 AM
  • HI David,

    Have you been able to find a solution for the problem? I experiencing the same issue using both the GUI or the Powershell New-NetLbfoTeam command.

    Here is a screenshot of the error:

    Wednesday, July 17, 2013 12:44 PM
  • Still no resolution at this point.

    I am just about to remove one of the affected servers from production though, so I'll finally be able to do a little bit more invasive testing on it.

    Wednesday, July 17, 2013 1:20 PM
  • Hi,

    I haven't seen that issue on any IBM server. I've just finished building up a system with 6 IBM x3650 M4 servers on Windows Server 2012 about 2 months ago.

    It might because of the new 10Gb NICs. Can you try to install previous version of Windows Server (maybe Windows Server 2008 R2), then use the hardware native teaming solution to make sure that it's not because of the imcompatibility between driver and OS?

    Regards,

    Tu9a2

    Thursday, July 18, 2013 2:18 AM
  • FWIW ... none of the servers I'm using have 10GbE adapters, so I doubt that's the cause of it.

    So far I've had exactly the same problem on 3 x HP DL380 G6 servers and 2 x HP DL320 G7 servers.

    Thursday, July 18, 2013 6:31 AM
  • Guys

    I had the same problem with the Intel 520-T2 NICs. One servers the teaming worked fine, and the other it didn't. Difference was the driver. The server using the Microsoft drivers (3.0.8.X)  the teaming worked fine, the server with the Intel drivers 3.41.X would not team, timeout every time. However on the server with the 540-T2 NICs that would not team, the on board Broadcom (was a HP DL360p) would team fine

    So..

    I uninstalled the Intel drivers on all 4 NIC ports (I have 2 x 540-T2 in each server) and rebooted, checked that it has reverted to the Microsoft driver, and the Windows Teaming worked fine.

    After that I patched the drivers again with the new Intel drivers and the teaming is still fine. If I tried to re-create the TEAM NIC am sure it would fail but am unlikely to need to do so, given the server is now stable, and I can always roll back.

    I am guessing this is because the Intel driver has built in teaming (tab) in the driver / NIC setup and it doesn't play nice with the Windows Teaming setup.

    Can't help the guys with other NICs but if you have 540-T2 running in 10Gb mode then this will fix your problem. Worked for me.

    Sunday, September 8, 2013 12:40 AM
  • Hi,

    I'm facing the same problem here, I have identical servers with identical drivers, on 1 server I am not able to enable teaming. I'm getting "TeamNic installation did not complete in a timely manner. Check if all
    TeamMembers are disabled".

    Any solution for this yet?

    And "All TeamMembers disabled"? Should that not be Enabled? 

    Regards,
    WiM 

    Wednesday, November 13, 2013 4:24 PM
  • I'm having this same issue. I tried uninstalling the Intel drivers and rebooting, but the drivers are still 'provided by intel' in the driver details page. And they are version 3.47.X  How did you get rolled back to Microsoft drivers at version 3.0.8.X? I can't locate that version any where. This is on a brand new 2012R2 server.

    Here's my other thread, in case it helps others:

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/106b2f89-d759-4a94-80d6-f43d9172f2f4/nic-teaming-on-new-2012r2-install-intelx540t2-netgear-xs712t-not-functioning-properly?forum=winserverPN

    Tuesday, December 10, 2013 9:58 PM
  • I have the same problem, install on the all nic protocol Microsoft Network adapter Mulitplexor Protocol , then create team, for me solved problem.

    Tuesday, February 11, 2014 7:14 AM
  • I have the same problem, install on the all nic protocol Microsoft Network adapter Mulitplexor Protocol , then create team, for me solved problem.

    Thank you. It's solved problem for me too. HP DL380p G8. Windows Server 2012 R2 Standard.
    • Proposed as answer by DrBCG Wednesday, November 25, 2015 6:11 PM
    Friday, June 27, 2014 3:27 PM
  • Worked for me as well on Dell PowerEdge R720
    Monday, January 19, 2015 2:34 PM
  • I have the same problem, install on the all nic protocol Microsoft Network adapter Mulitplexor Protocol , then create team, for me solved problem.

    Thank you. It's solved problem for me too. HP DL380p G8. Windows Server 2012 R2 Standard.

    how i install nic protocol  Microsoft Network adapter Mulitplexor Protocol ?  appropriate your support 

    Sunday, February 1, 2015 8:54 AM
  • I have the same problem, install on the all nic protocol Microsoft Network adapter Mulitplexor Protocol , then create team, for me solved problem.


    Thank you. It's solved problem for me too. HP DL380 G7. Windows Server 2012 R2 Datacenter.

    Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, March 29, 2015 3:31 PM
  • I have the same issue but don't understand your resolution?!?! please can you elaborate.

    Wednesday, May 27, 2015 1:23 PM
  • Thanks for the tip. It helped solve my issue.
    Friday, April 15, 2016 8:05 PM