none
Problems with System Writer on Windows Server Enterprise

    Question

  • Hi everyone,

    I got a problem when I use Avamar on some servers, only Windows Server Enterprise. The backup is not working, and when I'm looking into logs, I can see that I got an error about "System Writer". Indeed, when I launch "vssadmin list writers", I should see "System writer" but I don't.

    I searched on internet to get some solutions, like giving some rights on some folders, but it changed nothing and then I saw that I could install the Fix484021 to fix it. But... the fix isn't working on my OS :( (link : https://support.microsoft.com/en-us/help/2911752/system-writer-is-missing-and-backups-fail-in-windows-server-2008)

    I tried to contact the support by chat, but I don't get an answer from it because it's laggy.

    Waiting for help.

    Thanks in advance.

    Regards,

    Clément.

    Thursday, June 21, 2018 2:50 PM

All replies

  • Hi Clement,

    May I ask what's the OS for your server?

    When you run vssadmin list writers, except System writer missing, is there anything wrong with other writers?

    First, you should try the below solution:

    Go to local services to start or restart below services:

    • COM+ Event System

    • COM+ System Application

    • Distributed Transactions Coordinator

    • Microsoft Software Shadow Copy Provider

    • Volume Shadow Copy service

    Then try to take test backup. If it does not work, please check the permissions to files in the %windir%\winsxs\filemaps\ or %windir%\winsxs\temp\PendingRenames directories are incorrect.

    https://support.microsoft.com/en-us/help/2009272/system-state-backup-using-windows-server-backup-fails-with-error-system-writer-is-not-found-in-the-backup

    After that restarted cryptographic service to do a check.

    And since this is windows server backup forum, we mainly focus on build-in backup feature. For 3rd party backup software, you may still contact the vendor.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 22, 2018 2:11 AM
    Moderator
  • Hi,
    Could the above reply be of help? If yes, you may mark it as answer, if not, feel free to feed back
    Best Regards,
    Mary

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 25, 2018 7:33 AM
    Moderator
  • Hi,

    Thanks for your answer Mary, but it doesn't work in my case. :(

    Firstly, I (re)started all the services, then I give the good rights because in my eventvwr I have both 513 & 517 errors but not the 8213. At the end of these manipulations, I still not have the System writers in my "vssadmin list writers" so I think the problem is still in the system, am I right?

    If you have other idea, I'm waiting for them. I think, at the moment, it's useless to contact EMC Community about my problem because they won't answer til I haven't the "System writer".

    Best Regards,

    Clément.

    Monday, June 25, 2018 10:01 AM
  • Hi,

    As asked before, what's the version for your OS?

    Even on server 2012 and later version,we still need to ensure  permissions to files in the %windir%\winsxs\filemaps\ or %windir%\winsxs\temp\PendingRenames directories are incorrect.

    https://support.microsoft.com/en-gb/help/2009272/system-state-backup-using-windows-server-backup-fails-with-error-syste

    https://social.technet.microsoft.com/Forums/windows/en-US/0575cd88-4db3-46b5-9053-4138403efdca/windows-server-2012-vss-error-quotthe-system-writer-is-missingquot?forum=windowsbackup

    If it still couldn't find any clue, I'm afraid you might need to contact  Microsoft Customer Support Services (CSS) so that a dedicated Support Professional can help you on this issue.

    To obtain the phone numbers for specific technology request, please refer to the website listed below:

    https://www.microsoft.com/en-us/worldwide.aspx

    Appreciate your support and understanding.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 26, 2018 1:56 AM
    Moderator
  • Hi,

    My OS version is "Microsoft Windows Server 2008 SP2" (Build 6002).

    I already changed these permissions but it still changed nothing...

    I will try to make a call to Microsoft CSS and I will come back to you if I got a solution.

    Thanks for your help & have a good day.

    Best Regards,

    Clément.

    Tuesday, June 26, 2018 7:06 AM
  • Hi Clément,

    Appreciate your understanding.  And if you get more ideas, please feel free to contact us.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 27, 2018 1:27 AM
    Moderator
  • Clément,

    Did you get a resolution? We're having a very similar issue with one of our servers.

    Regards

    Rory

    Wednesday, July 4, 2018 12:19 PM
  • Hi,

    The problem is still there.

    The call was useless because they directly ask me to create an incident to Microsoft. But, to do that, I need to have an "approbation" from my L3 Windows & L3 Avamar.

    When I will have a solution I will come back there to post the solution.

    Regards,

    Clément.

    Wednesday, July 4, 2018 2:42 PM
  • In case it helps someone we found it was a Windows update that killed the system writer (KB4090450)
    Wednesday, July 4, 2018 2:58 PM