locked
Windows 8 pro with 2 monitors Video choppy RRS feed

  • Question

  • Hi guys ive installed windows 8 pro from MSDN and I run it with 2 monitors, if im running a game Warcraft world of tanks and have video running on the 2nd screen its choppy and stuttering.

    This is fine within windows 7

    Ive updated to whatever ATI have out at present 12.8 drivers but its still the same, even IMDB streams are poor, if I flick to that monitor outside of the game it runs fine.The system I run is fairly beefy core I7 3.8 , 12 gig Ram and an ATI 5870.

    Its has though its not giving any kind of priority to the 2nd screen.

    any ideas

    Saturday, August 25, 2012 6:43 PM

All replies

  • Hi,

    Did it work well when you play on the primary screen?  

    The issue should related with the driver or device incompatible with Windows 8. I suggest to update BIOS and chipset for test.

    Furthermore, try to turn up or turn down the screen refresh rate:

    Screen resolution---Advanced settings---Monitor---Monitor Settings

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Monday, August 27, 2012 6:24 AM
  • If im playing games on primary screen they run fine, they run fine on secondary also.

    Its only when your playing the game and have the screen beside you playing video does it go choppy, if i alt tab to second screen and click the video it all goes fine again.

    As i said above its as though when your playing anything and have the concentration on A screen be it 2nd or 1st, if any video is played on the secondary screen its choppy, only when you are actively moving the mouse around does it go good again. To me it looks like a Thread/driver issue.

    The card is an ATI XFX 5870. i,ll give it a go tonight

    thanks

    Tuesday, August 28, 2012 8:24 AM
  • No the best solution is for someone to fix this so I can watch a video and play a game at the same time, this has worked for years on Windows 7.  Most games work fine when you alt+tab out.

    I have the exact same issue, I always watch a video with VLC and play games, I'm using an Nvidia card 560ti card with 304.79 drivers version.  Since Windows 8 this has stopped working.  When Im playing the game the video stream moves at about 1 frame every 20 seconds, but the audio is fine.

    There is no resource issue on my machine according to task manager.(This will happen even if I'm just at the games main launch screen where nothing is really occurring)

    I can work around the issue in some games if they have options for Windowed mode, IE if I run the game in a Window at the same resolution there is no slow down at all.

    At first I thought it may be an NVidia issue.. but if ATI users are seeing the same thing..

    Tuesday, September 4, 2012 8:09 AM
  • Give it some time till the manufactures make fully working drivers. 

    Microsoft MVP - Windows Expert (IT Pro)

    Sunday, September 9, 2012 5:45 AM
  • I'm not 100% convinced its a driver issue.. I just tried the same tactic in Counster Strike Global Offensive, if I change the video options to full screen windowed there is no issue.  The game plays full screen on one monitor and the video playback is not choppy on the other.  If I set it to full screen(in the csgo options) then the video is choppy on the second monitor.

    It almost seems like the OS is taking priority off the video app when the other app is full screened.

    Sunday, September 9, 2012 5:57 AM
  • I dont think we are talking about games that offer triple monitor support.  We are talking about games you play on one monitor, but at the sametime you watch a video on a seconday display.

    Fyi.. The latest beta nvidia drivers from aug 27th do not seem to address this.

    Sunday, September 9, 2012 12:57 PM
  • I have also noticed on occasion that the ATI driver dies, its worrying though, that something this simpleton, wasn't picked up on the TAP programme, Quality Assurance want shooting.

    sigghhh might go back to 7 till it settles

    Sunday, September 9, 2012 8:41 PM
  • I'm not sure what the issue is but it only happens to me when games are in fullscreen mode. If you set the game to windowed or fullscreen windowed it should fix the issue in my limited experience. Not sure why this happens. Friend of mine had this issue in windows 7 and fixed it by changing priority for the video process.
    Friday, September 21, 2012 2:40 AM
  • I have started experiencing the same issue.  In Windows 7, I used the same drivers that I am using now.  When I am playing anything in Fullscreen, video goes crazy.  I have tried streaming - HBOGO, Netflix, Amazon Prime, Hulu - and it goes nuts.  I run video in Windows Media Player or VLC, it goes nuts.

    I tried running a game in Windowed(Fullscreen) and the video works great.  Now this is, hopefully, a temporary fix.  I know there are some games that dont run in Windowed mode very well, but this has worked pretty well so far.

    I also upgraded to the most recent driers and its the same thing.  I have rebooted and tried rollbacks and fresh installs, which makes me think that its not necessarily a driver issue.  

    I do run 4 monitors and have tried video on all of the screens and this will occur across any of the screens when one of them has a fullscreen game going.

    AMD Phenom II x6

    2x Nvidia GeForce 560 Ti SC 

    32GB Ram

    Asus M5A99X EVO

    Saturday, October 27, 2012 4:09 AM
  • I have the same problem. Playing games while watching movies on the 2nd screen with VLC always worked like a charm. Today I upgraded to Win8 final and got choppy playback whenever focus is away from the player.

    If I run games in windowed mode it works but thats hardly a good workaround. 

    Monday, October 29, 2012 10:41 PM
    • Proposed as answer by herrmadbeef Thursday, April 18, 2013 7:26 AM
    Monday, November 19, 2012 6:59 PM
  • did anyone test this solution ????

    did it worked 

    i just upgraded atoday and i am facing the issue

    my laptop is i7 

    32 GB ram and 1.5 TB raid 0 array 

    and a 

    2GB GDDR5 AMD Radeon HD 6970M

    so i do not think this is related to performance 

    Wednesday, April 17, 2013 9:54 AM
  • the patch solved my problem

    thanks Cyberflake

    Thursday, April 18, 2013 7:27 AM