locked
Browser URL desktop icons display 14x14 on 40x40 white background RRS feed

  • General discussion

  • The URL picture icons (the favicon designs) on my desktop display in size 14x14 pixels (tiny) on a 40x40 pixels white background. This is when I have medium size icons. Similar phenomena appears when scaling icon size up/down. I have searched extensively but not found the problem described elsewhere. System is Win 7 64 SP1 and newest browser versions as of today. It is quite annoying. Not really a good user experience on a small HD screen.

    Further description:
    - URL icons earlier displayed only as white "sheets of paper". I got to where I am now by refreshing each URL icon on the desktop by re-adding the icon to the desktop, dragging it from the FireFox URL line ('copy and replace'). I have tried same approach with IE 10 and Chrome while having each of these browsers as the default. They don't place any favicon designed URL icons on the desktop, only generic IE or Chrome icons - but in full size as they should be.
    - I have tried deleting the icon cache. which makes no difference.
    - Installed the program IconPackager and changed Windows default icons to something new and then back again. For someone this helped with a different icons issue. In this case it made no difference.
    - Windows icons behave as they should. They are not getting smaller, nor are they displayed on white background.
    - Have tried to create new user account. The problem persists.
    - Have - without success - tried to reset the URL file association value in the registry as described here: http://www.sevenforums.com/tutorials/19449-default-file-type-associations-restore.html.

    Help on this issue will be appreciated.

    • Changed type Niki Han Friday, May 3, 2013 4:13 AM
    Friday, April 26, 2013 8:22 PM

All replies

  • Please try the following for url's dragged from Firefox to the desktop.

    1. Right click the icon and choose properties.
    2. Click on Change Icon.
    3. Click on Browse to browse to the location of desired icon - if you want the Firefox icon this would be C:\Program Files (x86)\Mozilla Firefox - then you would click on Firefox.exe.
    4. The Change Icon dialog should now display a range of firefox icons - choose one then click OK.
    5. You should now have a full size icon on the desktop.

    To avoid this issue, instead of dragging url's to the desktop, right click a blank area of the desktop and choose "New" then "Shortcut". Paste the url into the Create Shortcut dialog, click next then enter the name of the shortcut. Then click "Finish". 
    Saturday, April 27, 2013 1:46 AM
  • Also, from what I've read, Firefox 21 will attempt to fix this by adding a "browser.shell.shortcutFavicons" option to about:config.
    Saturday, April 27, 2013 2:36 AM
  • Excellent.  I appreciate the precision of your response.  Now I see there are several optional Firefox icons.  One is a smaller white box with a larger Firefox.  That is now what I get after I changed the config setting.  I would prefer to use the larger Firefox Icon with what shows a blue background when you select it.  The box is clear on the screen and appears to be the same icon as shown on the taskbar.  Is there some way to make that the default selection?  Looking through the Firefox files I saw a visual elements file that contains two Icon choices.  Not clear where they are used or if one is already the icon I want to use as the default.  Is thee some way to use my icon of choice as the default icon?  Perhaps by changing the About:Config file to alter the default.  Thanks for your help.

    • Edited by rocrocroc Saturday, May 6, 2017 5:51 AM
    Saturday, May 6, 2017 5:25 AM