locked
How do I ignore punctuation with fuzzy match when merging queries? RRS feed

  • Question

  • I have a table of names that I'd like to merge with another table of names and fuzzy match has been working great except when the names have punctuation in them even when the match is remarkably close. For example, "J.R. Ewing" will not match up with "JR Ewing". Is there a workaround for this? If this has been asked before, my apologies and please direct me to the appropriate answer. Google searches have not been helpful.

    Thanks!

    Monday, September 21, 2020 11:29 PM

Answers

  • Hi,

    The issue seems to be because of the way our algorithm works on this kind of data. Thanks for pointing this out.

    As a workaround, you can use the TransformationTable option to map "JR" in this case to "J.R.". However, I don't think this is a scalable solution, and we'll work on addressing this issue.

    -Srinidhi

    Saturday, October 10, 2020 12:11 AM

All replies

  • Hi,

    Thanks for bringing up this issue. We are looking into it.

    -Srinidhi

    Friday, October 9, 2020 9:20 PM
  • Hi,

    The issue seems to be because of the way our algorithm works on this kind of data. Thanks for pointing this out.

    As a workaround, you can use the TransformationTable option to map "JR" in this case to "J.R.". However, I don't think this is a scalable solution, and we'll work on addressing this issue.

    -Srinidhi

    Saturday, October 10, 2020 12:11 AM
  • Hi,

    The issue has been fixed and should be available in the December 2020 release of PowerBI Desktop.

    Thanks,
    Srinidhi

    Friday, November 13, 2020 12:55 AM