locked
Autocorrect giving error "The operation failed. The messaging interface have returned an unknown error. If the problem persist, restart Outlook. Cannot resolve recipient." RRS feed

  • Question

  • Environment: On Premise Exchange 2010 SP3 Rollup 25
    Client: Outlook 2016

    Issue: On any new profile that is being created and after clearing the auto-correct cache by performing it via Outlook - File - Options - Mail - Empty Auto-Complete List and also Outlook.exe /CleanAutoCompleteCache. The first mail sent internal or external works, but then when you select the recipient from the drop down list the second time we receive the following error "The operation failed. The messaging interface have returned an unknown error. If the problem persist, restart Outlook. Cannot resolve recipient."

    If the address is added to the Outlook Address book by - right clicking on the email - add to Outlook outlook contact - then the error message is not displayed at all. Having to add the address to the Address Book is not a solution, but a workaround we are currently using.

    Additional info: This issue is only experienced for clients that are on premise, If a client is connected externally using OutlookAnywhere the issue is not present.

    Has anyone experienced this before. That can point me in the correct direction.

    • Edited by ShaneTen Tuesday, November 12, 2019 9:04 AM
    Tuesday, November 12, 2019 8:56 AM

All replies

  • Hi,

    Since you are using an Exchange account, autocomplete cache sync with server. The entry on the server may be corrupted. Even you clear the cache on Outlook client, corrupted cache could also sync to client again. So please try exiting Outlook desktop client and see if the issue can be reproduced on the web mail. 

    Besides, please start your Outlook in online mode (File > Account Settings > Double click your account)and click "Empty auto-complete list" again. Delete Stream_Autocomplete_0_[long GUID].dat under path:
    C:\Users\%username%\AppData\Local\Microsoft\Outlook\RoamCache

    If the issue continues, it is also suggested to start your Outlook in safe mode (Press Win + R, type “outlook /safe”, press Enter.) and see if the issue continues.

    Hope this can be helpful.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, November 13, 2019 2:35 AM
  • Hi,

    Have you got the issue fixed?

    I'm writing to see if the reply above is helpful to you. If yes, would you mind helping mark the reply as answer? So that others who might have a similar question can benefit from your thread? Thanks for your understanding and support.

    Regards, 

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Thursday, November 14, 2019 8:05 AM
  • Hi,

    I'm glad to see your issue has been fixed.

    Here I will provide a brief summary of this post for your information. This will make answer searching in the forum easier!

    Request/Expectation:

    On any new profile that is being created and after clearing the auto-correct cache by performing it via Outlook - File - Options - Mail - Empty Auto-Complete List and also Outlook.exe /CleanAutoCompleteCache. The first mail sent internal or external works, but then when you select the recipient from the drop down list the second time we receive the following error "The operation failed. The messaging interface have returned an unknown error. If the problem persist, restart Outlook. Cannot resolve recipient."

    Solution Summary:

    Since you are using an Exchange account, autocomplete cache sync with server. The entry on the server may be corrupted. Even you clear the cache on Outlook client, corrupted cache could also sync to client again. So please try exiting Outlook desktop client and see if the issue can be reproduced on the web mail. 

    Besides, please start your Outlook in online mode (File > Account Settings > Double click your account)and click "Empty auto-complete list" again. Delete Stream_Autocomplete_0_[long GUID].dat under path:
    C:\Users\%username%\AppData\Local\Microsoft\Outlook\RoamCache

    If the issue continues, it is also suggested to start your Outlook in safe mode (Press Win + R, type “outlook /safe”, press Enter.) and see if the issue continues.



    Reference Links:

    No.

    Regards, 

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Wednesday, November 27, 2019 8:50 AM