locked
Dashboard/Report "Drill Down To" Functionalilty Error RRS feed

  • Question

  • Hi,

     

    I have created a report off of an analysis cube.  Basically this shows salesperson and amount sold and their target for the year.  A simple bar chart.

     

    When I am in the Reports section of the PPS designer and I browse my report from there, when I right mouse click on one of the bar chart bars for a salesperson I have all the "Drill Down To" options that I expect to see (i.e., region, state, etc) and they work.  I have about 5 or 6 dimensions in total.

     

    However, when I go to create the Dashboard and view it within SharePoint, the PPS Web Part for SharePoint or by using the Preview function, I only see the first 2 items in the "Drill Down To" list.   They work but I am not seeing my complete list.

     

    Any ideas what is happening?

     

    Alan

    Monday, January 7, 2008 7:27 PM

Answers

  • Hello Alan Whitehouse,

    Placing the PPS server in the Local Intranet zone will set the IE security settings correctly. Doing this will also remove unwanted login prompts.

    Thanks,
    Jon Thomas
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by AseemN Monday, February 16, 2009 8:54 PM
    Monday, February 2, 2009 5:36 PM

All replies

  •  

    Hello Alan,

     

    This sounds like a security issue. If you do not have 'per user connectivity' set up, then the account identity for the application pool running the sharepoint and preview sites should be making the connection to the data source to return drill down to information. Do the ppsmonitoringwebservice, SharePoint and PPSMonitoringPreview site have different account identities that run the listed application pools? This may be the issue if the cube has restricted access rights to certain dimensions?

     

     

    Monday, January 7, 2008 9:22 PM
  • The cube has no restricted access rights to certain dimensions.  

     

    I could understand this being a security issue if *NONE* of the dimensions showed up.  But why only the first two and not the rest?   In fact, right now at this point we have not envoked almost zero security as this is our development platform for this client.  

     

    This to me sounds like some sort of bug with what is being displayed.

    Monday, January 7, 2008 9:35 PM
  • Alan,

     

    I have seen similar situations like the one you describe and most of the time it is being caused by a security problem.  I would verify that your app pools have the same identity account and proper access to the cube. When publishing to SharePoint you also need to make sure that the SharePoint -80 app pool also has the proper access. 

     

    Below I included a very good blog post written by one of your fellow forum posters Nick Barclay that does a great job explaining this topic. 

     

    http://nickbarclay.blogspot.com/2007/11/pps-data-source-connection-problems.html

     

     

    Aseem Nayar - MSFT
    Monday, January 7, 2008 10:06 PM
  • Just to test, I changed all my app pools to run as an Administrator account.  An account that can do everything.  I also checked my security on the cubes.  Everything is fine.

     

    Again, security issues don't really mesh with why only the first two choices under that dimension show up and not the rest.  And all my other drill down items (like show details) work.  

     

    This is all running on a single develop machine and the Administrator was the account that installed PPS/IIS/SQL and that created the origional SQL tables and SSAS cubes using the design studio.

     

    Alan

    Tuesday, January 8, 2008 4:38 PM
  • Turns out the problem was with Internet Explorer security settings. 

     

    I played with those and it began working.   I will have to spend time trying to figure out exactly what setting needs to be changed but it was definately an IE issue.

    Wednesday, January 9, 2008 3:05 PM
  • Hi Alan,

    Did you ever find out what security settings were causing the problem?

    Thanks
    Ian B
    Sunday, February 1, 2009 7:35 AM
  • Hello Alan Whitehouse,

    Placing the PPS server in the Local Intranet zone will set the IE security settings correctly. Doing this will also remove unwanted login prompts.

    Thanks,
    Jon Thomas
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by AseemN Monday, February 16, 2009 8:54 PM
    Monday, February 2, 2009 5:36 PM