locked
Turn off Offline Message Email Notifications in Skype for Business RRS feed

  • Question

  • We have Office 365 at my organization and we have recently started using Skype for Business.  When users send message to someone that is offline an email goes to there Outlook in box.  I want to turn this feature off.  I found an article 

    http://www.michev.info/Blog/Post/155/Offline-messaging-now-available-in-Skype-for-Business

     that details how but the Set-CsIMConfiguration cmdlet is not an option when I connect to Skype for Business via Powershell.

    I need help getting this turned off as this poses privacy concerns at my organization as we are a medical facility.

    Wednesday, October 5, 2016 5:22 PM

Answers

  • Hi ShawnDWHC,

    Welcome to post in our forum.

    Would you please tell us did you mean that you cannot run the command line Set-CsIMConfiguration  in the SFB management shell ?

    Please check that you are running Windows PowerShell version 3.0 or higher.

    You will also need to install the Windows PowerShell module for Skype for Business Online that enables you to create a remote Windows PowerShell session that connects to Skype for Business Online. This module, which is supported only on 64-bit computers, can be downloaded from the Microsoft Download Center at Windows PowerShell Module for Skype for Business Online.

    Restart your computer if you are prompted.

    After this, please try to run the Set-CsIMConfiguration  again and test if there is the same issue.

    Since you use the SFB online, you could also post this case in the following link, there are more experts will help you solve the issue.

    http://answers.microsoft.com/en-us/msoffice


    Alice Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Thursday, November 10, 2016 10:18 AM
    • Marked as answer by Alice-Wang Thursday, November 10, 2016 10:18 AM
    Wednesday, October 12, 2016 9:08 AM

All replies

  • Hi Shawn,

    Get/Set-CsIMConfiguration Cmdlet will be available after you update your SfB Deployment to CU3.
    Reference: 
    https://greiginsydney.com/sfb-2015-server-update-cu3-june-2016/

    Hope to help you.
    Best Regards

    Luca


    Luca Vitali | MCITP Lync/Exchange | snom Certified Engineer | Sonus SBC1000 Engineer

    Wednesday, October 5, 2016 10:47 PM
  • If you also wanted to disable the offline im feature , we can also attempt that with the following process https://support.office.com/en-us/article/Turn-on-or-off-Offline-Messages-for-admins-8967a77f-caa2-4680-aa22-8faa32c716e4?ui=en-US&rs=en-US&ad=US

    Linus || Please mark posts as answers/helpful if it answers your question.

    Thursday, October 6, 2016 10:16 AM
  • Hi ShawnDWHC,

    Welcome to post in our forum.

    Would you please tell us did you mean that you cannot run the command line Set-CsIMConfiguration  in the SFB management shell ?

    Please check that you are running Windows PowerShell version 3.0 or higher.

    You will also need to install the Windows PowerShell module for Skype for Business Online that enables you to create a remote Windows PowerShell session that connects to Skype for Business Online. This module, which is supported only on 64-bit computers, can be downloaded from the Microsoft Download Center at Windows PowerShell Module for Skype for Business Online.

    Restart your computer if you are prompted.

    After this, please try to run the Set-CsIMConfiguration  again and test if there is the same issue.

    Since you use the SFB online, you could also post this case in the following link, there are more experts will help you solve the issue.

    http://answers.microsoft.com/en-us/msoffice


    Alice Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Thursday, November 10, 2016 10:18 AM
    • Marked as answer by Alice-Wang Thursday, November 10, 2016 10:18 AM
    Wednesday, October 12, 2016 9:08 AM
  • If you are referring to Skype for business online, that command is not available.

    You will have to use set-csclientpolicy : https://support.office.com/en-us/article/Turn-on-or-off-Offline-Messages-for-admins-8967a77f-caa2-4680-aa22-8faa32c716e4


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, October 12, 2016 9:54 AM