none
Unable to delete FIM Service MA RRS feed

  • Question

  • Experts,

    I had three MA.

    -File based MA

    -fim service ma

    - AD MA

    Due to some problem now I am trying to start from starting. I deleted all MA but FIM Service MA is not getting deleted.

    during import and export 498 records shows error. How to get rid of this 498 connector space object.

    Can I ignore this errors. What impact this will have in future. Let this object in connector space.

    I see following errors while in eventvwr when I run FIM Service MA.

    The server encountered an unexpected error in the synchronization engine:

     "BAIL: MMS(12224): d:\bt\800\private\source\miis\server\sqlstore\sproc.cpp(1571): 0x80230405 (The operation failed because the object cannot be found)

    Thanks,

    Mann

    Thanks,

    Mann

    Friday, March 28, 2014 11:49 AM

All replies

  • Can I leave this as it is like let the 498 object in FIM Service MA?

    or is this error can some problem in future?

    Thanks,

    Mann

    Friday, March 28, 2014 12:09 PM
  • Hi.

    Do you have any Sync rules from the now deleted MA's left? If so try delete them and sync in the changes from FIM. You might need to turn of Synchronization rule provisioning in FIM sync manager/Options.

    /Robert

    Saturday, March 29, 2014 8:54 AM
  • The easiest way to clean up FIM Service is to export MV schema (if changed) and Management agents, then restore FIM's databases (hope you have them) as they were just after installing FIM.

    Then you are sure that you have clean environment.

    Other way is to delete connector spaces on all of the agents (so you would not have to re-create the same MA). Considering that there is some data on FIMService - delete it manually or by PS script. Or, if those objects tend to be there and they are ok, you can do it - it should not cause the problem.


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Saturday, March 29, 2014 4:32 PM