none
External data Refresh Failed RRS feed

  • Question

  • Hello,

    I am working on Project server 2013 as Administrator. Currently I am facing Excel Report Data Refresh Issue. I have Project Server 2013, MS SQL server 2008 R2 and Excel 2010. I did lots of R and D on google and also found solutions but none is woking. I have attached screen shots where you can see the error. This reports are using odata connection files.

    Friday, January 23, 2015 6:34 AM

Answers

  • Thanks Nabeell,

    Your suggestion is working only for non oData connection files.

    But i found solutions my-self :)

    I am using SharePoint 2013, but for access oData connections report files required MS Excel 2013, last time i was used MS Office 2010, so i just installed MS Office 2013 which include Excel 2013. After installation remaining reports was also working.

    Thanks,

    Anurag G J 


    anurag9179

    • Marked as answer by Anurag J Tuesday, March 10, 2015 9:36 AM
    Tuesday, February 24, 2015 9:18 AM

All replies

  • In your data connection, did you check the REFRESH ON OPEN?

    Are you getting an error or is the refresh not happening automatically?

    If you open Excel and do a DATA REFRESH are you getting errors?

    Are you using Secure store for authentication?  The Secure store ID is case sensitive, so make sure you have it spelled exactly the same in Excel.

    Cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Monday, January 26, 2015 3:56 AM
    Moderator
  • Hi,

    If you are still facing the same issue follow the below steps:

    1) Access PWA from your server

    2) Download any built in report from Reports section (in your case Project Server - Issue Data Project Server - Risk Data) to your server.

    3) Open report in excel, go to Data->Connections in Workbook Connection dialog open "Project Server - Issue Data" go to properties.

    4) Here select tab 'Definition' under connection file remove tick for 'Always use connection file'

    5) Tweak your connection string & tick save password option 

    6) Excel Services: Authentication Settings (suit yourself)

    Now, save & publish on PWA, hope it works :)

    • Marked as answer by Anurag J Tuesday, April 28, 2015 4:42 AM
    • Unmarked as answer by Anurag J Tuesday, April 28, 2015 4:43 AM
    Monday, January 26, 2015 6:31 AM
  • Because you are using OData, do you have group permissions to the Access Project Server Reporting Service? Without that, you can't access OData. You can test this by putting the OData string in the browser url field and seeing if you get data back.

    Secondly, do you have PowerPivot for SharePoint installed? I believe OData requires PowerPivot support. However, I don't have a current on-premises instance to test this.

    Treb Gatte, Project MVP | http://www.tumbleroad.com | @TumbleRoad | Take Our Project Administrator Survey

    Monday, January 26, 2015 9:58 PM
    Moderator
  • Have you followed all the steps in the article, Configure reporting for Project Web App (Project Server 2013): https://technet.microsoft.com/en-us/library/ee662106(v=office.15).aspx

    Is the issue happening on all the reports or custom reports or any specific out of the box reports.


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.

    Thursday, January 29, 2015 1:42 AM
  • Thanks Nabeell,

    Your suggestion is working only for non oData connection files.

    But i found solutions my-self :)

    I am using SharePoint 2013, but for access oData connections report files required MS Excel 2013, last time i was used MS Office 2010, so i just installed MS Office 2013 which include Excel 2013. After installation remaining reports was also working.

    Thanks,

    Anurag G J 


    anurag9179

    • Marked as answer by Anurag J Tuesday, March 10, 2015 9:36 AM
    Tuesday, February 24, 2015 9:18 AM