locked
Certificate Assignment Fails "Https Binding not found on the web site." RRS feed

  • Question

  • After requesting a certificate from the local CA the process to assign the Cert fails with the following error: Command execution failed: Https binding not found on the web site.

    This CA and the same process worked without issue with the RC deployment.

    Here are the details from the Deployment Log:


       11/29/2010 9:47:17 PM   Error

     └    Error: An error occurred: "Microsoft.Rtc.Management.Deployment.CertificateException" "Https binding not found on the web site."   11/29/2010 9:47:17 PM   Error
     

    Tuesday, November 30, 2010 3:50 AM

Answers

  • Looking more closely i saw that the request was indicating that the CA was not a trusted source.  I unbound the server from AD and rebound the server and started the process over again... this worked fine.... Somewhere in the AD binding process the machine didn't establish a trust to the DC.
    • Marked as answer by NWCC Thursday, December 2, 2010 2:42 AM
    Thursday, December 2, 2010 2:42 AM

All replies

  • Hi, website and binding are created during activation, if the binding is deleted manually, you need to re-activate it. Then set the certificate after the reactivation.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 30, 2010 5:53 AM
  • How do i go about re-activating the binding?  I don't know that i deleted it.. but could have possibly done so... (or obviously did so since we have this error)
    Tuesday, November 30, 2010 6:14 AM
  • Hi, please verify that there are no https binding created for external and internal websites, if have then manually delete those IIS bindings and try to re-assign certificates.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 30, 2010 10:04 AM
  • Hi to check the binding you either do the following:

    1- open the Internet Information Service (IIS) Manager

    2- expand sites, you should see three websites: default, lync external web site and lync internal web site

    3- Select the lync external website

    4- check the right pan of the IIS manager you should find "bindings" under the "Edit site" section 

    5- click on bindings you should find HTTP on port 8080 and HTTPS on port 4443 address *  this is for the external lync web site

    and you should find HTTP on port 80 and HTTPS on port 443 for the internal Lync web site 

     

    method 2 confirm bindings from the toppoloy builder by checking the Front-end pool properties node 

    regards,

     

     


    Charbel Hanna
    • Proposed as answer by Lobsb Thursday, July 21, 2011 4:46 AM
    Tuesday, November 30, 2010 10:22 AM
  • Looking more closely i saw that the request was indicating that the CA was not a trusted source.  I unbound the server from AD and rebound the server and started the process over again... this worked fine.... Somewhere in the AD binding process the machine didn't establish a trust to the DC.
    • Marked as answer by NWCC Thursday, December 2, 2010 2:42 AM
    Thursday, December 2, 2010 2:42 AM
  • Hi to check the binding you either do the following:

    1- open the Internet Information Service (IIS) Manager

    2- expand sites, you should see three websites: default, lync external web site and lync internal web site

    3- Select the lync external website

    4- check the right pan of the IIS manager you should find "bindings" under the "Edit site" section 

    5- click on bindings you should find HTTP on port 8080 and HTTPS on port 4443 address *  this is for the external lync web site

    and you should find HTTP on port 80 and HTTPS on port 443 for the internal Lync web site 

     

    method 2 confirm bindings from the toppoloy builder by checking the Front-end pool properties node 

    regards,

     

     


    Charbel Hanna

    when i expand sites , there are only Default web site , i dont have lync external web site and lync internal web site .

    Tuesday, January 4, 2011 10:27 AM
  • If you do not see those secondar web sites then you have to go back to step 2 and re-run it.  If it prompts to reboot then do that, and then go back and start step 2 again until it completes. Them move on to step three.
    • Proposed as answer by Jordan Zielin Friday, December 2, 2011 7:45 AM
    Wednesday, January 12, 2011 3:46 PM
  • I'm getting the same issue with the certificates, I've checked all the bindings and they are correct though I only have Lync external, not internal. Is that a problem\ how do I get it created?

    I'm also having an issue with step 2 (setting up lync server components) with an error saying “Command execution failed: Not found: Web site "34577"”, is this causing the certification error maybe?

    I've also re-attached the server to the AD to ensure the trust is in place.

    Any advice would be appreciated

    Tuesday, November 27, 2012 2:42 AM
  • Hello guys,

    I was facing the same problem.

    I've noticed that, after running the Setup or Remove Lync Server Components, it asked me for a reboot.

    Done the reboot and tried to create/assign the certificate and received the same error. Checking IIS, I found out that both Internal and External websites were missing. 

    Running the Setup or Remove .. step again, it keep on installing a lot of things and after that, executing the certificate assignment goes well.

    Friday, December 7, 2012 12:12 PM
  • Yeah i agree running the ad/re again does the trick.
    Thursday, March 7, 2013 6:12 PM
  • This was exactly the case for my deployment. Step 2 had appeared to run successfully, but I encountered the same errors with HTTPS binding and not having the Internal and External websites in IIS. After re-running step 2, rebooting, and re-running step 2 one more time, the certificate assigned successfully.

    (Also, in my deployment we were using a self-signed certificate)

    Thursday, October 3, 2013 8:41 PM
  • Hi

    When i open my IIS, I don't have any site for lync just default web site is in there

    What should I do?

    thanks for helping


    alfONso

    Saturday, November 30, 2013 8:23 AM