locked
wmcmd.vbs (part of Windows Media Components) generates error 0x80040266 on Windows 7 RRS feed

  • Question

  • Hi, 

    I read with interest that someone has got Windows Media Encoder working under Windows 7:

    http://social.technet.microsoft.com/Forums/en/w7itproappcompat/thread/8534bc53-8979-45df-a5ff-8def93e38332

    I'm rather envious - I've tried all the suggestions on this thread, but I still get the error when running wmcmd.vbs:

    Error: 0x80040266 -

    The only reference I could find to this error was this page:

    http://msdn.microsoft.com/en-us/library/dd375623%28VS.85%29.aspx

    Which has the description:

    VFW_E_NO_TRANSPORTPins cannot connect because they don't support the same transport.

    For example, the upstream filter might require the IAsyncReader interface, while the downstream filter requires IMemInputPin .

    This makes no sense to me at all.  I've tried the standard and 64 bit versions, in XP (SP2) and Vista mode, and also applied the KB929182 patch. 

    Pretty much stumped - Windows is like a foreign country to me.  Anyone got any suggestions?

     

    Much appreciated,

    Thanks,
    David.

    Wednesday, June 2, 2010 11:35 PM

All replies

  • Hi David,

     

    Based on my research, it can be related to permissions in Windows 7. Please refer to the following similar issue:

     

    Alldayvideo creation on Win7 64 bit

     

    Please note: we provide the above similar issue for reference. Microsoft doesn’t guarantee any contacting information.

     

    Best Regards

    Dale

    Thursday, June 3, 2010 6:58 AM
  • Hi Dale,

    Thanks for your interest in this problem.  I tried running things from an elevated cmd window (run as administrator), but still have the same error.


    Any other ideas?

    Thanks,
    David,.

    Thursday, June 3, 2010 8:20 PM