locked
Issue when using "my local drafts folder" upon checkout RRS feed

  • Question

  • We have Windows 7, Office 2010 and Sharepoint 2007 and when you check out a spreadsheet from Sharepoint and have the checkbox enabled for "use my local drafts folder" any link within the document (such as links to other location within the spreadsheet) causes the message "Some files can be harmful to your computer" to pop up with any click of the links. 

    If you uncheck the box when checking out a document you only get the security warning prompt when you first open the file.  All links within the document work without prompting thereafter.

    We redirect My Documents to a network share and the default location for the drafts folder is a Sharepoint Drafts subdirectory.  I have tried adding the file server location to the trusted locations via GPO but didnt make a difference.  I have also tried changing the default location of the draft folder to a local drive (inlcuding a locaiton that is already in the trusted locations) but alas it still prompts on every link.

    Does anyone have any idea how to fix this?  I have scoured the web and can not seem to find a resolution.  :-(

    • Moved by Mike Walsh FIN Monday, February 28, 2011 5:48 PM Not Excel Services (From:SharePoint - Excel Services (pre-SharePoint 2010))
    Monday, February 28, 2011 3:12 PM

All replies

  • Hello William,
     
    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
     
    Thank you for your understanding and support.

    Wednesday, March 2, 2011 1:59 AM
  • Hi William,

     

    Here is the summary issue as I understand.

    Scenario: the “Versioning settings “ has been enabled for the SharePoint Document Library. Now , you want to check out the documents. When you check the “use my local draft folder” checkbox, you will get the error message pop up; but if you don’t check the checkbox, it works as expected. Now, you want to know how to avoid the error message when you check the “use my local draft folder” checkbox. Am I right?

     

    When you check the checkbox, the document will be download to your local folder when you check it out.  If the IE browser doesn’t know whether it’s a trust site or not, it will give you some warning message. So I suggest you to add the SharePoint site to the intranet or trusted site to your IE browser, and try again.

     

    Here is some other information about “local folder”:

    http://www.office-outlook.com/outlook-forum/index.php/m/649159/#msg_649159

    share your result.

     

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    • Marked as answer by KeFang Chen Friday, March 11, 2011 1:24 AM
    • Unmarked as answer by William Bracken Wednesday, March 16, 2011 3:45 PM
    Wednesday, March 2, 2011 2:24 AM
  • Hi William,

     

    Would you please let us know how is your problem going? Is the suggestion helpful for your issue?

    If you need further assistance, please feel free to let us know.

     

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Tuesday, March 8, 2011 1:42 AM
  • Hi Wayne, sorry for the delayed reply.

    The sharepoint site in reference above is indeed already listed as an "Intranet" site in IE.  When I check out a document and leave it on the sharepoint site (by unchecking the "use my local draft" option) the links within the spreadsheet work without prompting for harmful files.

    When I tell it to "use my local drafts folder" and it copies the file localy for editing is when I get the security warning prompt each time I click a link within the spreadsheet.

    I have tried setting the local drafts folder to various locations on the local drive as well as other network locations and adding those locations as a "trusted location" in the trust options in excel and yet it continues to prompt on every link click. 

    The link you posted above talks about disabling the "harmful file" prompt upon first launch of the file type.  I am fine with this particular prompt.  Even when I leave it on the sharepoint server for checkout I get this prompt the first time I open the doc.  Again thats fine.  The issue comes into play when you click on hyperlinks within the spreadsheet that points to different data within the same spreadsheet.  Each time you click a link you have to click OK to the "harmful file" warning before it takes you to that location in the spreadsheet.

    Hopefully this makes it more clear?

    Thanks!

    Wednesday, March 16, 2011 3:52 PM
  • Bump.  ;-)  This could be a major show stopper for us rolling out Office 2010.

     

    Thanks!

    Thursday, April 7, 2011 2:31 PM
  • Still hoping to get some feedback on this..

    Thanks,
    William

    Friday, April 22, 2011 9:16 PM
  • Hi William,

    You'd better create a new thread about this issue, many experts are focusing on new thread.

    Hope you get help there.

    Saturday, April 23, 2011 5:41 AM
  • We have seen this type of issue in the past with cross links being broken between documents because the URL links change from http: to the local path DRIVE: when using the local draft option.

    But your behavior is within the same document which is slightly different. I am leaning towards expected behavior due to how this code works but I will ask one of our Office Client Server Integration folks to look at this thread for me to see if they have any work arounds.


    Fred Ellis - MSFT - "Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread."
    Saturday, April 23, 2011 12:03 PM
  • Ed Barnes from our OCSI team reproduced this problem and after hooking up process monitor found a regkey entry that can be created/edited in order to bypass this problem on the client. See DisableHyperlinkWarning and EditFlags in the following KB.

    How to disable hyperlink warning messages in Office 2003
    http://support.microsoft.com/kb/829072

    If you have problems with this please open a support case with our Office Client Server Integration (OCSI) team.

    Also ...

    Having the drafts local rather than on a network/mapped drive is the route you want to go. Please see the following article on how changing this can cause problems.

    Word doc remains checked out if saving first, then closing Word, when SharePoint Drafts folder is redirected to network drive/mapped drive
    http://support.microsoft.com/kb/2025595


    Fred Ellis - MSFT - "Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread."

    Saturday, April 23, 2011 6:08 PM
  • Yeah, unfortunately I came across that thread awhile back and as comfirmed by numerous others who have tried this with Office 2010 that solution does not work.  :-/

    Unfortunately it appears we will have to open a case with Microsoft before we can roll Office 2010.  Thanks for trying anyway.  ;-)

    Monday, April 25, 2011 2:16 PM