none
Display name in To field not matching contact (outlook 2016)

    Question

  • One of my users has an issue with the display names in the To field. With a couple of internal users the contact details gets mixed up. In the attached example, he emailed me and my direct colleague but the display name and profile picture are from my account.

    When you hover of the names, you will see the the contact details of the correct person, except the name and profile picture.  This is happening with 5 to 10 contacts that he frequently emails.

    I checked his contacts in Outlook and everything looks normal. Deleting the faulty contacts from the suggested list didn't help, neither updating the address book.

    Any thoughts on how to resolve this issue?

    Outlook version: 1710 (build 8625.2121) with Office 365 ProPlus

    Monday, November 13, 2017 1:40 PM

All replies

  • Make sure he doesn't have any Contacts objects in his mailbox that are misconfigured.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, November 14, 2017 1:17 AM
  • Checked the contacts, they are all looking fine. Also testen Outlook Online, problem doesn't occur there. But the users has the same problem on the Remote Desktop (also Outlook 2016)
    • Edited by _Ruud Tuesday, November 14, 2017 7:28 AM
    Tuesday, November 14, 2017 7:20 AM
  • Checked the contacts, they are all looking fine. Also testen Outlook Online, problem doesn't occur there. But the users has the same problem on the Remote Desktop (also Outlook 2016)

    Hi Ruud,

    What does "outlook online" mean here? Outlook online mode or Outlook web access(OWA)?

    If start Outlook by using the /CleanAutoCompleteCache switch, is there the same issue?

    To do this, follow these steps:

    1.Click Start, and then click Run.
    2.Type Outlook.exe /CleanAutoCompleteCache.
    Note If Outlook is not installed in the default location, you must point to the path of Outlook.exe.

    Moreover, please also check if the faulty contacts have been set a linked contact to them. That may cause the similar issue.


    Best Regards,

    Niko Cheng


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 14, 2017 9:22 AM
  • Outlook Online is outlook.office.com (for Office 365).

    Tried the CleanAutoCompleteCache but that didn't help either.

    Tuesday, November 14, 2017 12:48 PM
  • I have seen the issue. It happens due to addressbook cache of lync or skype.

    The presence is not getting cleared. If you try to put the user in lync or skype, you will see the other name as you see in outlook. There is a link to clear the cache used by lync/skype


    Thanks & Regards Ramandeep Singh

    Wednesday, November 15, 2017 9:04 AM
  • Hello,

    It would helpful if explanations were full and clear.  Suddenly within last two weeks I have three users with the same problem.  We have been deploying Skype for Business recently; there seems to be an implication this may be related to the problem, but I do not understand your answer.

    What is a 'presence' that's not getting cleared?

    Where is this link to clear the cache used by lync/skype?

    Thank you,

    Saturday, May 12, 2018 12:16 AM