none
File shares on Server 2012R2 cause clients to hang during file access RRS feed

  • Question

  • Server Setup:

    • Dell T320 server - Intel Xeon E5-2420
    • VMWare ESXi Hypervisor build 1474528
    • Windows Server 2012 R2 Essentials
    • 2012 R2 acting as domain controller, providing DNS, DHCP, AD and file and print services

    Seemingly at random, when a client computer goes to save a file in Office 2007 (Word or Excel) on a Windows 7 SP1 or Windows XP SP3  machine to a mapped network drive, Excel or Word hangs during the save. (Beginning, middle or end of the progress bar... seems random.)

    This locks up the Excel or Word program/process, and sometimes even requires a full reboot to properly kill the program/process. It usually (but not always) also stops the machine from properly accessing the mapped network drive. Pings to and from the server IP are still returned. NSlookup still returns the correct path/ip for the domain. This happens with people joined to the domain AND people just using user credentials to access the file share.

    A .tmp file is created in the same directory by the client computer that stalled during saving, and when opened the temp file is complete and has the changes that were in the process of being saved. In the course of the file hanging, the file being used appears to be corrupted and any further use on ANY workstation or the server locks up the window or program being used to access that file. 

    If I reboot the server, the corrupted file is magically made usable again, with the changes that had been added, but the .tmp file is left in place in the directory. Without fail, a reboot of the server fixes the problem, at least for a time.

    After reboot, oftentimes the DNS table displayed on the router and the DHCP assignments given out on the server no longer match. Frequently I see multiple entries for a single computer name on the router DNS table. 

    Very similar problem reported here, but his solution did not work for me.

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/5c4e725c-09ab-4326-a064-4d8747e01c0c/unable-save-office-files-to-network

    Things I've tried:

    Disabling SMB2 in registry ala this link: http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

    Moving DHCP from the router to the server and disabling the DHCP service on the router. It's now effectively acting as a gateway only. 

    Static addressing of client and server machines.

    Mapping the network drives using ip addressing rather than the computer names.

    Providing exceptions in the windows firewall settings.

    I've tried swapping out our switches to make sure we don't have a malfunctioning network device.

    I tried swapping out the router for our old one, prior to moving DHCP services to the server.

    Additional Details:

    There is no antivirus software running, except Security Essentials on the client PCs. 

    All available updates have been installed for all client machines and server 2012

    Server share is from the on board hard drive, it is not NAS. 

    Server2012 is running on top of VMWare's ESX.

    Every so often, if I wait for 30-50 seconds, network connectivity appears to be restored and the save completes.

    Every so often, if I wait long enough, the save fails and I get the message "document not saved."

    I've gone through the event logs on client computers, but only a hang error ever seems to register.

    I've looked at the event logs on the server and can't find any specific warning/error that occurs every time, or even most of the time. 


    I'm very much a novice IT guy, and I'm trying frantically to pick up what I need. This is interrupting workflow in our office, often multiple times per day and I'm about ready to call in the pros. Something the boss and the accountant really don't want to do. Any help you folks can offer would be appreciated. 


    • Edited by bergmbe Thursday, March 6, 2014 3:25 AM
    Thursday, February 20, 2014 12:49 AM

All replies

  • Tried disabling SMB 2/3 from powershell as well. (Used Method 2 from here: http://support.microsoft.com/kb/2696547) Both on the server and on the client PCs that were most often experiencing the issue. (Windows 7) No luck.

    Once I see the problem materialize on one client PC, it's never too long before I hear of someone else having an issue. And any file that stalled out on the client that was originally having an issue will be inaccessible from any computer on the network

    Thursday, February 20, 2014 7:11 PM
  • For what it's worth, in case someone sees this and wants solutions... it appears it's likely an SMB problem, though details are iffy at best. I'm finding similar and identical reported instances in these threads:

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/e9567167-22db-4b8c-9f96-a08b97d507f9/server-2012-r2-file-server-stops-responding-to-smb-connections

    and here:

    http://www.edugeek.net/forums/windows-server-2012/126721-server-2012-file-server-suddenly-stops-serving-requests-but-otherwise-looks-fine.html

    But no permanent solutions have been found yet. As of 3/4/14, it appears there are at least 3 definite cases open with Microsoft where they're trying to resolve these issues. And it appears the problems are confirmed as far back as October 2012. It seems to afflict Windows Server 2012 and 2012R2 and client machines are confirmed to experience the problems in Windows XP, Windows 7, Windows 8 and Windows 8.1. 

    Tuesday, March 4, 2014 5:42 PM
  • Did you ever find a resolution to this issue? We believe we might be seeing something similar to you.
    Thursday, June 19, 2014 9:00 PM