none
DPM Agent Install Fails RRS feed

  • Question

  • Server is Windows 2003 x86 Sp2  

    Agent error


    Installation of a knowledge base article 975759 has failed. This is required for
     the DPM agent to function correctly.
    Install knowledge base article 975759 from http://go.microsoft.com/fwlink/?LinkI
    d=184897, and then try installing the DPM Agent again.
    Check log files in [WINDIR]Temp\MSDPM*.LOG
    Press Enter key to close the window

    I have tried to install the hotfix manually and get the same error.  

    MSDPMKB975759Install.LOG]
    5.860: ================================================================================
    5.860: 2010/09/05 16:55:29.798 (local)
    5.860: d:\9ed51d70d2da463723684845b27d42\update\update.exe (version 6.3.4.1)
    5.860: Hotfix started with following command line: /quiet /norestart /log:C:\WINDOWS\Temp\MSDPMKB975759Install.LOG
    5.891: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    8.000: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with error 0x2
    8.000: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with error 0x2
    8.000: DoInstallation: CleanPFR failed: 0x2
    8.000: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    8.000: SetProductTypes: InfProductBuildType=BuildType.Sel
    8.016: SetAltOsLoaderPath: No section uses DirId 65701; done.
    8.141: DoInstallation: FetchSourceURL for d:\9ed51d70d2da463723684845b27d42\update\update_SP2QFE.inf failed
    8.141: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB975759-v2$
    8.157: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed: 0xe0000102
    8.157: BuildCabinetManifest: update.url absent
    8.157: Starting AnalyzeComponents
    8.157: AnalyzePhaseZero used 0 ticks
    8.157: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
    8.157: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
    8.157: Enumerating Devices of computer, GUID {4d36e966-e325-11ce-bfc1-08002be10318}
    8.953: OEM file scan used 796 ticks
    9.282: AnalyzePhaseOne: used 1125 ticks
    9.282: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    9.282: AnalyzeComponents: Hotpatching is disabled.
    9.282: FindFirstFile c:\windows\$hf_mig$\*.*
    9.703: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntoskrnl.exe not found
    10.125: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntoskrnl.exe not found
    10.297: AnalyzeForBranching: Package required to migrate c:\windows\system32\ntkrnlpa.exe not found
    10.500: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrpamp.exe not found
    10.719: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrpamp.exe not found
    10.907: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrnlpa.exe not found
    11.344: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrnlpa.exe not found
    11.547: AnalyzeForBranching: Package required to migrate c:\windows\system32\ntoskrnl.exe not found
    11.735: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrnlmp.exe not found
    12.094: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrnlmp.exe not found
    12.110: AnalyzeForBranching used 2610 ticks.
    12.110: AnalyzePhaseTwo used 0 ticks
    12.110: AnalyzePhaseThree used 0 ticks
    12.110: AnalyzePhaseFive used 0 ticks
    12.125: AnalyzePhaseSix used 15 ticks
    12.125: AnalyzeComponents used 3968 ticks
    12.125: Downloading 0 files
    12.125: bPatchMode = FALSE
    12.125: Inventory complete: ReturnStatus=0, 3984 ticks
    12.125: DoInstallation: Installation was canceled because migration is blocked by following files:
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrnlmp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrnlmp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrpamp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrpamp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: KB975759-v2 Setup encountered an error:  Failed to migrate dependent packages.
    12.282: Failed to migrate dependent packages.
    12.282: Update.exe extended error code = 0xf0ea
    12.282: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    2.219: ================================================================================

     

     

     

     

    Tuesday, September 7, 2010 2:52 PM

Answers

  • From your log file I see the following two lines:

    0450 060C 09/09 14:47:40.200 10 main.cpp(3565)   NORMAL The Distributed COM Users group name = [Distributed COM Users]
    0450 060C 09/09 14:47:40.216 10 main.cpp(3591)   WARNING AddDPMServerToDcomGroup: NetLocalGroupAddMembers returned error 2141

    Since your protected server (to be) is a 2003 DC in a domain other than the DPM server's domain you are hitting the following issue.

    950156 The "NetlocalgroupAddMembers" function cannot add cross-domain objects to local groups on a Windows Server 2003-based domain controller that has hotfix 923354 installed
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;950156

    Install the hotfix from the above KB on the DC and reboot. Then try the agent install/setdpmserver.

    /Steve

     


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by eg0911 Thursday, September 9, 2010 10:31 PM
    Thursday, September 9, 2010 5:07 PM
    Moderator
  • OK... The first servere is fixed..  As the log in my first post, I had to install  KB979683 and then the agent installed successfully .   One thing to note, windows update did not show that I needed this update. 

     

    • Marked as answer by eg0911 Thursday, September 9, 2010 10:31 PM
    Thursday, September 9, 2010 10:31 PM

All replies

  • Hi

    If you got the hotfix installed on your DPM server share the catalouge RA that holds the agents and do a manually installation from that share. Be sure to be logged on as an domain administrator.

    Get back with info

    BR

    Robert Hedblom


    Check out my DPM blog @ http://robertanddpm.blogspot.com
    Tuesday, September 7, 2010 9:03 PM
    Moderator
  • Hello Robert,

    Thanks for your reply...  Where can I find the Catalogue RA.... I have tried both of the installation manually, first just the agent and then just the hotfix..  How is what you are asking me to do any different? I’m running the installs as a domain admin. Thanks in advance. 

     

    Wednesday, September 8, 2010 1:44 PM
  • I started to install another agent on a second server in the same child domain as the server above.  I can install the agent successfully but the service won't start and the SetDPMServer fails with the error below.  

    SetDpmServer failed with errorcode =0x80072141, error says: The specified group type is invalid.

    To further troubleshoot failures with SetDpmServer, go to  http://go.microsoft.com/fwlink/?LinkId=169142

    I edited the Component Services settings for the DPM RA Service on the protected computer to allow the DPM server to perform Activation and Launch.(both remote and local) But I’m still seeing the error below,

    The server {DA6AA17A-D61C-4E9C-8CEA-DB25DEA52A95} did not register with DCOM within the required timeout.

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    More info…. This server is a DC of a child domain. (Win2003R2x86-SP2)   The DPM Server is installed in the root domain.  I have been able to install agents on 10 Hyper-V servers (Win2008x64S-P2), 2 Win2003x86-SP2 and 2 Win2003x64-SP2 with Exchange 2007 in a CCR cluster. All of the agents that installed successfully are in the root domain.  There is a functioning two way trust between the two domains. There is also a hardware based firewall that has a rule to allow all traffic between the DPM server and the servers that I’m trying to protect.  No software based firewall are installed or activated. 

    Thursday, September 9, 2010 2:04 AM
  • Look at the real-time logs in the firewall when your running the SetDpmServer CMDLET. What firewall are you using? WatchGuard?


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Thursday, September 9, 2010 1:29 PM
    Moderator
  • Yes... We do use Watchgurad... But nothing is showing in the logs....

    MSDPMAgentBootstrap errorlog

    0450 060C 09/09 14:47:40.153 10 main.cpp(1677)   WARNING AddMachineToGroup returned error 2141
    0450 060C 09/09 14:47:40.169 10 main.cpp(1677)   WARNING AddMachineToGroup returned error 2141
    0450 060C 09/09 14:47:40.185 10 main.cpp(1147)   NORMAL Hr: = [0x00000000] SecUtils::GetMachineOrAccountSid wnyschools.net\BCKP returned
    0450 060C 09/09 14:47:40.200 10 main.cpp(3565)   NORMAL The Distributed COM Users group name = [Distributed COM Users]
    0450 060C 09/09 14:47:40.216 10 main.cpp(3591)   WARNING AddDPMServerToDcomGroup: NetLocalGroupAddMembers returned error 2141
    0450 060C 09/09 14:47:40.216 10 main.cpp(3592)   WARNING Failed: Hr: = [0x80072141] : F: lVal : (UINT)status
    0450 060C 09/09 14:47:40.216 10 main.cpp(3598)   WARNING Failed: Hr: = [0x80072141] AddDPMServerToDcomGroup failed
    0450 060C 09/09 14:47:40.216 10 main.cpp(4168)   WARNING Failed: Hr: = [0x80072141] : F: lVal : AddDPMServerToDcomGroup(hInstall, fNtlmAuth, dpmServerAccount)
    0450 060C 09/09 14:47:40.216 10 main.cpp(4200)   WARNING Failed: Hr: = [0x80072141] DoConfigurationForDPMServerName failed
    0450 060C 09/09 14:47:40.216 10 main.cpp(4111)   WARNING Failed: Hr: = [0x80072141] : F: lVal : DoConfigurationForDPMServerName(0, dpmServerName, fNtlmAuth, dpmServerAccount)
    0450 060C 09/09 14:47:40.013 10 setdpmserver.cpp(600)   NORMAL Using Thread Language ID = 1033
    0450 060C 09/09 14:47:40.013 10 setdpmserver.cpp(620)   NORMAL Configuring production server for DPM server =[dpmserver.domain.net]
    0450 060C 09/09 14:47:40.013 10 setdpmserver.cpp(686)   NORMAL Finding domain\machine format for DPMserver =[dpmserver.domain.net]
    0450 060C 09/09 14:47:40.122 10 setdpmserver.cpp(691)   NORMAL Trying to purge all non-AD user accounts if any
    0450 060C 09/09 14:47:40.122 10 setdpmserver.cpp(698)   NORMAL Configuring dpm server settings and firewall settings for dpm server =[domain\DPMServer]
    0450 060C 09/09 14:47:40.216 10 setdpmserver.cpp(701)   WARNING Failed: Hr: = [0x80072141] : F: lVal : ConfigureDpmServerSettings(dpmserverNameInDomainFormat, fNtlmAuth, ssUserAccountName)
    0450 060C 09/09 14:47:40.216 10 setdpmserver.cpp(822)   WARNING Failed: Hr: = [0x80072141] SetDpmServer failed, error says: [The specified group type is invalid.
    0450 060C 09/09 14:47:40.216 10 setdpmserver.cpp(822)   WARNING ]

    Thursday, September 9, 2010 2:49 PM
  • From your log file I see the following two lines:

    0450 060C 09/09 14:47:40.200 10 main.cpp(3565)   NORMAL The Distributed COM Users group name = [Distributed COM Users]
    0450 060C 09/09 14:47:40.216 10 main.cpp(3591)   WARNING AddDPMServerToDcomGroup: NetLocalGroupAddMembers returned error 2141

    Since your protected server (to be) is a 2003 DC in a domain other than the DPM server's domain you are hitting the following issue.

    950156 The "NetlocalgroupAddMembers" function cannot add cross-domain objects to local groups on a Windows Server 2003-based domain controller that has hotfix 923354 installed
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;950156

    Install the hotfix from the above KB on the DC and reboot. Then try the agent install/setdpmserver.

    /Steve

     


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by eg0911 Thursday, September 9, 2010 10:31 PM
    Thursday, September 9, 2010 5:07 PM
    Moderator
  • Hello Steve,

    Thanks for your reply....That hotfix fixed my installation issue on the second server. One down and one to go.... The first server is still not allowing me to install the agent...Below is the log.  Look at my first post for MSDPMKB975759Install.LOG]

    714 0AEC 09/09 18:51:32.311 06 installagent.cpp(115)   NORMAL Agent installation started
    0714 0AEC 09/09 18:51:32.311 06 bootstrapmsihelper.cpp(223)   ACTIVITY The agent bootstrapper is doing prerequisite checks
    0714 0AEC 09/09 18:51:32.311 06 bootstrapmsihelper.cpp(1110)   NORMAL OS version more than or equal to Win2K3SP2.
    0714 0AEC 09/09 18:51:32.311 06 bootstrapmsihelper.cpp(1141)   NORMAL Querying for DPMRA with Upgrade code: {2718092A-7CDA-43A6-955F-A08FB73A4808}
    0714 0AEC 09/09 18:51:32.311 06 bootstrapmsihelper.cpp(1220)   NORMAL Querying for DPMRA with product code: {3EC7C770-9F3F-4177-A754-EBFF04A1AFF2}
    0714 0AEC 09/09 18:51:32.311 06 bootstrapmsihelper.cpp(502)   NORMAL The agent bootstrapper is installing prerequisite KBs (KB975759)
    0714 0AEC 09/09 18:51:34.124 06 bootstrapmsihelper.cpp(307)   NORMAL The KB975759-v2 is not found
    0714 0AEC 09/09 18:51:34.124 06 bootstrapmsihelper.cpp(330)   NORMAL Launching Process d:\974d490430a39e92e2e39f155cc9c8aa\WindowsServer2003-KB975759-v2-x86-ENU.exe /quiet /norestart /log:C:\WINDOWS\Temp\MSDPMKB975759Install.LOG
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(367)   WARNING Process KB975759-v2 failed with exit code 1603
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(391)   WARNING Failed: Hr: = [0x80004005] : F: lVal : hr
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(398)   WARNING Failed: Hr: = [0x80004005] LaunchAndWaitForProcess returned
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(536)   NORMAL Hr: = [0x80004005] KB975759 installed returned
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(540)   NORMAL Hr: = [0x80004005] KB install failed, converting this to E_COORD_KB975759_FAILED
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(541)   WARNING Failed: Hr: = [0x80990a1c] : F: lVal : ((HRESULT) (((unsigned long)(1)<<31) | ((unsigned long)(0x99)<<16) | ((unsigned long)(0x00000000 + 0xA10 + (0x0C)))) )
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(557)   WARNING Failed: Hr: = [0x80990a1c] InstallPrereqKBs failed
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(233)   WARNING Failed: Hr: = [0x80990a1c] : F: lVal : InstallPrereqKBs(silent)
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(275)   WARNING PerformAgentInstall failed with errorcode=80990a1c
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(159)   WARNING Failed: Hr: = [0x80990a1c] : F: lVal : PerformAgentInstall(installargs, silent, skipKB)
    0714 0AEC 09/09 18:51:52.249 06 bootstrapmsihelper.cpp(162)   WARNING InstallProtectionAgent failed with errorcode=80990a1c
    0714 0AEC 09/09 18:51:52.249 06 installagent.cpp(116)   WARNING Failed: Hr: = [0x80990a1c] : F: lVal : InstallProtectionAgent(false , false )

     

    Thursday, September 9, 2010 7:15 PM
  • OK... The first servere is fixed..  As the log in my first post, I had to install  KB979683 and then the agent installed successfully .   One thing to note, windows update did not show that I needed this update. 

     

    • Marked as answer by eg0911 Thursday, September 9, 2010 10:31 PM
    Thursday, September 9, 2010 10:31 PM
  • Windows/Microsoft Update is not going to push all hotfixes out. Typically that is used for critical and security fixes, service packs, and application updates. The fix you mentioned, KB979683, is a security patch and WU should have taken care of it. You could always troubleshoot WU if you think it is missing updates for you.

    The following KB has a Fix it solution that will do common tasks to reset Windows Update for you.

    How do I reset Windows Update components?

     

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, September 10, 2010 9:37 AM
    Moderator
  • Server is Windows 2003 x86 Sp2  

    Agent error


    Installation of a knowledge base article 975759 has failed. This is required for
     the DPM agent to function correctly.
    Install knowledge base article 975759 from http://go.microsoft.com/fwlink/?LinkI
    d=184897, and then try installing the DPM Agent again.
    Check log files in [WINDIR]Temp\MSDPM*.LOG
    Press Enter key to close the window

    I have tried to install the hotfix manually and get the same error.  

    MSDPMKB975759Install.LOG]
    5.860: ================================================================================
    5.860: 2010/09/05 16:55:29.798 (local)
    5.860: d:\9ed51d70d2da463723684845b27d42\update\update.exe (version 6.3.4.1)
    5.860: Hotfix started with following command line: /quiet /norestart /log:C:\WINDOWS\Temp\MSDPMKB975759Install.LOG
    5.891: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    8.000: In Function TestVolatileFlag, line 12013, RegOpenKeyEx failed with error 0x2
    8.000: In Function TestVolatileFlag, line 12045, RegOpenKeyEx failed with error 0x2
    8.000: DoInstallation: CleanPFR failed: 0x2
    8.000: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    8.000: SetProductTypes: InfProductBuildType=BuildType.Sel
    8.016: SetAltOsLoaderPath: No section uses DirId 65701; done.
    8.141: DoInstallation: FetchSourceURL for d:\9ed51d70d2da463723684845b27d42\update\update_SP2QFE.inf failed
    8.141: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB975759-v2$
    8.157: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll failed: 0xe0000102
    8.157: BuildCabinetManifest: update.url absent
    8.157: Starting AnalyzeComponents
    8.157: AnalyzePhaseZero used 0 ticks
    8.157: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
    8.157: SetupFindFirstLine in LoadExclusionList Failed with error: 0xe0000102
    8.157: Enumerating Devices of computer, GUID {4d36e966-e325-11ce-bfc1-08002be10318}
    8.953: OEM file scan used 796 ticks
    9.282: AnalyzePhaseOne: used 1125 ticks
    9.282: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    9.282: AnalyzeComponents: Hotpatching is disabled.
    9.282: FindFirstFile c:\windows\$hf_mig$\*.*
    9.703: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntoskrnl.exe not found
    10.125: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntoskrnl.exe not found
    10.297: AnalyzeForBranching: Package required to migrate c:\windows\system32\ntkrnlpa.exe not found
    10.500: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrpamp.exe not found
    10.719: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrpamp.exe not found
    10.907: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrnlpa.exe not found
    11.344: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrnlpa.exe not found
    11.547: AnalyzeForBranching: Package required to migrate c:\windows\system32\ntoskrnl.exe not found
    11.735: AnalyzeForBranching: Package required to migrate c:\windows\driver cache\i386\ntkrnlmp.exe not found
    12.094: AnalyzeForBranching: Package required to migrate c:\windows\system32\dllcache\ntkrnlmp.exe not found
    12.110: AnalyzeForBranching used 2610 ticks.
    12.110: AnalyzePhaseTwo used 0 ticks
    12.110: AnalyzePhaseThree used 0 ticks
    12.110: AnalyzePhaseFive used 0 ticks
    12.125: AnalyzePhaseSix used 15 ticks
    12.125: AnalyzeComponents used 3968 ticks
    12.125: Downloading 0 files
    12.125: bPatchMode = FALSE
    12.125: Inventory complete: ReturnStatus=0, 3984 ticks
    12.125: DoInstallation: Installation was canceled because migration is blocked by following files:
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrnlmp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrnlmp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntkrpamp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntkrpamp.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\ntkrnlpa.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\system32\dllcache\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: Package KB979683, File c:\windows\driver cache\i386\ntoskrnl.exe, Version 5.2.3790.4666, Branch SP2GDR
    12.125: KB975759-v2 Setup encountered an error:  Failed to migrate dependent packages.
    12.282: Failed to migrate dependent packages.
    12.282: Update.exe extended error code = 0xf0ea
    12.282: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    2.219: ================================================================================


    Hi!

    Don't know if this issue is stil a problem for you, but it was a problem for me today for on all Windows 2003 (R2) servers.

    I was running a agent push from DPM 2010 to Windows 2003, 2003 R2 and 2008 servers. All 2003 en 2003 R2 servers failed.
    After some throubleshooting i discovered that some one (the sick ____!) deleted all C:\Windows\$NtUninstallKBxxxxx$ folders and also all folders under C:\WINDOWS\$hf_mig$
    Maybe setup checks those files or folders i don't know, perhaps someone from Microsoft could answer that for us. But it's another reason why not to delete those files and folders.

    When i tried reinstalling KB979683 and after that did a new agent push it worked!

    Try reinstalling the update by downloading it from one of the sites bellow:
    X32
    http://www.microsoft.com/downloads/en/details.aspx?familyid=0A7EA2D0-61CE-4B68-AD82-D917B1A56F9D&displaylang=en
    X64
    http://www.microsoft.com/downloads/en/details.aspx?familyid=1FC66F54-260A-4219-A0B4-056BA9DD0ABE&displaylang=en

    After that you should be able to push your DPM 2010 agents to your servers to protect.

    Good luck!

    Best regards
    Pascal

    Monday, October 18, 2010 2:48 PM