locked
Content deployment jobs all stopped running with 4958 error RRS feed

  • Question

  • We have had 4 web apps with content deployment running successfully 3 times a day for at least a year. Sunday night there was an error on one although it did not mail out a message. There were 2 4958 error messages associated with the failure which read:  

    Publishing: Content deployment job failed. Error: 'System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    at Microsoft.SharePoint.SPGlobal.HandleUnauthorizedAccessException(UnauthorizedAccessException ex)

    at Microsoft.SharePoint.Library.SPRequest.AddOrUpdateItem(String bstrUrl, String bstrListName, Boolean bAdd, Boolean bSystemUpdate, Boolean bPreserveItemVersion, Boolean bUpdateNoVersion, Int32& plID, String& pbstrGuid, Guid pbstrNewDocId, Boolean bHasNewDocId, String bstrVersion, Object& pvarAttachmentNames, Object& pvarAttachmentContents, Object& pvarProperties, Boolean bCheckOut, Boolean bCheckin, Boolean bMigration, Boolean bPublish)

    at Microsoft.SharePoint.SPListItem.AddOrUpdateItem(Boolean bAdd, Boolean bSystem, Boolean bPreserveItemVersion, Boolean bNoVersion, Boolean bMigration, Boolean bPublish, Boolean bCheckOut, Boolean bCheckin, Guid newGuidOnAdd, Int32& ulID, Object& objAttachmentNames, Object& objAttachmentContents, Boolean suppressAfterEvents)

    at Microsoft.SharePoint.SPListItem.UpdateInternal(Boolean bSystem, Boolean bPreserveItemVersion, Guid newGuidOnAdd, Boolean bMigration, Boolean bPublish, Boolean bNoVersion, Boolean bCheckOut, Boolean bCheckin, Boolean suppressAfterEvents)

    at Microsoft.SharePoint.SPListItem.Update()

    at Microsoft.SharePoint.Publishing.Administration.JobReportBase.Update()

    at Microsoft.SharePoint.Publishing.Administration.ContentDeploymentJob.EnsureLastReport()

    at Microsoft.SharePoint.Publishing.Administration.ContentDeploymentJob.Run(Boolean runAsynchronously)'

     

    I ran the job again and it went fine. I thought it was just one of those things. However since then there has been no successful run of a content deployment although it says the jobs were successul in central admin under the status column of the Manage Content Deployment Paths and Jobs page. But if you look at last run it shows that nothing has happened since Sunday.

    One other clue is, now if I try to run a job manually now, when I choose "Run now" from the job drop down, the page refreshes with an access denied. Since I have a policy on central admin, I have never seen an access denied message in this area. This also happens for the install account if I sign in with that.

    Can anyone tell me if they have seen this sort of behavior before? And of course more importantly, how can it be fixed?

    Tuesday, April 12, 2011 9:37 PM

Answers

  • Hi,

        Check the credentials under which the timer jobs  are running . As for the Access denied issue try setting the remote administrator access denied to false.

    Refer to by blog for details.

    http://dmohapatra.in/?p=11

    let me know.

     

    Regards,

    Deepankar Mohapatra

    http://dmohapatra.in

     

    • Marked as answer by Leoyi Sun Wednesday, April 20, 2011 8:36 AM
    Thursday, April 14, 2011 4:52 AM

All replies

  • One thing I should add that we found, the farm administrators group within Central admin seems to have lost a level of permissions. Members can no longer be added or removed from the group, the new button is missing and a number of abilities under actions has gone missing including the remove user permissions ability. Under settings you can no longer view the group settings.

    In our test environment you can see that the farm administrators group owns itself, and is the only one that has permissions to add and remove users.

    So it looks like the farm administrator group is not what it used to be.

    We cannot think of any infrastructure or other changes that were made during the timeframe when we went from being good to when it failed.

    Has anyone seen their farm administrator group lose permissions?

    Wednesday, April 13, 2011 2:35 PM
  • Restarting the server will let out all the error messages that are associated with the account. Also, have a look at the db space in the sql server machine. 

    We had few similar issues when we ran out of space. Although, this seems to be some sort of permission issue. 

    Hope it helps. 

    Thanks

    V


    V
    Wednesday, April 13, 2011 8:48 PM
  • Hi,

        Check the credentials under which the timer jobs  are running . As for the Access denied issue try setting the remote administrator access denied to false.

    Refer to by blog for details.

    http://dmohapatra.in/?p=11

    let me know.

     

    Regards,

    Deepankar Mohapatra

    http://dmohapatra.in

     

    • Marked as answer by Leoyi Sun Wednesday, April 20, 2011 8:36 AM
    Thursday, April 14, 2011 4:52 AM