locked
WSUS - windows 10 enable .net framework 3.5 error 0x800F081F RRS feed

  • Question

  • Hi All:

    When i enable .net framework 3.5 in windows 10 will get the error 0x800F081F.

    I had selected the "windows 10 Feature on Demand" at product sheet in WSUS but it did not work.

    Maybe i do not choose the right item in category from WSUS. Or should I use other methods to solve the issue?

    Thank you for your help.

    Wednesday, November 15, 2017 5:27 AM

All replies

  • Hi,

    >>When i enable .net framework 3.5 in windows 10 will get the error 0x800F081F.

    "

    If you are running Windows 10 and need to install something old that requires .NET 2 or .NET 3.5 you will likely follow the instructions to install it from PROGRAMS AND FEATURES > TURN WINDOWS FEATURES ON OR OFF > .NET FRAMEWORK (INCLUDES .NET 2.0 and .NET 3.0) but then find you receive  errors like 0x800F0906 and 0x800F081F .  This is frustrating.  Fortunately the solution is simple IF you have a Windows 10 source disk:

    You can install .NET 3.5 by bringing up a CMD window (don’t forget to right click and RUN AS ADMININISTRATOR) and then type either:

    Dism /online /enable-feature /featurename:NetFx3 /All /Source:<var><drive></var>:\sources\sxs /LimitAccess


    "
    https://www.urtech.ca/2016/01/solved-cannot-install-net-3-5-on-windows-10-error-0x800f0906-and-0x800f081f/
     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Elton_Ji Thursday, November 16, 2017 5:09 AM
    Thursday, November 16, 2017 5:09 AM
  • Hi Elton:

    Thank you for your information.  But I need a solution that meets the enterprise side so i did not choose this way.

    I also try the GPO to fix the issue but still fail. 

    https://technet.microsoft.com/en-us/library/dn482065.aspx?f=255&MSPPError=-2147217396

    https://www.kjctech.net/install-net-framework-3-5-on-windows-8-1-10-with-wsus/

    And i found someone say that windows 10 install .net 3.5 feature is different with windows 8.  Windows 10 is using "windows 10 feature on demand" from WSUS so the GPO is invalid.

    But I still get this error 0x800F081F.  

    Thursday, November 16, 2017 10:21 AM
  • Hi,

    I also tried to use "feature on demand" to install .Net 3.5 for win10 , but same result .

    As a workaround I'd suggest you try to copy the .Net 3.5 source file into a file share server , then configure the policy "specify setting for optional component installation and component repair" to cover your needs :

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 17, 2017 9:45 AM
  • Hi Elton:

    Thank you for your suggestion.

    I've thought about this way but i worried  the other windows version( win7、8、server version..... ) do not apply. I want to avoid maintaining all version of windows.

    Monday, November 20, 2017 2:22 AM
  • Hi,

    Actually , that policy applies to windows 8/2012 and later .

    As for windows 7 (in my lab) ,  .Net 3.5 is enabled by default .

    In addition , server 2008R2 do not need source file to install .Net 3.5 .

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Elton_Ji Monday, November 20, 2017 4:19 AM
    • Proposed as answer by Elton_Ji Wednesday, November 29, 2017 9:34 AM
    Monday, November 20, 2017 4:14 AM