locked
Allow user to edit email address in user information page in sharepoint? RRS feed

  • Question

  • I have FBA sharepoint. When user trying to edit user information (My settings). it is allowing edit only name and not email address. How allow them edit email address too? (not through programmatic)

    ItsMeSri MOSS, 3 WEFs
    • Edited by ItsMeSri Tuesday, March 15, 2011 2:07 PM
    Monday, March 14, 2011 7:25 PM

Answers

  • Hi,

     

    According to your description, I am sorry that I don’t understand what you mean. In my limited experience, SharePoint itself doesn’t allow changing of a  user’s email address. The only way of specifying an email address for a user is by using Remote Desktop and editing the user’s details directly.
     
    Best regards
    David Hu

     

    • Marked as answer by Emir Liu Wednesday, March 23, 2011 1:15 AM
    Wednesday, March 16, 2011 2:01 AM
  • Try to modify the settings in SSP, to allow users from editing values for the property, uncheck Do not allow users to edit values for this property.

    Refer to the following URL for more information

    http://technet.microsoft.com/en-us/library/cc263080(office.12).aspx#section2

     


    --Cheers
    • Marked as answer by Emir Liu Wednesday, March 23, 2011 1:15 AM
    Wednesday, March 16, 2011 6:52 AM

All replies

  • Hi,

    You questioning is confusing! Are you sayig that the user is unable to edit their email address?
    If so, check their SharePoint permission levels > "Edit User Info" checkbox is checked.

    hope this helps,


    -- techChirag
    Monday, March 14, 2011 10:21 PM
  • That was already checked still he is not able to edit his email address to update.

    ItsMeSri MOSS, 3 WEFs
    Tuesday, March 15, 2011 1:11 PM
  • Hi,

     

    According to your description, I am sorry that I don’t understand what you mean. In my limited experience, SharePoint itself doesn’t allow changing of a  user’s email address. The only way of specifying an email address for a user is by using Remote Desktop and editing the user’s details directly.
     
    Best regards
    David Hu

     

    • Marked as answer by Emir Liu Wednesday, March 23, 2011 1:15 AM
    Wednesday, March 16, 2011 2:01 AM
  • Try to modify the settings in SSP, to allow users from editing values for the property, uncheck Do not allow users to edit values for this property.

    Refer to the following URL for more information

    http://technet.microsoft.com/en-us/library/cc263080(office.12).aspx#section2

     


    --Cheers
    • Marked as answer by Emir Liu Wednesday, March 23, 2011 1:15 AM
    Wednesday, March 16, 2011 6:52 AM