locked
7.5 hour work day but resource levels to 8.0 RRS feed

  • Question

  • Hi,

    I have set my project hours for 7.5 (8-12 and 1-4:30) But when I level a single resource on a single 10 hour task with plenty of time, it levels to 8/2 instead of 7.5/2.5.

     

    What did I forget to set, and how do I find it?

    Thanks

    Monday, May 16, 2011 4:27 PM

Answers

  • Hi TJ?
     
    The simple answer is that Project is not designed to fill gaps.  It will resource level overallocation, but it only delays tasks until the resource is free.  I believe that your desires can be met by using one of the Usage views, but this is a manual, albeit effective method.
     
    Mike Glen
    Project MVP
    See http://tinyurl.com/2xbhc for my free Project Tutorials
    • Marked as answer by Mike Glen Saturday, December 10, 2011 8:02 PM
    Tuesday, May 17, 2011 8:13 AM

All replies

  • Please also check in Tools- >options -> Calendar if it has the settings of Hours per day - 7.5; Hours per Week -> 7.5hrs X 5 days and number of days per week -> say 5. etc.
    Sapna S
    Monday, May 16, 2011 4:56 PM
  • I apologize for my ignorance.  I don't see Tools -> options in Project 2010.  Can you point me to it?
    Monday, May 16, 2011 4:58 PM
  • In 2010 its in File -> Options -> Schedule
    Sapna S
    Monday, May 16, 2011 5:41 PM
  • It says 8-12, 1-4:30, 7.5 hr/day, 37.5 hr/week

    On my standard schedule, I also have 8-12, 1-4:30.

    I have set all tasks to use the standard schedule.

    Monday, May 16, 2011 5:46 PM
  • Did you change hours/day to 7.5 hrs in options here ? And 37.5 hrs/week?
    Sapna S
    Monday, May 16, 2011 5:48 PM
  • When you say here, do you mean in file->options or in change working hours?
    Monday, May 16, 2011 5:56 PM
  • actually, no matter how I get to it, it says 7.5 hours/day, 37.5 hours/week
    Monday, May 16, 2011 5:59 PM
  • Ok, so you mean your Calendar is all set for 37.5hrs/week. Now when you level it levels using 8hrs/day ?
    Sapna S
    Monday, May 16, 2011 6:03 PM
  • Yes, it split the task, but used 8 hours.

     

    May I email you the file so you can see?  I have inactivated most tasks to try and find out what I did wrong.  I figured I'd start with 1 longer task and then add in the others until it didn't do what I expected.  Unfortunately, that happened with the first additional task.

     

     

    Monday, May 16, 2011 6:07 PM
  • I sent it.  Thank you again.
    Monday, May 16, 2011 6:13 PM
  • Based on the File shared by Teri I found that the tasks had :

    1. Constrain Dates with Start No Ealier then or Finish no later then with dates defined.

    2. Predecessors were not defined for the tasks so it implied that if there are 8 tasks then all appeared to start in parallel at 8:00 am on a specific date, hence making the resource overallocated.

    3. Leveling option was set at Day-by-Day, hence it is not able to resolve hour-by-hour overallocation. Set hour-by-hour option.

    4. Each task is assigned individually task calendar, please assign a single Project Calendar for effective and single orde of scheduling.

    5. Run the leveling now, this will remove 80% of overallocation, rest you can work by drilling down the plan and using Team planner option.

    This will remove all overallocations.


    Sapna S

    Monday, May 16, 2011 6:57 PM
  • Sapna has gone to bed.  Is there anyone else who might be willing to take a look?
    Monday, May 16, 2011 8:01 PM
  • Unfortunately, this did not help.

    I am trying to schedule a single task around daily tasks.

    On 5/16 there are a few hours of daily tasks, and then it 4.75 hours of task 120, for a total of 8 hours.  It schedules .25 hours for 5/17.  The constraint is finish by 5/18.  Despite looking complicated, this would be a balanced schedule if it put 3.75 hours on 5/16 and .75 hours on 5/17, for a total of  3 hours on 5/17.

    In response to Sapna's comments:

    1. Constraint dates were applied to make the daily tasks daily, and only to those tasks.

    2. Predecessors were not defined because all tasks were daily except 120. 

    3. Hour by hour produced the same result as day by day.

    4. I assigned each task to the standard calendar because I though maybe the cause of the 8 hours was microsoft choosing the default 8 hr calendar instead of the standard calendar.

    5. I don't see why there should be any overallocation.

     

    I must be missing something simple that I can't get the 1 task to not overallocate when there is plenty of time.

     

    Thanks to anyone who will consider this.

    Teri

     


    Monday, May 16, 2011 8:36 PM
  • Hi newbie,
     
    Before I go to bed, you might like to see FAQ Item: 5. Default Working Hours
     
    FAQs, companion products and other useful Project information can be seen at this web address:  http://project.mvps.org/faqs.htm
     
    Hope this helps - please let us know how you get on :-)
     
    Mike Glen
    Project MVP
    Monday, May 16, 2011 9:56 PM
  • Hi Mike,

    Looked that one up before I asked the question.  Would you be willing to look at a very simple file?

     

    The premise is simple.  One person, a bunch of daily tasks whose duration varies by day.  During the remaining time, I'm trying to fill up the day with other projects that will be over in a few days.  My goal is to get project to automatically fill the day to 7.5 hours with the additional tasks, spread as long as necessary.

    Project would rather overallocate.  Even with a single extra task, it was splitting it so the total day was over 7.5 with a smaller than necessary amount on the second day and no extra work on the third day.

    I figure I'm missing something obvious.  I didn't think what I was asking for was that hard.

    Monday, May 16, 2011 11:02 PM
  • Hi TJ?
     
    The simple answer is that Project is not designed to fill gaps.  It will resource level overallocation, but it only delays tasks until the resource is free.  I believe that your desires can be met by using one of the Usage views, but this is a manual, albeit effective method.
     
    Mike Glen
    Project MVP
    See http://tinyurl.com/2xbhc for my free Project Tutorials
    • Marked as answer by Mike Glen Saturday, December 10, 2011 8:02 PM
    Tuesday, May 17, 2011 8:13 AM
  • Hi Mike, not sure if below is a limitation of MS Project 2016. 

    I've setup in Options that work hours is 7.5 hours per day. But when I view it in Resource Usage, it shows that the resource still has 0.5 hour availability and this confuses me. I noticed that MS Project computes availability based on 8 hours. Please help. Thank you. 

    Tuesday, June 25, 2019 9:40 PM
  • Vicente Juan Paolo,

    Well, no, resource availability is based on the resource's work calendar. Even though you may have set File > Options > Hours per day to be 7.5, if the Project calendar is still the Standard calendar that means you still have a normal 8 hour work day. And by default, the resource Base Calendar will also be the Standard calendar so the resource has 8 hours of availability each workday.

    The hours per day setting is used only to determine how a "day" will be shown in the Duration field. So for example, a single work day (per calendar), will display as 1.07 days in the Duration field if you have the option set for 7.5 hours per day.

    Hope this helps.

    John

    Wednesday, June 26, 2019 1:48 AM
  • Vincente, this old thread goes back to 2011. It might be better to start a new one.

    "limitation"? Hardly. That's how it works from the earliest versions of MSP.

    However, here goes. You went to file, options, schedule and set the hours/day to 7.5. What you have done there is tell MSP that when you type in a duration as "1 day" that will be interpreted as 7.5 hours. It's a conversion factor which is necessary because "day" is ambiguous and "hour" is not.

    Then when you look at the resource sheet you will see that the base calendar is "standard". That's because the project calendar is the standard calendar, and every resource gets as base calendar whatever is the project calendar when you create the resource. You can see the project calendar in project, project information.

    You will need to create a new calendar based on the standard calendar, and the new calendar will have work weeks with the start, finish times to match your 7.5 hour day.

    Then in project information make this the project calendar, and in the resource sheet make it the base calendar for the resource. Also, in project information make sure that the start time of the project matches the start time in the calendar. You will need to select a date/time format that displays time as well as date.

    Any help?

    Wednesday, June 26, 2019 2:06 AM
  • Thank you, John and Trevor. I combined the info that you both have shared and I got the solution I want.

    The working times set under OPTIONS has to be matched with the working times set in the calendar (either Base or Resource calendar) under PROJECT>WORK WEEKS>Details.

    I can now see the correct availability hours of resources under the Resource Usage view. 

    Thanks a lot!

    Wednesday, June 26, 2019 4:19 PM
  • Vicente Juan Paolo,

    You're welcome and thanks for the feedback.

    John

    Wednesday, June 26, 2019 7:56 PM