none
Reinstall WSUS on SBS 2011

    Question

  • Hello,

    Attempting to reinstall WSUS on SBS 2011.  We have tried the downloaded version of WSUS Setup and the version on the SBS repair DVD, which appear to be identical.

    It does not matter if the uninstall options are selected or not, the install fails.  The wsussetup.log file shows:

    2019-01-13 18:16:32  Success   MWUSSetup          Validating pre-requisites...
    2019-01-13 18:16:42  Success   MWUSSetup          Removing Wsus...
    2019-01-13 18:16:43  Success   CustomActions.Dll  Unable to get INSTALL_LANGUAGE property, calculating it...
    2019-01-13 18:16:44  Success   CustomActions.Dll  Successfully set propery of WSUS admin groups' full names
    2019-01-13 18:16:44  Error     CustomActions.Dll  Could not read regkey ContentDir (Error 0x80070002: The system cannot find the file specified.)
    2019-01-13 18:16:44  Error     CustomActions.Dll  SetPropertyFromRegistryStringValue failed (Error 0x80070002: The system cannot find the file specified.)
    2019-01-13 18:16:44  Error     CustomActions.Dll  SetUninstallProperties: Failed to set CONTENT_DIR property. Attempting to continue... (Error 0x80070002: The system cannot find the file specified.)
    2019-01-13 18:16:44  Error     CustomActions.Dll  SetUninstallProperties: Could not read regkey SqlServerName (Error 0x80070002: The system cannot find the file specified.)
    2019-01-13 18:16:44  Error     MWUSSetup          RemoveWsus: MWUS Uninstall Failed (Error 0x80070643: Fatal error during installation.)
    2019-01-13 18:16:44  Error     MWUSSetup          Wsus MSI uninstallation failed. (Error 0x80070643: Fatal error during installation.)
    2019-01-13 18:16:44  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80070643: Fatal error during installation.)
    2019-01-13 18:16:48  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80070643: Fatal error during installation.)

    Any suggestions for reinstalling?  Thanks for your help.


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Monday, January 14, 2019 12:04 AM
    Moderator

Answers

All replies

  • Hi Larry,

    It could be issue related to Windows Server Update Services it’s worth trying to repair and see.

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-essentials-sbs/gg680316(v=ws.11)

    Also please have a look the below thread: https://community.spiceworks.com/topic/987606-reinstalling-wsus-on-sbs-2011

    Hope this helps!

    ---------------------------------------------------------------------------------------------------------

    Please don't forget to “mark the replies as answers” if they helped, also set "like" it’s a boost for us to keep blogging J

    Click here to learn more. Visit the dedicated Community forum to shareexplore and talk to experts about Microsoft Kaizala.


    Monday, January 14, 2019 5:01 AM
  • Hi,

    If possible, I would recommend you to manually uninstall WSUS first, make sure that WSUS has been removed from current system, then, try to re-install and check the result.

    Reinstall WSUS on SBS:
    https://glennopedia.com/2016/02/25/wsus-and-sbs/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 14, 2019 7:11 AM
    Moderator
  • Hi, and thanks for the reply.

    Regarding the first link, I have done most of what it says.  Down to this part, where the installation fails:

    "Open a Command Prompt window with administrative privileges. See To open a Command Prompt window as an Administrator. At the command prompt, type <DVD Drive>:\CMPNENTS\wsus\wsussetup.exe /q DEFAULT_WEBSITE=0 CREATE_DATABASE=1 CONTENT_LOCAL=1 CONTENT_DIR=C:\WSUS WYUKON_DATA_DIR=C:\WSUS, where <DVD Drive> is the DVD drive for the computer, and then press ENTER"

    Regarding the second link, the solution was to do the above, which does not work.  There is a link in that thread that takes one back to your first suggestion.


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Monday, January 14, 2019 3:24 PM
    Moderator
  • Hi, and thank you for the reply and the suggestions.

    Regarding your suggestion to uninstall, this has been done.  There is nothing in Control Panel Programs nor Server Manger Roles.

    Regarding the link to Glennopedia:  The standard process is suggested in that link which is already done and failing to install.  There is a link to check registry entries.  The entry for WYukonInstalled was 1, now 0.  The entry for SqLInstanceIsRemote did not exist.  I have created it and set the value to 0.

    Any attempts to install result in failure.  I have saved the log files and can post the results here, but I know how tedious it is to read them here.  You can provide a place for me to post them or message me privately and I can sent them to you.  Or any other method you prefer. 

    Please note that the log file results are different, but still failure, if one ticks the boxes to remove the features first or not.

    Please let me know how to proceed.

    Thanks,

    Larry Struckmeyer


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Monday, January 14, 2019 4:14 PM
    Moderator
  • Hi,

    You may upload log file to OneDrive(https://onedrive.live.com/), share it and provide me the access link.

    Please note that, log file may include private information, you may choose not to share it due to security consideration. Or, you may manually cancel the sharing once I have download your log file. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, January 16, 2019 2:06 AM
    Moderator
  • Hi Eve,

    Thanks for the response.  Here is the link to the setup files:

    https://1drv.ms/f/s!Ah28u7O_KbhJjqlHU5arEUOsmiWyxA

    Please let me know what else I can do to assist.

    Thanks,


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Wednesday, January 16, 2019 3:19 PM
    Moderator
  • Hi,

    I had downloaded the file, and you may safely delete it or disable sharing the log.

    I will check the log and reply to you as soon as possible. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 18, 2019 9:46 AM
    Moderator
  • Hello,

    Is there any update to this?  Were the log files of any assistance?  Is there anything else I can send/tell you?

    Thanks,

    -Larry Struckmeyer


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Thursday, January 24, 2019 2:55 PM
    Moderator
  • Hello,

    Any progress on this?  Customer is falling behind on updates and I don't want them to be installed automatically if WSUS can be fixed.

    Thanks,

    -Larry


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Tuesday, January 29, 2019 3:10 PM
    Moderator
  • Hi,

    Sorry for my later reply. Based on the log file, it seems that problem happens due to registry entry, such as registry entry missing, permission losing and etc. 

    If you need to have an further identification, we need to capture detail process log, compare it with working process, to find out the problematic registry entry. 

    Tool such as Process Monitor can be considered:
    https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

    I would suggest you contact Microsoft Customer Support and Services where more in-depth investigation can be done so that you would get a more satisfying explanation and solution to this issue. 

    Global Customer Service phone numbers:
    https://support.microsoft.com/en-us/help/13948/global-customer-service-phone-numbers

    Best Regards,
    Eve Wang



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 30, 2019 8:33 AM
    Moderator
  • Hello,

    This issue has been resolved by contacting Microsoft Customer Support and Services as suggested by Eve.  Therefore I will mark her reply as the answer, even though I already knew of this avenue.


    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Monday, February 18, 2019 11:59 PM
    Moderator