none
The control type 'Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader' is not allowed on this page. The type is n RRS feed

  • Question

  •  

    Hello,

     

    i can deploy a dashboard successfully to MOSS, but if i try to start the site i am getting the following error message:

     

    "The control type 'Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader' is not allowed on this page. The type is not registered as safe. "

     

    What´s going wrong?

     

    Thanks

    Bernd

    Friday, November 9, 2007 6:29 PM

Answers

  • Hi Bernd

     

    Have you got MOSS installed on the same box as PPS Monitoring?

     

    This is usually due to an entry missing from the web.config of your MOSS site but the entry should be made when you install PPS.

     

    Your MOSS web.config is usually found in C:\Inetpub\wwwroot\wss\VirtualDirectories\XXXX\ where XXXX is the port that you have Sharepoint installed on.

     

    You should have the following entry in the <SafeControls> section of the config file:

     

    <SafeControl Assembly="Microsoft.PerformancePoint.Scorecards.WebParts, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="Microsoft.PerformancePoint.Scorecards.WebParts" TypeName="*" Safe="True" />

     

    Once you have added it run IISReset from a commnd prompt and try your dashboard again.

     

    Hope this helps

     

    Tim

    Friday, November 9, 2007 9:23 PM

All replies

  • Hi Bernd

     

    Have you got MOSS installed on the same box as PPS Monitoring?

     

    This is usually due to an entry missing from the web.config of your MOSS site but the entry should be made when you install PPS.

     

    Your MOSS web.config is usually found in C:\Inetpub\wwwroot\wss\VirtualDirectories\XXXX\ where XXXX is the port that you have Sharepoint installed on.

     

    You should have the following entry in the <SafeControls> section of the config file:

     

    <SafeControl Assembly="Microsoft.PerformancePoint.Scorecards.WebParts, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="Microsoft.PerformancePoint.Scorecards.WebParts" TypeName="*" Safe="True" />

     

    Once you have added it run IISReset from a commnd prompt and try your dashboard again.

     

    Hope this helps

     

    Tim

    Friday, November 9, 2007 9:23 PM
  • Hello,

     

    thanks, that helps, but now i get another error "Web part Error unexpected error has occured"

     

    Regards

    Bernd

    Monday, November 12, 2007 6:07 PM
  •  

    Hi Bernd

     

    It sounds like your installation may have had some issues.  If you go to C:\Windows\Assembly Folder on your server can you see any libraries that are namespaced Microsoft.PerformancePoint.Scorecards.*

     

    If not then it's worth re-installing and re-configuring the Monitoring Server.

     

    Hope this helps

     

    Tim

    Tuesday, November 13, 2007 4:50 PM
  • I got the same error when I tried to view a dashboard deployed to another site on the same server I found the following solution: http://blogs.msdn.com/performancepoint/archive/2007/11/12/how-do-i-deploy-the-monitoring-web-part-on-a-separate-sharepoint-web-application-on-the-same-sharepoint-web-server.aspx

     

     

    Simon

    Friday, November 23, 2007 6:48 AM
  • hi,

     

    i am facing the same error as "unexpected error". i checked in the assembly folder and i do have the dll's in there. please let me know what can be done.

     

    thanks

    aananta

     

    Wednesday, November 28, 2007 7:57 AM
  •  

    Have you deployed the webparts correctly, check the link to the blog post in my previous post and make sure that all the sets have been done. That worked for me.

     

    //Simon

    Wednesday, November 28, 2007 8:41 AM
  •  

    Hi,

     

    I have been trying to run the following command from  C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN

     

    stsadm.exe -o deploysolution -name PSCWebParts.cab -url  http://manishdesktop:31947  -local   -allowgacdeployment -force.

     

    I get an error saying "object reference not set to an instance of an object"

     

    I have the site http://manishdesktop:31947 up and running.

     

     

    thanks

    aananta

    Wednesday, November 28, 2007 11:08 AM
  • Hey that code worked for me. I was having Moss 2007 but i wanted to make PerformancePoint Server work using WSS 3.0. So i uninstalled Moss and installed WSS 3.0 and that disturbed my structure and i started getting the error message as the webpart performancepoint.scorecard was removed from my sharepoint. The above code referenced the PerformacePoint server and it started working again

     

    Thanks,

     

    Daljit Saini

    Thursday, December 6, 2007 7:42 PM
  • hi all,

     

    I have followed all the steps mentioned in the blog. but now i am getting this error for all the webparts.

    "

    PerformancePoint ‭[1]‬

    The database connection failed. Please contact an administrator

     

     

     

    I have checked these things also.

    1. i am the admin on the server

    2. i am using my credentials for application network identity for the monitoring application as well as the sharepoint site.

    3. the web application which was used while installing the PPS-M is able to show all the webparts.

    4. i have permission on all the datasources

     

    regards

    Rohit

    Tuesday, March 11, 2008 7:53 AM
  •  

    after following the intructions in the blog linked to above, i have hit exactly the same problem as Rohit.  Did anyone find a fix for this?

     

    Guy

    Wednesday, June 11, 2008 1:21 PM
  •  

    Hi guys,

     

    I was getting the same error as mentioned

     

    The database connection failed. Please contact an administrator
     
    Actually there is entry in web.config file which is like this
     

    <add key="Bpm.MonitoringConnectionString" value="Data Source= YOUR_DATABASE_SERVER;Initial Catalog=PPSMonitoring;Integrated Security=True" />

     
    In place of YOUR_DATABASE_SERVER, I gave My database server name .
     
    After which i was able to publish performance point server dashboard in sharepoint
     
    Thanks
     
    Girish
    Thursday, July 17, 2008 1:13 PM
  • When i run the pcswebparts.cab solution, i get the following error:

     

    Error: Cannot add the specified assembly to the global assembly cache: Microsoft.PerformancePoint.Scorecards.WebParts.dll.

     

    can someone please guide me...The dashboards were working fine, since the past 2 days this suddenlys topped working.

    Please advice, i have been trying to do this since last 2 days...and its really urgent

     

    thanks

    Wednesday, September 10, 2008 9:10 AM
  •  

    Add the assembly 'Microsoft.PerformancePoint.Scorecards.WebParts.dll'

    manually to the Global assembly gache

     

    Thanks

     

    Wednesday, September 10, 2008 9:20 AM
  • Thanks Girish, can you pls. advice where exactly i need to look for this.

    I am new to this.

     

    Thanks

    Wednesday, September 10, 2008 9:24 AM
  • any idea on this. Plis advice

    Wednesday, September 10, 2008 9:43 AM
  • Wednesday, September 10, 2008 10:02 AM
  • Did that as well but the solution is not getting deployed and throwing the error that it cannot find "Microsoft.performancepoint.scorecards.webparts.dll in the global assembly cache"

    Wednesday, September 10, 2008 10:05 AM
  • Any idea on how i could solve this problem?

    There are 2 things to the problem:

     

    1) My pcswebparts.cab deploy solution is not successful and throws the following error:

     

    "Error: Cannot add the specified assemby to the global assembly cache: Microsoft.PerformancePoint.Scorecards.Webparts.dll"

     

    2) I continued editing the webconfig file as suggessted in the link and when i open my site to view the dashboard. it throws the following error

     

    "PerformancePoint[2]: The Dashboard is unavailable. Contact your system administrator".

     

    Can some one please help me. Its realy urgent Sad

    Thursday, September 11, 2008 7:00 AM
  • Can someone plis give me suggesstions, im stuck with this badly Sad

    Friday, September 12, 2008 6:47 AM
  •  

    Hello,

     

    Have you tried to add the dll to the global assembly cache?  See here:

     

    http://msdn.microsoft.com/en-us/library/ex0ss12c(VS.80).aspx

     

     

    For your second error this is usually an indication that your web.config file is pointing at the wrong PPSMonitoring database or server.  Do you have more than one PPSmonitoring db in SQL?

     

    See my solution here: 

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3840087&SiteID=17

     

     

    Aseem Nayar - MSFT

     

     

    Friday, September 12, 2008 2:34 PM
  • Thank you. I just went ahead and re-installed Monitorign Server components and it started working fine.

    The web config file had PPS related data missing and the pmswebserivce file was corrupted.

     

    Thanks everyone

    Wednesday, September 17, 2008 10:02 AM
  • Thanks Simon,

    This article was so helpful and resolve my problem.
    That worked for me..

    Thanks,
    Arash
    Tuesday, May 19, 2009 6:28 AM
  • I followed the steps. Slowly got passed one problem after another.  Installed AJAX 2.0 Ext 1(not mentioned in this article but thats while I was getting an error in the web.config)But now when i try to deploy from PP to SP, I just get a message that says, Dashboard 'TestDashboard' was not deployed.  No error logs on any server or machine are recorded.  On another note, I do see that I can start to add the PerformancePoint Dashboard Item web part to a page, but when the page is about to load, it just says 'file not found'.  Oh ya?  What file.  The installation of this is aweful beyond belief.  I guess my only choice is to try to install PP on the same server as SP MOSS.
    • Edited by Question Guy Friday, September 25, 2009 6:30 PM typo
    Friday, September 25, 2009 6:30 PM
  • hi,
    When I try deploying the report on a new SharePoint site on which I have admin or contributor rights( which I had not specified while configuring monitoring server "Dashboard view for SharePoint services"), I get access to the SharePoint site and my report gets deployed in the shared documents folder. Since I had not specified the site in the configuration the web part fails to give me access to the reports and generates the following error (The control type 'Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader' is not allowed on this page. The type is not registered as safe.). After specifying the server in the monitoring server configuration I  am not able to deploy the web part at all giving me the following error (The URL for the SharePoint Site is not valid, or you currently have no access to this SharePoint Site. Please enter a new URL), even though I have full admin access. what is it that makes the deployment unsuccesful after configuring the monitoring server to that sharepoint site. even after changing the configuration to some other sharepoint site, the previous site fails to deploy the reports.
    Tuesday, February 2, 2010 10:26 AM
  • Hi,

       Please check the applications pools of your sharepoint site and Monitoring server. If they are running under network service then change it to configurable. Both the application pools should run under a specified domain account.

    HTH,
    Ram
    Wednesday, February 3, 2010 1:33 PM
  • hi,
    i have changed the application pool identity of both the sharepoint site as well as the monitoring server to my id under the specified company domain i am using. the problem still persisted
    i reinstalled the software but it now gives me the following error
    (there are currently no document libraries for this sharepoint site.Please select another sharepoint url or contact the sharepoint administrator to add a document library to the sharepoint site)
    even though i created a seperate library for the same(apart from the default shared library) i am not able to understand the reason behind the error. Kindly provide some input. 
    Thursday, February 4, 2010 5:46 AM
  • Hi,

      Are you providing the complete URL for sharepoint in the Sharepoint link?? if you are providing the complete URL then its wrong. You just need to provide

    http://servername:portnumber/sitename/  . Once you provide like this the doc lib name will appear in the dropdown. Make sure you do not use default.aspx in your URL.


    HTH,
    Ram
    Thursday, February 4, 2010 6:12 AM
  • i am not providing the complete URL this error is showing up after i configured the site to enable anonymous access on my account. i am proving the following url http://servername:portnumber as my site's address is http://chdsez101762da:6550/default.aspx
    Saturday, February 6, 2010 6:23 AM
  • Hi,

        Make sure you have added SPAlertsCounter entry inside safe control section of config file.

        http://crazzycoding.blogspot.com/2010/11/spgridviewwebpartspalertscounter-is-not.html

     

        Once make this entry you can follow this post to insert required config file entries.

     

     

    Thanks,

    Ashish Chotalia

    Sunday, November 14, 2010 5:52 AM
  • stsadm -o deploysolution ... returned 
        "Error: Cannot add the specified assembly to the global assembly cache: Microsoft.PerformancePoint.Scorecards.WebParts.dll."

    The only way I could break it free was to open a CMD window and manually delete the existing .dll file from the GAC object folder.
        cd C:\WINDOWS\assembly\GAC_MSIL\Microsoft.PerformancePoint.Scorecards.WebParts\3.0.0.0__31bf3856ad364e35
        del MicrosoftPerformancePoint.Scorecards.WebParts.dll


    -Steve
    Saturday, November 20, 2010 10:50 PM