none
inbound sync rule not applied RRS feed

  • General discussion

  • Hello,

    Working with FIM 2010 with an ECMA file MA the inbound sync rule is not applied.

    In this situation there are several ECMA file MA which work fine. One however is not working properly. The inbound sync rule is not applied.

    When a new identity is found in the connected system the identity is created in the CS, updates are also applied to the CS with an Import no errors.

    With a full sync there are no errors, however the changes are not synced to the MV nor are the new identities created.

    The sync rule is configured to create a FIM resource.

    Already tried:

    a small change to the sync rule and a full import/full sync from FIM no result.

    Refresh of the MA schema no result.

    Remove identity from CS and add identity no result.

    Is there anything else I can try?

    Friday, November 16, 2012 9:13 AM

All replies

  • This is just some general troubleshooting I usually do, but maybe it will help. 

    Do you see the rule on the provisioning tab of the user in the FIM portal? If not, you may need to re-trigger the application of the sync rule to the user (ie by removing and then re-adding him to a set).

    Once the rule is confirmed on the user, a preview may help after you import the user to the sync. Check that the attributes the SR relies on are all there and maybe check the FIM log in the event viewer for any clues.

    I'm assuming you have the flows on the FIM MA for expected and detected rules extensions.

    Friday, November 16, 2012 12:16 PM
  • Hello SamiVV,

    These are inbound syncrules. They are applied when a new object enters a Connector Space. The rules define attribute mapping between Connectors Space attributes and Meta Verse attributes. So the object is not present in FIM yet.

    The preview shows no error, the rule just does not get applied. The strange thing is, this has worked as 430 objects can testify. It suddenly stopped working.

    Friday, November 16, 2012 12:53 PM
  • Hi,

    Random things to check--that synchronization rule provisioning is still checked under Tools-->Options. I've also had weird experiences where re-entering the credentials in the FIM MA has cleared things up.

    Does the preview show any attribute precedence that might be causing a conflict?

    Sorry--have not encountered your particular error, so these may not be very helpful.

    Thanks,


    Sami

    Friday, November 16, 2012 2:10 PM
  • Hello Sami,

    The option is checked but to avoid problems I unchecked it, full import/full sync. Enabled it again full import/full sync no change in behavior.

    The preview does not show any error, just the sync rule will not be applied. I.e. no provisioning for new accounts, no changes for updated accounts.

    No precedence conflict, the MA which supplies the values is listed as the correct source, just no changes.

    I have restarted the service but not re-entered the password. For other, similar, MA's everything works fine.

    Fer

    Friday, November 16, 2012 4:30 PM