locked
Clear Type, Segoe revisited RRS feed

  • Question

  • I have been searching this forum and I did find several related queries regards this, but none of them could resolve the issue in entirety.

    I have been trying out on Windows 7 on a desktop and a laptop. Both have nvidia cards, with the latest drivers.

    The clear type font appears extremely blurry to me, and is severely straining my eyes. If I manually tweak the clear type settings, the results are the same, no matter what settings I try. Turning off clear type looks horrible as well. This also seems to be tied to the use of Segoe as the shell font.

    All I would like is a single place to do system wide settings like Windows XP, with standard font smoothing and Tahoma Font. But this is proving a herculean task no matter what I try.

    Any ideas?

    Thanks
     
    • Edited by pcube Sunday, May 31, 2009 5:45 PM
    Sunday, May 31, 2009 5:42 PM

All replies

  • Hello pcube,

    One way of achieving your goal would be to change the fonts and types manually.  If you go to the Personalization screen and choose Windows color,  choose change advanced settings.  Here you can change all the text fields to Tahoma and possibly make it bold to see if it gets clearer.  Another suggestion  would be to use the default Windows WDDM driver that came with Windows 7.  Hope any of these suggestions help. 
    Monday, June 1, 2009 1:36 AM
  • Hi,
    I did try to do this too. But it doesn't seem to affect some elements or the other. e.g. The title bar of the dialogs/windows is still blurry, or typing quoted phrases in IE/Mozilla is just unreadable. Not to mention that these changes (when they do affect some elements) are nowhere near the 'crispiness' of the windows XP font render with standard font smoothing on both the laptop/desktop

    "Another suggestion  would be to use the default Windows WDDM driver that came with Windows 7.  Hope any of these suggestions help."
    This is something along the lines of what I am looking for actually. A way to do it brute force/system wide. How do I use the default WDDM driver?

    Monday, June 1, 2009 5:28 AM
  • pcube,

    The differences between WDDM 1.0 and 1.1 aren't immediately clear to many Windows 7 prerelease users. WDDM 1.0 is the display driver model introduced with Windows Vista, and many video drivers automatically installed with Windows 7 default to this driver model out of the box. ATi, nVidia, and other video card manufacturers have since built drivers using WDDM 1.1, and these have been distributed since the release of the Windows 7 beta both via Windows Update and on the manufacturers' websites. If, in fact, you're using the nVidia beta 185.xx drivers, then you're using WDDM 1.1; you could try selecting "Roll back driver" from your display device properties in the device manager to roll back to a WDDM 1.0 driver.

    You'll find a very good writeup on the differences between WDDM 1.0 and 1.1 here , if you're that way inclined.
    -Alex
    Monday, June 1, 2009 2:55 PM
  • I did realize after I posted that the nvidia drivers that I have installed were infact built using the WDDM model/standard. I got a bit confused thinking that WDDM had something to do with the font render engine or something to that effect, and separate from the graphics card driver. Anyhow, doesn't matter..

    Back on the topic at hand, rolling back the drivers doesn't work. Infact, I have 2-3 versions of nvidia Windows 7 drivers from the point they started releasing the drivers for Windows 7. None of them solve the problem.

    It is my belief that this has nothing to do with the driver or the lcd on my desktop, laptop. But something to do with the way fonts are handled in the system. Which is why the changes mentioned SamMcp1123 don't seem to be cascaded through system wide:

    "The title bar of the dialogs/windows is still blurry, or typing quoted phrases in IE/Mozilla is just unreadable"

    I fear this is someting to do with how SeGoe and ClearType are tighly integrated. Is there a registry setting (recommended or not) that I can try at my own risk, for getting the same
    standard font smoothing as Windows XP, and Tahoma Font system wide?

    Thanks,

    Monday, June 1, 2009 4:03 PM
  • Another way to get back to the default WDDM driver is to uninstall the video card from Device Manager and let Windows 7 re-install with the default drivers.  If that is successfull keep your eye on Windows Update for the newer versions.
    Monday, June 1, 2009 4:04 PM
  • I did do all that as I mention. I can roll back the driver. I also tried different nvidia drivers. I meant to say, that this doesn't solve the problem at hand.
    Monday, June 1, 2009 7:04 PM
  • Please let me know if you found a solution. I've disabled Cleartype, disable font smoothing, replaced Segoe UI with Tahoma everywhere I could, added Tahoma to the font substitutions list, and tried just about every other tweak I can find.

    And still, the titlebar, taskbar, and certain control panel / menu dialogues are stilll anti-aliased! GAHHHHHHHHHH!!!! I can't stand that blurry text! It's unreadable and gives me a splitting headache! Why do you hate me so much, Microsoft?



    Sunday, August 9, 2009 2:27 AM
  • I'm finding the same issue with Win7 appearing blurry.

    Now, I noticed that if I use Personalize and choose the Windows Classic them all my text and menus are changed system wide and look nice and sharp and don't create eyestrain. The downside is that cripples all the nice features of Aero.

    Is there a way to setup a happy medium?
    Tuesday, September 22, 2009 1:23 PM