locked
Win 7 - Explorer association problem RRS feed

  • Question

  • When I've tried to open the "Downloads" folder (Win 7), it doesn't open but the pop-up message has been shown like;

    Explorer.exe
    This file does not have a program associated with it for performing this action.
    Please install a program or, if one is already installed, create an association in the Default Programs control panel.

    Besides, the icon of "Downloads" doesn't look like a folder anymore. It looks like a sheet. The explorer program works fine.I don't know how to fix this problem. I've followed a couple of suggestions which are available in some Winhelp web site but that didn't help. Please let me know how to fix this trouble. Thank you.

     


    Thursday, November 4, 2010 12:40 AM

All replies

  • Hi,

    Please use the following tool FIXEXELNK http://www.ptorris.com/download.php?file=fixexelnk.zip

    Check all the options and see if it works.


    Blog Microsoft | Déployer Windows 7 | Améliorer les performances de Windows 7
    Thursday, November 4, 2010 1:59 AM
  • Thanks for your reply.

    Unfortunately, it didn't help. Besides, all description in the file is written in French and this doesn't help either at all.

    Let me know other ways to fix this trouble. Thank you!

    Thursday, November 4, 2010 2:21 AM
  • You need to determine what happened to cause this. It doesn't happen on it's own. Install software, remove a virus, etc.

    Anyway, Click Start=>All Programs=>Accessories=>right-click command prompt=>select Run as Administrator=> type sfc /scannow, tap enter. This will examine and attempt to repair system files. It will take a while. Be patient. When it's completed, reboot and test Windows Explorer.

    Alternatively, you could select a restore point prior to this problem and perform a system restore. Start\Control Panel\System and Security and select restore your computer to an earlier time under the Action Center category.

    Thursday, November 4, 2010 2:33 AM
  • Unfortunately, it didn't work at all. The system restoration didn't work either.

    I have several documents in the "Downloads" folder. Is there anyone who can really fix this problem?

    Thanks a lot in advance.

    Friday, November 5, 2010 1:14 AM
  • Try to reset the registry setting for the download folder. copy the following in a notepad and save it as download.reg and execute it. (replace Yannick with your username in the setting "C:\\Users\\Yannick\\Downloads" below

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
    "{374DE290-123F-4565-9164-39C4925E467B}"="C:\\Users\\Yannick\\Downloads"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
    "{374DE290-123F-4565-9164-39C4925E467B}"=hex(2):25,00,55,00,53,00,45,00,52,00,\
      50,00,52,00,4f,00,46,00,49,00,4c,00,45,00,25,00,5c,00,44,00,6f,00,77,00,6e,\
      00,6c,00,6f,00,61,00,64,00,73,00,00,00

    and try also the Fix It tool:

    http://support.microsoft.com/gp/windows_file_and_folder_diag
    http://support.microsoft.com/gp/system_maintenance_for_windows


    Blog Microsoft | Déployer Windows 7 | Améliorer les performances de Windows 7
    Friday, November 5, 2010 1:24 AM
  • Thanks a lot for your suggestions.  I've followed and tried all you suggested but nothing was worked to solve the problem.

    Do I have to give up? It's really frustrating. Anyone can help?

     

    Friday, November 5, 2010 1:46 AM
  • Download and apply the "folder" association registry fix from my File Association Fixes for Windows 7 page. If that's not enough, apply the "directory" association fix as well.
    Blog Microsoft | Déployer Windows 7 | Améliorer les performances de Windows 7
    Friday, November 5, 2010 1:49 AM
  • Open Windows Explorer, navigate to User Name\Downloads folder, right-click and select restore previous version.

    You borked the folder somehow, so why don't you provide the information about what you did to your system? Then it can get corrected.

    If you did perform a system restore and it didn't work, the folder has been borked for a while. Seems like PBCK.

    Friday, November 5, 2010 2:10 AM
  • A friend of mine let me know this link at the first time when I got this problem and I did what they guided but nothing worked. I tried "folder" and "directory" association fix but none of them worked unfortunately.
    Friday, November 5, 2010 2:22 AM
  • I also tried to do this but it showed like "there is no previous version". I didn't do anything to my system. I'd like to see the pdf file in the "downloads" folder but noticed that the folder icon was broken and it can't open. When I tried to do a system restore, it said like there was no time point to set the system back.

    Friday, November 5, 2010 2:26 AM
  • Old subject....

    Start -> Run (or Windows Key + "R"). Type in "regedit".  Go to HKEY_CLASSES_ROOT\Folder\shell\explore\command

    Under this key you should have a string named "DelegateExecute" with a value of "{11dbb47c-a525-400b-9e80-a54615a090c0}".

    Voila! All done. This was a fix I had to run after having a Vista Security infection on a Windows 7 computer. haha.

    Tuesday, April 12, 2011 12:38 AM