locked
Sequenced App does not load any shortcuts? RRS feed

  • Question

  • Hello

    I have an issue when I sequence any application, none of the shortcuts I select or add during the sequencing phase show up on the client when the application is loaded in.

    I am using a test environment with 1 windows 7 Vm for the sequencer 4.6, and 1 windows 7 vm for the client 4.6. I have set the paths in the registry correct, and my applications load up fine. I can also create a new shortcut for the application in the client, and that works fine. It just wont carry over the shortcuts I make in the sequencing stage.

    I have tried looking into the client log file, and didn't see any errors. I have tried re-installing the client and sequencer.

    I follow best practice with 8.3 naming, and save to Q: drive.

    Im really at a loss as to what to do next?

    Tuesday, May 22, 2012 7:26 AM

All replies

  • Hello,

    What shortcuts are defined in the .OSD-file?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, May 22, 2012 7:35 AM
  • Hi,

    can you check on the management server console if the OSD and ICON path´s of your sequenced app´s are pointing to the UNC path of your "Content" folder?

    Tuesday, May 22, 2012 9:23 AM
  • You may need to enable verbose logging on the client to see why the shortcuts are not being created. Have you also confirmed that the application is being created on the App-V client (via the client MMC).


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Tuesday, May 22, 2012 10:47 AM
    Moderator
  • Thankyou for your quick responses.

    @znack - This is the shortcut info from the .OSD file.

    <MGMT_SHORTCUTLIST>
            <SHORTCUT LOCATION="%CSIDL_STARTMENU%" FILENAME="Mozilla Firefox.lnk" OVERRIDDEN="TRUE" DISPLAY="Mozilla Firefox" ICON="%SFT_MIME_SOURCE%/Firefox Icons/Mozilla Firefox 12.01.1001 x86.ico"/>
        </MGMT_SHORTCUTLIST>

    @kirryto - I am only testing the apps with a local streaming server, therefore I have no App-v server. This has not been a problem in the past.

    @aaron - I turned on verbose logging, and could see that the variable locations for my shortcuts were successfully converted to the physical locations of where they should be. After that I see no other mention of the shortcuts in the log file.

    Tuesday, May 22, 2012 10:39 PM
  • When you open the APP-V Client and go to Applications can you actually see Mozilla Firefox in there?

    Have you tried setting OVERRIDDEN to FALSE?


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Tuesday, May 22, 2012 10:52 PM
  • Hi Rorymon,

    Yes the application loads into the client perfect. And if i manually create a shortcut from the client, it works also. My user settings that I captured in the sequence also apply, like setting the homepage for example.

    I will try setting OVERRIDDEN to FALSE.

    Thanks

    EDIT: no luck with the OVERRIDDEN setting to FALSE
    • Edited by binga30 Tuesday, May 22, 2012 11:38 PM
    Tuesday, May 22, 2012 10:57 PM
  • If it helps this problem occurs with every application that i sequence, so I am beginning to think that maybe my client settings are preventing this. Which settings in particular would effect this?

    I have tried using another fresh VM, and I also use the Administrator account so permissions should not be an issue.

    Wednesday, May 23, 2012 10:27 PM
  • So none of your applications are appearing on your machine?

    Do you have enabled checked on your applications from within the Management Console? Also in the Console, if you go to the shortcuts tab is anything checked and/or populated?


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, May 23, 2012 10:40 PM
  • The applications do appear on the client machine, I add them in manually as I am using a local test environment. Its just the shortcuts do not appear when I add in the applications.
    Wednesday, May 23, 2012 11:09 PM
  • Hello,

    You are probably not "adding" them properly - but then again, I don't know how your doing that. There are quite a few ways to deploy an application - including;

    command-line interface

    MSI

    App-V Management Infrastructure

    SCCM and App-V integration

    Depending on which method - there are a number of things that might go wrong. The description you gave on what type of infrastructure you gave was extremely vague and does not clarify how you use it - and raised more questions on my part than answered it.


    Nicke Källén | The Knack| Twitter: @Znackattack


    • Edited by znack Saturday, May 26, 2012 9:56 AM
    Saturday, May 26, 2012 9:54 AM
  • Hi znack,

    Appreciate your patience. I am learning application virtualization and I am using app-v sequencer 4.6 and client 4.6 to stream in standalone mode. I have each installed on a windows 7 x86 virtual machine each with 1gb ram.

    I am sequencing some basic applications like firefox, bittorrent, notepad++ just for practice. I run through the sequencer and install a start menu shortcut as part of the install. The start menu shortcut appears on the sequencer. I save out my package to a shared folder.

    I import the application to the client. I load the application, it reaches 100%, but my shortcut does not appear in the start menu. I have tried desktop and quick launch shortcuts also, and they do not load up when the application loads. I can however create a manual shortcut via the app-v client, right click add shortcut method.

    I have tried generating the msi as part of the sequence, and preloading from that, didnt help.

    I have all firewalls and updates turned off, windows defender is off.

    You can see the <SHORTCUT> properties in the osd file. It just wont create them upon loading an application. Also you can see the Icon files in the correct folder.

    Im not sure how else to describe the situation and what information is useful or not. Just looking for an answer as to why this is happening.

    Saturday, May 26, 2012 11:28 PM
  • Hello,
    I am sorry - I am more confused. You are combining things here which I don't understand - you are running it in standalone mode, and adding the package - yet no explanation of how you do this?

    As a general recommendation for running App-V in standalone mode - there is the the Trial Guide which explains this scenario in great detail.

    http://download.microsoft.com/download/F/7/8/F784A197-73BE-48FF-83DA-4102C05A6D44/App-V/App-V%204.6%20SP1%20Trial%20Guide.docx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, May 27, 2012 8:33 AM
  • Appreciate your patience. I am learning application virtualization and I am using app-v sequencer 4.6 and client 4.6 to stream in standalone mode. I have each installed on a windows 7 x86 virtual machine each with 1gb ram.

    ...

    I import the application to the client. I load the application, it reaches 100%, but my shortcut does not appear in the start menu. I have tried desktop and quick launch shortcuts also, and they do not load up when the application loads. I can however create a manual shortcut via the app-v client, right click add shortcut method.

    How are you importing and publishing the applications on the client? What exact commands are you using?


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Sunday, May 27, 2012 12:06 PM
    Moderator
  • I import the application on the client from a network share. IE- I open App-V client, right click on applications, new application.

    I find the OSD file on the network share and import. Then i right click on the application in the client, and select Load.

    When this finishes loading to 100% I check the start menu for the expected shortcut. Its not created.

    But when I right click the application in the client, and select add shortcut, this will create my shortcut.

    I dont use any command line stuff, this is the way I was shown how to test without an app-v server. It has worked in the past, but I am learning this again after a 12 month break. If this is not the right method I would like to know the correct method of how to test an application without needing an app-v server.

    Thankyou both znack and aaron


    • Edited by binga30 Sunday, May 27, 2012 11:13 PM
    Sunday, May 27, 2012 11:12 PM
  • I would suggest adding the application using the SFTMIME ADD PACKAGE command or by copying the package locally and installing via the MSI file. 

    See this article for the command line method: How to Add a Package by Using the Command Line



    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    • Proposed as answer by Sanjuktadas Thursday, October 11, 2012 6:22 AM
    • Unproposed as answer by Sanjuktadas Thursday, October 11, 2012 6:22 AM
    Monday, May 28, 2012 8:10 AM
    Moderator
  • Have you installed the client properly in your machine.

    I meant to say have you passed SMFN file as parameter while installing the client.If you haven't shortcut wont be visible

    Thursday, October 11, 2012 6:24 AM