locked
Window 7 Enterprise Devices and Printers Window Does Not Finish Loading RRS feed

  • Question

  • I'm running Windows 7 Enterprise SP1 and my Devices and Printers window never finishes loading. I've tried the "Bluetooth Service" fix, the "SFC /SCANNOW" fix, and everything else I could find on the net without any success. I have a feeling some background process is causing the window to hang. Is there some way to analyze this?

    Friday, August 12, 2011 2:13 PM

Answers

  • Ok. You wouldnt happen to have any disk encryption software enabled would you? I've heard of scenarios where it might cause this.

     

    Might be worth trying to temporarily uninstall that and see if the behavior changes.


    Michael. [MSFT]
    Monday, August 15, 2011 8:11 PM
  • Michael,

    I have McAfee Endpoint encryption and McAfee Removable Media encryption installed. I tried removing the McAfee Removable Media Encryption component first and that seemed to allow me to view the Devices and Printers folder after rebooting my system. There most be a compatibility issue. I don't use removable media on a regular basis so I believe I can live without this extra protection until McAfee releases a fix. This seems like a bug.

    Thank you for your guidance.

    ~Aaron

    • Marked as answer by Miya Yao Tuesday, August 16, 2011 7:31 AM
    Monday, August 15, 2011 8:23 PM

All replies

  •  

    Hi Aaron,

     

    Lets try a couple of a things.

    1. Disable Bluetooth in the BIOS and make sure the Bluetooth service is started and set to automatic then check the behavior of "Devices and Printers"

    2. Stop the spooler and then see if you are able to get in to "Devices and Printers".

     

    Please let me know what your findings are.

    Thank you,

    Michael.

    Saturday, August 13, 2011 12:02 AM
  • Michael,

    Thank you for your response. Sadly, neither of these suggestions produced favorable results. The "Devices and Printers" window still does not load normally.

    ~Aaron

    Monday, August 15, 2011 7:51 PM
  •  

    Hi Aaron,

     

    I am sorry to hear that. When you have a moment, temporarily uninstall your antivirus software and let us know if that changed the behavior.

     

    Thanks,

    Michael.


    Michael. [MSFT]
    Monday, August 15, 2011 7:52 PM
  • Michael,

    I tried uninstalling McAfee temporarily but it didn't make a difference.

    ~Aaron

    Monday, August 15, 2011 7:55 PM
  • Ok. You wouldnt happen to have any disk encryption software enabled would you? I've heard of scenarios where it might cause this.

     

    Might be worth trying to temporarily uninstall that and see if the behavior changes.


    Michael. [MSFT]
    Monday, August 15, 2011 8:11 PM
  • Michael,

    I have McAfee Endpoint encryption and McAfee Removable Media encryption installed. I tried removing the McAfee Removable Media Encryption component first and that seemed to allow me to view the Devices and Printers folder after rebooting my system. There most be a compatibility issue. I don't use removable media on a regular basis so I believe I can live without this extra protection until McAfee releases a fix. This seems like a bug.

    Thank you for your guidance.

    ~Aaron

    • Marked as answer by Miya Yao Tuesday, August 16, 2011 7:31 AM
    Monday, August 15, 2011 8:23 PM