locked
Transfer Files (7 to Xp) RRS feed

  • Question

  • Hey. 

    I have 2 computers at my house. they are actually located right next to each other. they are both connected to the internet via wireless. 

    I want to transfer files (sized 180 Mb to 400 Mb) from one to the other. Right now I am just using my "home network" thingy, and i go to NETWORK, and find the XP computer, and just PASTE the file from my computer (WIN7) to the xp. BUT IT TAKES SO LONG - 10 minutes for the 180 Mb files. 

    I was told there is a LOT quicker way. something to do with the router? 

    Can anyone help me? i would really appreciate it. 

    THANK YOU!

    PS
    i don't know much about computer, so please keep it simple (-:
    thanks again
    Saturday, November 28, 2009 5:26 AM

Answers

  • I found it: The problem is how win 7 uses the DFS-R shares. If you are using DFS-R rep´lication between two or more 2K3 servers you have to switch off all DFS-shares except one.
    You can use only one share! So you have no failover-system as usual in 2K3 server!
    Thats a problem of win 7 not a feature.
    The unexpectet network error 0x8007003B disappears now.
    For getting a very fast and stable network you have to check the following:
    - snb signing between server and clients pls look at www.grurili.de for help
    - toe ist enabled
    - if using managed switch and jumbo frame e.g. is switched on, use on all clients and server the same settings
    - if using managed switchand automatic speed is switched on, use the same setting on server and clients
    - netbios over TCPIP - IPv6 can be switched on
    - check your dns server(s) - check your DHCP for correct settings
    - check your gateway settings
    - have a look that all updates, firmware and driver are up to date thats all, then it should work.
    I have to wait for hotfix for DFS in win 7.
    greetings and join the day Thorsten
    P.S.: Thanks to Nicholas for his work here and Marc and his work on grurili.de
    • Proposed as answer by Thorsten_KS Friday, December 11, 2009 6:05 AM
    • Marked as answer by Nicholas Li Wednesday, December 16, 2009 7:17 AM
    Friday, December 11, 2009 6:05 AM

All replies

  • Does your wireless router have RJ45 ports for wired connections? if so, just get standard network cables, plug them in and have at it. It's at this point acting as a hub anyways.
    MCSE, MCSA, MCDST
    Saturday, November 28, 2009 5:51 AM
  • I have the same problem in an w2k3 domain. Alle computer are in cabled version. Thos who use win XP are fast, those 2 with win 7 pro are very slow. Maximum 1 mBit/sec transfer rate. I have switches Autotuning off netsh interface tcp set global autotuninglevel=disabled  but it doesn't help. Any more ideeas?
    Thank you,
    best regards Thorsten
    Saturday, November 28, 2009 2:01 PM
  • Hi,

     

    Based on my research, please try the following:

     

    1.    Boot the computers to Safe Mode with networking or Clean Boot to check if the issue persists.

     

    To perform a Clean Boot, please refer to:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

     

    2.    Disable SNP in Windows 7 by setting Registry as following:

    Note: Please perform a full-system backup first.

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

    EnableTCPChimney=dword:00000000

    EnableTCPA=dword:00000000

    EnableRSS=dword:00000000

     

    3.    Run the following commands one by one in an elevated command prompt in Windows 7:

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Thursday, December 3, 2009 10:30 AM
  • Hello Nicholas,

    thank you for reply and your idea.
    Sorry, but it doens't help.
    If i copy a file from Server2k3 to W7-64 machine, i get this fault:
    Copy 0x8007003B: unexpected network fault
    Its a file about 2,25KB
    The copy job was about 600MB with a lot of files.

    Copying files from win7 to W2k3 serverR2 everything is fine, 1,3 GB less than 1 minute.

    All XP-SP3 machines working fine in both directions.
    I have not checked to copy files from XP to win7 and back, but i will do and give reply.

    The win 7 machine is a Dell optiplex 780 brandnew and was  first with vista SP2 64 working.
    There were no problems. So I think it must be a bug or a feature in win7 which is not well working with Server 2003 R2

    There are a lot of people having the same problem.
    Any ideas what else to do?

    Thank you for all, Thorsten
    Sunday, December 6, 2009 1:07 AM
  • Hi Thorsten,

     

    Please enable NetBIOS over TCP/IP on both computers:

     

    1.    Enable NetBIOS over TCP/IP in Windows 7:

     

    1)   Go to “Control Panel\Network and Internet\Network Connections”.

    2)   Right-Click on the connection and choose Properties.

    3)   Click “Internet Protocol (TCP/IP) Version 4” in the list.

    4)   Click Properties, and then click Advanced.

    5)   On the Advanced TCP/IP settings windows, go to “WINS” tab.

    6)   Under NetBIOS setting, click “Enable NetBIOS over TCP/IP”, and then click OK.

     

    2.    If the issue persists, please also enable NetBIOS over TCP/IP in Windows Server 2003 and try again.

     

    Thanks.


    Nicholas Li - MSFT
    Tuesday, December 8, 2009 8:55 AM
  • Hey Nicholas,

    now i can give you more spec. Information of the problem.
    In my case, the problem is not
    - SNB on or off
    - TOE enabled or disabled
    - netbios over DHCP or TCPIP

    The problem seems to be the DFS and replication between our two 2K3 R2 server.
    First time of vista there was the same problem. You can google this with 0x8007003B unexpected network error
    But i found no solution.

    I can copy files when i am using:

    \\IPadressOfOneserver\administrativeShare$    everything is fine and fast
    \\DNSnameOfOneServer\administrativeShare$   everything is fast and fine

    If i am using the shares over DFS copying /calculating is starting, and latest stops responding when i give a klick on one another file of the share.
    Got me?
    I need the replication between the servers, so what to do? Any Idea?
    Greetings Thorsten
    Tuesday, December 8, 2009 3:30 PM
  • I found it: The problem is how win 7 uses the DFS-R shares. If you are using DFS-R rep´lication between two or more 2K3 servers you have to switch off all DFS-shares except one.
    You can use only one share! So you have no failover-system as usual in 2K3 server!
    Thats a problem of win 7 not a feature.
    The unexpectet network error 0x8007003B disappears now.
    For getting a very fast and stable network you have to check the following:
    - snb signing between server and clients pls look at www.grurili.de for help
    - toe ist enabled
    - if using managed switch and jumbo frame e.g. is switched on, use on all clients and server the same settings
    - if using managed switchand automatic speed is switched on, use the same setting on server and clients
    - netbios over TCPIP - IPv6 can be switched on
    - check your dns server(s) - check your DHCP for correct settings
    - check your gateway settings
    - have a look that all updates, firmware and driver are up to date thats all, then it should work.
    I have to wait for hotfix for DFS in win 7.
    greetings and join the day Thorsten
    P.S.: Thanks to Nicholas for his work here and Marc and his work on grurili.de
    • Proposed as answer by Thorsten_KS Friday, December 11, 2009 6:05 AM
    • Marked as answer by Nicholas Li Wednesday, December 16, 2009 7:17 AM
    Friday, December 11, 2009 6:05 AM
  • Hi,

     

    I am glad to know it worked in the end. I really appreciate your efforts. I hope what you experienced and what you shared with us will be good references for other users who meet the similar issues.

     

    In the future, if you experience any issues regarding our products or if you have some feedbacks, you are also welcome to post a new thread in our forum. It is always our pleasure to be of assistance.

     

    Thanks again! Have a nice day!


    Nicholas Li - MSFT
    Wednesday, December 16, 2009 7:23 AM