none
Windows 10 not recognizing ethernet cable? RRS feed

  • Question

  • Whenever I use my Ethernet cable on Windows 10 64bit The computer fails to acknowledge that it is there. It is not a faulty cable, I have switched from Windows 8.1 to 10 back to 8.1 and back to 10 and the cable works fine when used on windows 8.1 and for some reason doesn't work on 10. I have tried the IP reset and the computer reset and nothing has fixed the issue. Any help would be great.
    • Edited by Jordyn D Sunday, August 16, 2015 3:38 AM
    Sunday, August 16, 2015 3:38 AM

Answers

  • If Using the realtek PCIe GBE family NIC's Try this it worked for my NIC no issues now

    http://drivers.softpedia.com/get/NETWORK-CARD/REALTEK/Realtek-PCIe-GBE-Family-Controller-LAN-Driver-1015052015-for-Windows-10-64-bit.shtml

    Monday, August 17, 2015 10:58 PM

All replies

  • I am in the same situation. There are multiple posts on the internet, but none work. Worked fine under 8.1

    • Upgraded Driver
    • Down graded driver
    • use MS version
    • Used Realtek versions

    All Failed

    Sunday, August 16, 2015 3:45 AM
  • Same issue Here seems to be a realtek thing as all the post and pages i read with same issue seem to have that in common .I could be wrong but hope not.
    • Proposed as answer by Shaggy2061 Monday, August 17, 2015 10:58 PM
    • Unproposed as answer by Shaggy2061 Monday, August 17, 2015 10:58 PM
    Monday, August 17, 2015 7:11 AM
  • If Using the realtek PCIe GBE family NIC's Try this it worked for my NIC no issues now

    http://drivers.softpedia.com/get/NETWORK-CARD/REALTEK/Realtek-PCIe-GBE-Family-Controller-LAN-Driver-1015052015-for-Windows-10-64-bit.shtml

    Monday, August 17, 2015 10:58 PM