none
Database connection Error in Dashboard Designer RRS feed

  • Question

  •  

    Hello,

     

    I am trying to create a sample Analytic Report in Dashboard Designer and then publish it to a Dashboard. Before starting itself I am facing basic issues Sad.

     

    I have

     

    Win XP with IIS 5.1

    PPS 2007

    SQL Server 2005 and

    I am using Adventure Works DW Database.

     

    When I try to create a datasource in Dashboard designer, I gave my local server name and on click of the Database pulldown, I get the following error message "Database Connection Failed. Please contact an administrator".

     

    I am able to see the database through SSMS and the database is created in Analysis Services.

     

    Please advice if am missing anything

     

    Thanks in advance

    Raj.

     

     

     

    Tuesday, December 9, 2008 1:13 AM

Answers

  • Hi Raj,

     

    I'm sorry, I should have noticed that you have IIS 5.1. The error message you're now receiving basically means that the ASPNET account does not have read access to the database you are trying to access. Make doubly-sure this account is given read access to the cube. PPS is trying to connect to the DB using this account, to confirm what is happening trace the DB calls that are happening and see "who" they are trying to execute as.

     

    Cheers,

    Nick

    Wednesday, December 10, 2008 1:28 AM

All replies

  • Hi Raj,

     

    Hopefully the contents of this post will help: http://nickbarclay.blogspot.com/2007/11/pps-data-source-connection-problems.html

     

    Cheers,

    Nick

    Tuesday, December 9, 2008 2:02 AM
  • Hi Nick,

    Thanks for your blog.

     

    Since I use XP OS, I followed the steps provided by Phil to add a new role ASPNET in my system. I dont know where to look for Application Pool details in IIS. I just navigated to IIS in control panel and checked the properties of web.config file etc. But I could not find the same screenshot provided by you in the blog. Please let me know if I still need to check the things provided by you in the blog.

     

    After reading your blog, I also checked couple of things. When I configured Monitoring Server in my machine, it did not ask for default TCP Port in "Web Site" step. Also, it gave me a message SSL is not configured in this machine. I just skipped that part and continued with my monitoring server configuration. In addition,  I did not see "Application Pool Identity" and "Web Parts" step.

     

    Note: Since I have XP OS, I did not install Share Point Server 2007 and mine is a stand alone configuration

     

    When I try to click on  Monitoring Central in Start Menu -> PPS 2007-> I get the option to RUN or GO Dashboard Designer, but the URL is not having the Default Port Number 40000. Is this OK ?

     

    Simillarly, when I go to Options -> Server and click connect in Dashboard designer, I get the error message "Unable to connect to server"

     

    Looks like something is messed up in my configuration. Please advice.

     

    Thanks in advance

    Raj

     

    Tuesday, December 9, 2008 8:37 AM
  •  Rajpr wrote:

    But I could not find the same screenshot provided by you in the blog. Please let me know if I still need to check the things provided by you in the blog.

    In IIS right-click the relevant application pool and select the Identity tab in the dialog that comes up

     

     Rajpr wrote:

    Note: Since I have XP OS, I did not install Share Point Server 2007 and mine is a stand alone configuration

    That's fine, you don't need to have WSS installed for the standalone. Don't worry about the web parts


     Rajpr wrote:

    When I configured Monitoring Server in my machine, it did not ask for default TCP Port in "Web Site" step. Also, it gave me a message SSL is not configured in this machine.

    It was there, you may have missed it. Don't worry about SSL and the default port, this is not important to what you're trying to achieve

     

     Rajpr wrote:

    I did not see "Application Pool Identity" and "Web Parts" step.

    Application Pool-based security is configured automatically by the config wizard. All you're asked to do in this step is to choose which account the app pool is to use as an identity. The default is NT AUTHORITY - NETWORK SERVICE

     

     Rajpr wrote:

    Simillarly, when I go to Options -> Server and click connect in Dashboard designer, I get the error message "Unable to connect to server"

    Raj I'm can't be sure what this problem could be, there could be a number of different causes. Do you have .NET 3.5 installed on the system?

    Tuesday, December 9, 2008 1:35 PM
  • Hi Nick,

     

     

     Rajpr wrote:

    When I configured Monitoring Server in my machine, it did not ask for default TCP Port in "Web Site" step. Also, it gave me a message SSL is not configured in this machine.

    It was there, you may have missed it. Don't worry about SSL and the default port, this is not important to what you're trying to achieve

     

    [RAJ]I wish I could paste my screenshot. I dont see the TCP Port at all in website step and its a fact, as I am able to access the monitoring central without the port number 40000 i.e. http://<<Servername>>/central. and it shows up the Monitoring Central with  "Run" and "GO" Page

    I did not miss it Smile

     

     Rajpr wrote:

    I did not see "Application Pool Identity" and "Web Parts" step.

    Application Pool-based security is configured automatically by the config wizard. All you're asked to do in this step is to choose which account the app pool is to use as an identity. The default is NT AUTHORITY - NETWORK SERVICE

     

    [RAJ] I dont see this option at all in Monitoring Server Configuration. I tried to uninstall and install Monitoring Server. Still, I dont see these steps during configuration.

     

     Rajpr wrote:

    Simillarly, when I go to Options -> Server and click connect in Dashboard designer, I get the error message "Unable to connect to server"

    Raj I'm can't be sure what this problem could be, there could be a number of different causes. Do you have .NET 3.5 installed on the system?

     

    [RAJ] Yes, I do have Microsoft.NET 3.5 Framework in my system. Again the URL in dashboard designer is without the port number. When I copy paste it in a browser, I am able to view the details.

     

    [RAJ] I uninstalled monitoring server. I have not yet checked the application pool in IIS.

     

    Thanks in advance.

    Tuesday, December 9, 2008 9:44 PM
  • I have an update!

     

    I uninstalled PPS Monitoring server and installed again. Again, I dont see the default port number 40,000 in TCP Port and am able to access the monitoring central without the 40000.

     

    Another update is I am able to connect to the server in Dashboard designer, note, I dont see the default port in the URL, still am able to connect.

     

    One more additional point is I use XP with IIS 5.1. browsing the web, I came to know that there is no "application pool" in iis 5.1. I followed Phils Blog to add ASPNET role in my Analysis services. Now, I am seeing this error again

     

    ""The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct""

     

    Any thoughts/suggestions ? and is it a problem if I dont see 40,000 default port in PPS ?

     

    Thank

    Tuesday, December 9, 2008 10:18 PM
  • Hi Raj,

     

    I'm sorry, I should have noticed that you have IIS 5.1. The error message you're now receiving basically means that the ASPNET account does not have read access to the database you are trying to access. Make doubly-sure this account is given read access to the cube. PPS is trying to connect to the DB using this account, to confirm what is happening trace the DB calls that are happening and see "who" they are trying to execute as.

     

    Cheers,

    Nick

    Wednesday, December 10, 2008 1:28 AM
  • Thank you so much Nick. I just re-installed monitoring server and re-configured it. I was able to successfully create a sample report and deploy in dashboard.

     

    Thanks a lot for you help !!

     

    Regards

    Raj

     

    Wednesday, December 10, 2008 6:24 AM
  • No problem Raj, glad I could help. If you get the chance could you please mark posts that you found helpful.

     

    Cheers,

    Nick

     

    Wednesday, December 10, 2008 5:11 PM